gdb: update to 12.1
authorNick Hainke <vincent@systemli.org>
Sat, 27 Aug 2022 17:53:17 +0000 (19:53 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 2 Sep 2022 21:13:53 +0000 (23:13 +0200)
Release Notes:
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=blob_plain;f=gdb/NEWS;hb=gdb-12.1-release

Refresh patches:
- 110-shared_libgcc.patch
- 130-gdb-ctrl-c.patch

Signed-off-by: Nick Hainke <vincent@systemli.org>
package/devel/gdb/Makefile
package/devel/gdb/patches/110-shared_libgcc.patch
package/devel/gdb/patches/130-gdb-ctrl-c.patch

index dd1df7af8551f9f2c177b8f06b090c446c78e2a1..7acf26d60b9678d6ea7a7da3934d75eaef3ec7f1 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=11.2
+PKG_VERSION:=12.1
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=1497c36a71881b8671a9a84a0ee40faab788ca30d7ba19d8463c3cc787152e32
+PKG_HASH:=0e1793bf8f2b54d53f46dea84ccfd446f48f81b297b28c4f7fc017b818d69fed
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
index 3979ccd26ba7cd8afd6eea3eba576a1f8c23c557..f1602bc69506e7129a885894e2b39d789b933230 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1300,13 +1300,13 @@ if test -z "$LD"; then
+@@ -1314,13 +1314,13 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -17,7 +17,7 @@
    AC_LANG_PUSH(C++)
    AC_LINK_IFELSE([AC_LANG_SOURCE([
  #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
-@@ -1705,7 +1705,7 @@ AC_ARG_WITH(stage1-ldflags,
+@@ -1719,7 +1719,7 @@ AC_ARG_WITH(stage1-ldflags,
   # trust that they are doing what they want.
   if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
       -a "$have_static_libs" = yes; then
@@ -26,7 +26,7 @@
   fi])
  AC_SUBST(stage1_ldflags)
  
-@@ -1734,7 +1734,7 @@ AC_ARG_WITH(boot-ldflags,
+@@ -1748,7 +1748,7 @@ AC_ARG_WITH(boot-ldflags,
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
@@ -37,7 +37,7 @@
  
 --- a/configure
 +++ b/configure
-@@ -5257,14 +5257,14 @@ if test -z "$LD"; then
+@@ -5275,14 +5275,14 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -56,7 +56,7 @@
    ac_ext=cpp
  ac_cpp='$CXXCPP $CPPFLAGS'
  ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -6149,7 +6149,7 @@ else
+@@ -6167,7 +6167,7 @@ else
   # trust that they are doing what they want.
   if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
       -a "$have_static_libs" = yes; then
@@ -65,7 +65,7 @@
   fi
  fi
  
-@@ -6185,7 +6185,7 @@ else
+@@ -6203,7 +6203,7 @@ else
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
index 72b7273434d20eb525460539aec4c8c53f1998d1..f793a71cae0222e5abe6d1e4108f9147ef701e51 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
 
 --- a/gdbserver/linux-low.cc
 +++ b/gdbserver/linux-low.cc
-@@ -5733,7 +5733,7 @@ linux_process_target::request_interrupt
+@@ -5496,7 +5496,7 @@ linux_process_target::request_interrupt
  {
    /* Send a SIGINT to the process group.  This acts just like the user
       typed a ^C on the controlling terminal.  */