e2fsprogs: fix compilation with musl 1.2.4
authorTianling Shen <cnsztl@immortalwrt.org>
Tue, 16 May 2023 07:49:08 +0000 (15:49 +0800)
committerPetr Štetiar <ynezz@true.cz>
Tue, 16 May 2023 14:33:20 +0000 (16:33 +0200)
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces and
autotools failed to check the lseek64 function.

Force enable ac_cv_func_lseek64 to workaround it.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
package/utils/e2fsprogs/Makefile

index 9437947ab6949541324ac3fcf286e23dd2e935d9..42c297152941e38bd5f7f09568abbcf66dfb7ad8 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
 PKG_VERSION:=1.47.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/tytso/e2fsprogs/v$(PKG_VERSION)/
@@ -156,6 +156,10 @@ CONFIGURE_ARGS += \
        --disable-rpath         \
        --disable-fuse2fs
 
+ifneq ($(CONFIG_USE_MUSL),)
+  CONFIGURE_VARS += ac_cv_func_lseek64=yes
+endif
+
 define Build/Prepare
        $(call Build/Prepare/Default)
        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/config/