uboot-imx6: rename to 'uboot-imx'
authorPiotr Dymacz <pepe2k@gmail.com>
Sun, 28 Mar 2021 16:51:58 +0000 (18:51 +0200)
committerPiotr Dymacz <pepe2k@gmail.com>
Wed, 3 Nov 2021 11:45:40 +0000 (12:45 +0100)
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
package/boot/uboot-imx/Makefile [new file with mode: 0644]
package/boot/uboot-imx/patches/0001-apalis_imx6_defconfig-enable-some-useful-commands.patch [new file with mode: 0644]
package/boot/uboot-imx/patches/110-mx6cuboxi-mmc-fallback.patch [new file with mode: 0644]
package/boot/uboot-imx/patches/111-mx6cuboxi_defconfig-force-mmc-boot.patch [new file with mode: 0644]
package/boot/uboot-imx6/Makefile [deleted file]
package/boot/uboot-imx6/patches/0001-apalis_imx6_defconfig-enable-some-useful-commands.patch [deleted file]
package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch [deleted file]
package/boot/uboot-imx6/patches/111-mx6cuboxi_defconfig-force-mmc-boot.patch [deleted file]

diff --git a/package/boot/uboot-imx/Makefile b/package/boot/uboot-imx/Makefile
new file mode 100644 (file)
index 0000000..9ca4d55
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2013-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_VERSION:=2020.04
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
+
+include $(INCLUDE_DIR)/u-boot.mk
+include $(INCLUDE_DIR)/package.mk
+
+define U-Boot/Default
+  BUILD_TARGET:=imx
+  UBOOT_IMAGE:=u-boot.imx
+endef
+
+define U-Boot/apalis_imx6
+  NAME:=Toradex Apalis
+  UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
+  UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
+  BUILD_DEVICES:=toradex_apalis
+endef
+
+define U-Boot/mx6cuboxi
+  NAME:=SolidRun Cubox-i boards
+  UBOOT_IMAGE:=SPL u-boot.img
+  UBOOT_MAKE_FLAGS:=SPL u-boot.img
+  BUILD_DEVICES:=solidrun_cubox-i
+endef
+
+define U-Boot/wandboard
+  NAME:=Wandboard Dual Lite/Quad/Solo
+  BUILD_DEVICES:=wandboard_dual
+endef
+
+UBOOT_TARGETS := \
+       apalis_imx6 \
+       mx6cuboxi \
+       wandboard
+
+UBOOT_MAKE_FLAGS += u-boot.imx
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(foreach img,$(UBOOT_IMAGE), \
+               $(CP) $(PKG_BUILD_DIR)/$(img) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(img); \
+       )
+endef
+
+$(eval $(call BuildPackage/U-Boot))
diff --git a/package/boot/uboot-imx/patches/0001-apalis_imx6_defconfig-enable-some-useful-commands.patch b/package/boot/uboot-imx/patches/0001-apalis_imx6_defconfig-enable-some-useful-commands.patch
new file mode 100644 (file)
index 0000000..10ed918
--- /dev/null
@@ -0,0 +1,37 @@
+From 630b39c46b29de1874149c6b2c18c64966a0fabf Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
+Date: Sun, 1 Mar 2020 22:47:31 +0100
+Subject: [PATCH] apalis_imx6_defconfig: enable some useful commands
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+partition table info, EXT4 write support, support for FAT and generic FS
+commands like load/ls that work for multiple FS types.
+
+Signed-off-by: Petr Štetiar <ynezz@true.cz>
+---
+ configs/apalis_imx6_defconfig | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+--- a/configs/apalis_imx6_defconfig
++++ b/configs/apalis_imx6_defconfig
+@@ -44,6 +44,7 @@ CONFIG_CMD_GPIO=y
+ CONFIG_CMD_GPT=y
+ CONFIG_CMD_I2C=y
+ CONFIG_CMD_MMC=y
++CONFIG_CMD_PART=y
+ CONFIG_CMD_USB=y
+ CONFIG_CMD_USB_SDP=y
+ CONFIG_CMD_USB_MASS_STORAGE=y
+@@ -53,6 +54,10 @@ CONFIG_CMD_PMIC=y
+ CONFIG_CMD_REGULATOR=y
+ CONFIG_OF_CONTROL=y
+ CONFIG_DEFAULT_DEVICE_TREE="imx6-apalis"
++CONFIG_CMD_EXT4=y
++CONFIG_CMD_EXT4_WRITE=y
++CONFIG_CMD_FAT=y
++CONFIG_CMD_FS_GENERIC=y
+ CONFIG_ENV_IS_IN_MMC=y
+ CONFIG_SYS_RELOC_GD_ENV_ADDR=y
+ CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG=y
diff --git a/package/boot/uboot-imx/patches/110-mx6cuboxi-mmc-fallback.patch b/package/boot/uboot-imx/patches/110-mx6cuboxi-mmc-fallback.patch
new file mode 100644 (file)
index 0000000..9d490dd
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/board/solidrun/mx6cuboxi/mx6cuboxi.c
++++ b/board/solidrun/mx6cuboxi/mx6cuboxi.c
+@@ -286,6 +286,12 @@ static void setup_iomux_enet(void)
+       gpio_free_list_nodev(&desc, 1);
+ }
++void board_boot_order(u32 *spl_boot_list)
++{
++      spl_boot_list[0] = spl_boot_device();
++      spl_boot_list[1] = BOOT_DEVICE_MMC1;
++}
++
+ int board_phy_config(struct phy_device *phydev)
+ {
+       if (phydev->drv->config)
diff --git a/package/boot/uboot-imx/patches/111-mx6cuboxi_defconfig-force-mmc-boot.patch b/package/boot/uboot-imx/patches/111-mx6cuboxi_defconfig-force-mmc-boot.patch
new file mode 100644 (file)
index 0000000..4c3dc4c
--- /dev/null
@@ -0,0 +1,23 @@
+From 00ad8b42dfe801107db25ead8249cb10afcd0f94 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
+Date: Sun, 1 Mar 2020 22:10:23 +0100
+Subject: [PATCH] mx6cuboxi_defconfig: force mmc boot
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Petr Štetiar <ynezz@true.cz>
+---
+ configs/mx6cuboxi_defconfig | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/configs/mx6cuboxi_defconfig
++++ b/configs/mx6cuboxi_defconfig
+@@ -9,6 +9,7 @@ CONFIG_ENV_SIZE=0x2000
+ CONFIG_ENV_OFFSET=0xFE000
+ CONFIG_DM_GPIO=y
+ CONFIG_SPL_MMC_SUPPORT=y
++CONFIG_SPL_FORCE_MMC_BOOT=y
+ CONFIG_SPL_SERIAL_SUPPORT=y
+ CONFIG_NR_DRAM_BANKS=1
+ CONFIG_SPL=y
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
deleted file mode 100644 (file)
index 6c2297d..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-#
-# Copyright (C) 2013-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_VERSION:=2020.04
-PKG_RELEASE:=$(AUTORELEASE)
-
-PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
-
-include $(INCLUDE_DIR)/u-boot.mk
-include $(INCLUDE_DIR)/package.mk
-
-define U-Boot/Default
-  BUILD_TARGET:=imx6
-  UBOOT_IMAGE:=u-boot.imx
-endef
-
-define U-Boot/apalis_imx6
-  NAME:=Toradex Apalis
-  UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
-  UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
-  BUILD_DEVICES:=toradex_apalis
-endef
-
-define U-Boot/mx6cuboxi
-  NAME:=SolidRun Cubox-i boards
-  UBOOT_IMAGE:=SPL u-boot.img
-  UBOOT_MAKE_FLAGS:=SPL u-boot.img
-  BUILD_DEVICES:=solidrun_cubox-i
-endef
-
-define U-Boot/wandboard
-  NAME:=Wandboard Dual Lite/Quad/Solo
-  BUILD_DEVICES:=wandboard_dual
-endef
-
-UBOOT_TARGETS := \
-       apalis_imx6 \
-       mx6cuboxi \
-       wandboard
-
-UBOOT_MAKE_FLAGS += u-boot.imx
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
-       $(foreach img,$(UBOOT_IMAGE), \
-               $(CP) $(PKG_BUILD_DIR)/$(img) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(img); \
-       )
-endef
-
-$(eval $(call BuildPackage/U-Boot))
diff --git a/package/boot/uboot-imx6/patches/0001-apalis_imx6_defconfig-enable-some-useful-commands.patch b/package/boot/uboot-imx6/patches/0001-apalis_imx6_defconfig-enable-some-useful-commands.patch
deleted file mode 100644 (file)
index 10ed918..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-From 630b39c46b29de1874149c6b2c18c64966a0fabf Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
-Date: Sun, 1 Mar 2020 22:47:31 +0100
-Subject: [PATCH] apalis_imx6_defconfig: enable some useful commands
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-partition table info, EXT4 write support, support for FAT and generic FS
-commands like load/ls that work for multiple FS types.
-
-Signed-off-by: Petr Štetiar <ynezz@true.cz>
----
- configs/apalis_imx6_defconfig | 5 +++++
- 1 file changed, 5 insertions(+)
-
---- a/configs/apalis_imx6_defconfig
-+++ b/configs/apalis_imx6_defconfig
-@@ -44,6 +44,7 @@ CONFIG_CMD_GPIO=y
- CONFIG_CMD_GPT=y
- CONFIG_CMD_I2C=y
- CONFIG_CMD_MMC=y
-+CONFIG_CMD_PART=y
- CONFIG_CMD_USB=y
- CONFIG_CMD_USB_SDP=y
- CONFIG_CMD_USB_MASS_STORAGE=y
-@@ -53,6 +54,10 @@ CONFIG_CMD_PMIC=y
- CONFIG_CMD_REGULATOR=y
- CONFIG_OF_CONTROL=y
- CONFIG_DEFAULT_DEVICE_TREE="imx6-apalis"
-+CONFIG_CMD_EXT4=y
-+CONFIG_CMD_EXT4_WRITE=y
-+CONFIG_CMD_FAT=y
-+CONFIG_CMD_FS_GENERIC=y
- CONFIG_ENV_IS_IN_MMC=y
- CONFIG_SYS_RELOC_GD_ENV_ADDR=y
- CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG=y
diff --git a/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch b/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch
deleted file mode 100644 (file)
index 9d490dd..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/board/solidrun/mx6cuboxi/mx6cuboxi.c
-+++ b/board/solidrun/mx6cuboxi/mx6cuboxi.c
-@@ -286,6 +286,12 @@ static void setup_iomux_enet(void)
-       gpio_free_list_nodev(&desc, 1);
- }
-+void board_boot_order(u32 *spl_boot_list)
-+{
-+      spl_boot_list[0] = spl_boot_device();
-+      spl_boot_list[1] = BOOT_DEVICE_MMC1;
-+}
-+
- int board_phy_config(struct phy_device *phydev)
- {
-       if (phydev->drv->config)
diff --git a/package/boot/uboot-imx6/patches/111-mx6cuboxi_defconfig-force-mmc-boot.patch b/package/boot/uboot-imx6/patches/111-mx6cuboxi_defconfig-force-mmc-boot.patch
deleted file mode 100644 (file)
index 4c3dc4c..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-From 00ad8b42dfe801107db25ead8249cb10afcd0f94 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
-Date: Sun, 1 Mar 2020 22:10:23 +0100
-Subject: [PATCH] mx6cuboxi_defconfig: force mmc boot
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Petr Štetiar <ynezz@true.cz>
----
- configs/mx6cuboxi_defconfig | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/configs/mx6cuboxi_defconfig
-+++ b/configs/mx6cuboxi_defconfig
-@@ -9,6 +9,7 @@ CONFIG_ENV_SIZE=0x2000
- CONFIG_ENV_OFFSET=0xFE000
- CONFIG_DM_GPIO=y
- CONFIG_SPL_MMC_SUPPORT=y
-+CONFIG_SPL_FORCE_MMC_BOOT=y
- CONFIG_SPL_SERIAL_SUPPORT=y
- CONFIG_NR_DRAM_BANKS=1
- CONFIG_SPL=y