treewide: use AUTORELEASE on all uboot-* packages
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 2 Oct 2021 17:03:32 +0000 (19:03 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 2 Oct 2021 19:26:12 +0000 (21:26 +0200)
Nobody ever updates PKG_RELEASE when changing devices or setup in
the various uboot-* packages. Use $(AUTORELEASE) so we still have
proper versioning there.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/boot/uboot-at91/Makefile
package/boot/uboot-fritz4040/Makefile
package/boot/uboot-imx6/Makefile
package/boot/uboot-lantiq/Makefile
package/boot/uboot-mxs/Makefile
package/boot/uboot-omap/Makefile
package/boot/uboot-oxnas/Makefile
package/boot/uboot-ramips/Makefile
package/boot/uboot-rockchip/Makefile
package/boot/uboot-tegra/Makefile

index a8a71239a39889db433c2edbb7cbf796689c0723..06cfcd904573a31aa8b8dd008cc1f6976d969e20 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_VERSION:=linux4sam-2020.04
-PKG_RELEASE:=2
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/linux4sam/u-boot-at91.git
index 21305817656e4062f8b70f7b984584c6371502fc..d7cde938ce6a49227d198b3e91ab86158a445465 100644 (file)
@@ -14,7 +14,7 @@ PKG_SOURCE_VERSION:=f92be9d783b1210c020d5d6129e210a94bb7e290
 PKG_SOURCE_DATE:=2019-10-19
 PKG_MIRROR_HASH:=e40a7f624b1758b276f81c765ef1da568c595b8bd54568b9cceca7d170ebc612
 
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
index ed6074053aab5c949d485867b656461b9a54fa54..6c2297dd815d15d05d12d75821b2f1b8aedc07a4 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_VERSION:=2020.04
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
 
index 55038fdf657fd746b9c66bf4bd501e6510bb6f74..2786f1afdafa23c73f33ada307f17be67c027410 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
 PKG_VERSION:=2013.10
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_HASH:=0d71e62beb952b41ebafb20a7ee4df2f960db64c31b054721ceb79ff14014c55
 
index 2a202dca8f6856f266ad6a3409af5c35af470a87..f4211d3a549ff03b0c08830419d4fcdf83e40676 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_VERSION:=2020.04
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
 
index f66b8d5331f18470b11ecef47f40d69e3ee26e59..d0158a72840b02f7341fc34be005c1b3df86509e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_VERSION:=2020.04
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
 
index daa266ea8cd5f19a93f35a1f79be775b1c6db085..98c6cee8e1e5caf93011fa9a4def0c83a9148e8a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_VERSION:=2014.10
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_HASH:=d3b132a7a9b3f3182b7aad71c2dfbd4fc15bea83e12c76134eb3ffefc07d1c71
 
index 5229f5cd3cccf96764305da93d17c592328f8734..337ea0047951af7ab2bb59fea71feb4af0d0ed1f 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_VERSION:=2020.04
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
 
index ff246b57711bef616ee3e7b8e10aacc4e15c7c30..f419ec6ca7d71f9002cb15a26b3483ca52c45a31 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_VERSION:=2021.07
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_HASH:=312b7eeae44581d1362c3a3f02c28d806647756c82ba8c72241c7cdbe68ba77e
 
index a3d66900db7f65da59d716b1ee727abdbfc755df..582f7be9471c170f9e392644f0b9d7897736443f 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_VERSION := 2020.04
-PKG_RELEASE := 1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_HASH := fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372