fs/cifs: update module dependencies
authorRosen Penev <rosenp@gmail.com>
Thu, 15 Oct 2020 06:03:25 +0000 (23:03 -0700)
committerPetr Štetiar <ynezz@true.cz>
Tue, 22 Dec 2020 17:59:10 +0000 (18:59 +0100)
0fdfef9aa7ee68ddd508aef7c98630cfc054f8d6 upstream removed CIFS_SMB311.
Kernels 4.19 and above do not have it. Currently only kernels 4.19 and
5.4 are in the tree.

The Kconfig file in the kernel has more selection that what is in here.
Add the rest and reorder based on upstream ordering.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/kernel/linux/modules/fs.mk

index 18976a79416b7dbce1b8f0c65f82a3e8444f0bba..d43542b17e5372e232752a34b68f529f75e006f5 100644 (file)
@@ -90,19 +90,22 @@ define KernelPackage/fs-cifs
   KCONFIG:= \
        CONFIG_CIFS \
        CONFIG_CIFS_DFS_UPCALL=n \
-       CONFIG_CIFS_UPCALL=n \
-       CONFIG_CIFS_SMB311=n
+       CONFIG_CIFS_UPCALL=n
   FILES:=$(LINUX_DIR)/fs/cifs/cifs.ko
   AUTOLOAD:=$(call AutoLoad,30,cifs)
   $(call AddDepends/nls)
   DEPENDS+= \
-    +kmod-crypto-arc4 \
-    +kmod-crypto-hmac \
-    +kmod-crypto-md5 \
     +kmod-crypto-md4 \
-    +kmod-crypto-des \
+    +kmod-crypto-md5 \
+    +kmod-crypto-sha256 \
+    +kmod-crypto-sha512 \
+    +kmod-crypto-cmac \
+    +kmod-crypto-hmac \
+    +kmod-crypto-arc4 \
+    +kmod-crypto-aead \
+    +kmod-crypto-ccm \
     +kmod-crypto-ecb \
-    +kmod-crypto-sha256
+    +kmod-crypto-des
 endef
 
 define KernelPackage/fs-cifs/description