ath79: image: extract common part for Fortinet FAP series
authorLech Perczak <lech.perczak@gmail.com>
Wed, 26 Jul 2023 01:01:02 +0000 (03:01 +0200)
committerDavid Bauer <mail@david-bauer.net>
Fri, 3 Nov 2023 22:06:07 +0000 (23:06 +0100)
In preparation for FAP-220-B support, extract the common part of image
recipe for FAP-221-B.

Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
target/linux/ath79/image/generic.mk

index 59cc3c5a2b3b842eefffa701b19add026f66a9a6..d8ee3192c08c5290eb233f9966e34a7a7d03a8ae 100644 (file)
@@ -1532,12 +1532,9 @@ define Device/extreme-networks_ws-ap3805i
 endef
 TARGET_DEVICES += extreme-networks_ws-ap3805i
 
-define Device/fortinet_fap-221-b
+define Device/fortinet_fap_common
   $(Device/senao_loader_okli)
-  SOC := ar9344
   DEVICE_VENDOR := Fortinet
-  DEVICE_MODEL := FAP-221-B
-  FACTORY_IMG_NAME := FP221B-9.99-AP-build999-999999-patch99
   IMAGE_SIZE := 9216k
   LOADER_FLASH_OFFS := 0x040000
   IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
@@ -1546,6 +1543,13 @@ define Device/fortinet_fap-221-b
        append-loader-okli-uimage $(1) | pad-to 10944k | \
        gzip-filename $$$$(FACTORY_IMG_NAME)
 endef
+
+define Device/fortinet_fap-221-b
+  $(Device/fortinet_fap_common)
+  SOC := ar9344
+  DEVICE_MODEL := FAP-221-B
+  FACTORY_IMG_NAME := FP221B-9.99-AP-build999-999999-patch99
+endef
 TARGET_DEVICES += fortinet_fap-221-b
 
 define Device/glinet_6408