ar71xx/mikrotik: use ath10k-ct-smallbuffers for 64 MiB devices
authorThomas Nixon <tom@tomn.co.uk>
Sun, 5 Jan 2020 21:38:36 +0000 (21:38 +0000)
committerJohn Crispin <john@phrozen.org>
Wed, 15 Jan 2020 22:15:19 +0000 (23:15 +0100)
This image is only needed on one device (wAP AC); since this target is
going to be removed anyway it doesn't make sense to add an extra "low
RAM" image.

Fixes OOM issues on RouterBoard wAP AC.

Signed-off-by: Thomas Nixon <tom@tomn.co.uk>
target/linux/ar71xx/image/mikrotik.mk

index 91b11f3c7f125e65e19444544049f60332a918f6..dbbccb1c3fc216b33fe96aaa499041f374b73202 100644 (file)
@@ -55,7 +55,7 @@ TARGET_DEVICES += rb-nor-flash-16M
 define Device/rb-nor-flash-16M-ac
   $(Device/rb-nor-flash-16M)
   DEVICE_TITLE := MikroTik RouterBoard (16 MB SPI NOR, 802.11ac)
-  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct ath10k-firmware-qca9887-ct kmod-usb-ehci
+  DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct ath10k-firmware-qca9887-ct kmod-usb-ehci
   SUPPORTED_DEVICES += rb-wapg-5hact2hnd
 endef
 TARGET_DEVICES += rb-nor-flash-16M-ac