kernel: load device-mapper early on boot
authorDaniel Golle <daniel@makrotopia.org>
Sun, 3 Apr 2022 15:19:31 +0000 (16:19 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 3 Apr 2022 15:25:05 +0000 (16:25 +0100)
Previously commit openwrt/packages@3abb7cb ("lvm2: Added script and updated Makefile[...]")
couldn't actually work and allow rootfs_data to be stored on a LVM2 as
the necessary kernel modules had not been loaded at this point.
Fix this by loading device-mapper modules early at boot.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/linux/modules/block.mk

index dfb529db3bc6bb44c6b65893d81731a25dc6ed5a..72f670b6031def76df6641b9b45270577e14194b 100644 (file)
@@ -243,7 +243,7 @@ define KernelPackage/dm
     $(LINUX_DIR)/drivers/md/dm-log.ko \
     $(LINUX_DIR)/drivers/md/dm-mirror.ko \
     $(LINUX_DIR)/drivers/md/dm-region-hash.ko
-  AUTOLOAD:=$(call AutoLoad,30,dm-mod dm-log dm-region-hash dm-mirror dm-crypt)
+  AUTOLOAD:=$(call AutoLoad,30,dm-mod dm-log dm-region-hash dm-mirror dm-crypt,1)
 endef
 
 define KernelPackage/dm/description