autotools: remove specialized version of libtool
authorMichael Pratt <mcpratt@pm.me>
Thu, 16 Mar 2023 01:22:37 +0000 (21:22 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Mar 2023 22:41:50 +0000 (00:41 +0200)
Remove the specialized copy of libtool
which was used for linking to uClibc++, which is now removed.

Also remove references to the deprecated fixup targets
that invoked this specialized libtool, which no package uses.

Ref: 6b2ed6101 ("uclibc++: remove")
Ref: c10515db6 ("re-enable the libtool PKG_BUILD_DEPENDS for PKG_FIXUP")
Ref: 246a5b334 ("More libtool madness")
Signed-off-by: Michael Pratt <mcpratt@pm.me>
include/autotools.mk
tools/libtool/Makefile

index cba36ccd9fa2b83a9a3b64efaad81c0575fe828b..c378efe6f9d89f03ac8ca4e47fbfeb8b5afaea1e 100644 (file)
@@ -124,13 +124,6 @@ ifneq ($(filter libtool-abiver,$(PKG_FIXUP)),)
   Hooks/Configure/Post += set_libtool_abiver
 endif
 
-ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
- ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
-  Hooks/Configure/Pre += autoreconf_target
- endif
-endif
-
 ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
   ifeq ($(filter autoreconf,$(Hooks/Configure/Pre)),)
     Hooks/Configure/Pre += autoreconf_target
@@ -166,12 +159,6 @@ ifneq ($(filter libtool,$(HOST_FIXUP)),)
  endif
 endif
 
-ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
- ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
-  Hooks/HostConfigure/Pre += autoreconf_host
- endif
-endif
-
 ifneq ($(filter autoreconf,$(HOST_FIXUP)),)
   ifeq ($(filter autoreconf,$(Hooks/HostConfigure/Pre)),)
     Hooks/HostConfigure/Pre += autoreconf_host
index 662614229497b245c40f50b232083d002b4b838a..cc9e8a68fbd86f70b96f8bf307bf5db8a57b2c63 100644 (file)
@@ -35,8 +35,6 @@ endef
 define Host/Install
        $(MAKE) -C $(HOST_BUILD_DIR) install
        $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(STAGING_DIR_HOST)/bin/libtool
-       $(CP) $(STAGING_DIR_HOST)/bin/libtool $(STAGING_DIR_HOST)/bin/libtool-ucxx
-       $(SED) 's,-lstdc++,-luClibc++,g' $(STAGING_DIR_HOST)/bin/libtool-ucxx
 endef
 
 define Host/Uninstall