at91: add support for sam9x60-ek board
authorClaudiu Beznea <claudiu.beznea@microchip.com>
Mon, 11 Oct 2021 08:47:26 +0000 (11:47 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 24 Oct 2021 16:52:29 +0000 (18:52 +0200)
Add support for SAM9X60-EK board.

Hardware:
- SoC: SAM9X60
- RAM: Winbond W972GG6KB-25 (2Gbit DDR2)
- NAND Flash: Micron MT29F4G08ABAEA
- QSPI Flash: Microchip SST26VF064B
- EEPROM: Microchip 24AA02E48
- SDMMC: One standard 4-bit SD card interface
- USB: two stacked Type-A connectors with power switches, one micro-B
       USB device
- CAN: 2 interfaces (Microchip MCP2542)
- Ethernet: one 10/100Mbps
- WiFi/BT: one optional WiFi/Bluetooth interface
- Audio: one ClassD port
- Display: one 24-bit LCD interface
- Camera: one 12-bit image sensor interface
- IO: one IO expander (Microchip MCP23008)
- Debug ports: one J-Link-OB + CDC, one JTAG interface
- Leds: one RGB LED
- Buttons: 4 push button switches
- Expansion: one PIO connector, one mikrobus connector
- Power management: two power regulators, two power consumption measurement
                    devices

Flashing:
- follow the procedure at [1]

[1] https://www.linux4sam.org/bin/view/Linux4SAM/Sam9x60EKMainPage#Create_a_SD_card_with_the_demo

Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
package/boot/at91bootstrap/Makefile
package/boot/uboot-at91/Makefile
target/linux/at91/image/sam9x.mk

index 8711acd286bddd95252669e26d5dab1e912f6ee6..2d77f7099721a582f2bf00656fbb7dc7ff7c65d5 100644 (file)
@@ -40,6 +40,18 @@ define AT91Bootstrap/at91sam9x5eksd_uboot
   BUILD_DEVICES:=atmel_at91sam9x25ek atmel_at91sam9x35ek
 endef
 
+define AT91Bootstrap/sam9x60eknf_uboot
+  NAME:=AT91Bootstrap for SAM9X60-EK board (NandFlash)
+  BUILD_SUBTARGET:=sam9x
+  BUILD_DEVICES:=microchip_sam9x60ek
+endef
+
+define AT91Bootstrap/sam9x60eksd_uboot
+  NAME:=AT91Bootstrap for SAM9X60-EK board (SDcard)
+  BUILD_SUBTARGET:=sam9x
+  BUILD_DEVICES:=microchip_sam9x60ek
+endef
+
 define AT91Bootstrap/sama5d2_icpdf_qspi_uboot
   TITLE:=AT91Bootstrap for SAMA5D2 ICP board (QSPI Flash)
   BUILD_SUBTARGET:=sama5
@@ -145,6 +157,8 @@ endef
 AT91BOOTSTRAP_TARGETS := \
        at91sam9x5eknf_uboot \
        at91sam9x5eksd_uboot \
+       sam9x60eknf_uboot \
+       sam9x60eksd_uboot \
        sama5d2_icpdf_qspi_uboot \
        sama5d2_icpsd_uboot \
        sama5d2_xplaineddf_uboot \
index 3262da4cbe2e1047542ec65a8a11a8c27b19a2c0..ad65247e3e53096fa99124f098cf6098b62ca2d8 100644 (file)
@@ -47,6 +47,18 @@ define U-Boot/at91sam9x5ek_mmc
                  atmel_at91sam9x35ek
 endef
 
+define U-Boot/sam9x60ek_nandflash
+  NAME:=SAM9X60-EK board (NandFlash)
+  BUILD_SUBTARGET:=sam9x
+  BUILD_DEVICES:=microchip_sam9x60ek
+endef
+
+define U-Boot/sam9x60ek_mmc
+  NAME:=SAM9X60-EK board (SDcard)
+  BUILD_SUBTARGET:=sam9x
+  BUILD_DEVICES:=microchip_sam9x60ek
+endef
+
 define U-Boot/sama5d3_xplained_nandflash
   NAME:=SAMA5D3 Xplained board (NandFlash)
   BUILD_SUBTARGET:=sama5
@@ -135,6 +147,8 @@ UBOOT_TARGETS := \
        at91sam9m10g45ek_nandflash \
        at91sam9x5ek_nandflash \
        at91sam9x5ek_mmc \
+       sam9x60ek_nandflash \
+       sam9x60ek_mmc \
        sama5d3_xplained_nandflash \
        sama5d3_xplained_mmc \
        sama5d2_icp_mmc \
index 6f10123bbaae37dea19cfdb89584f314789b5c78..b6c5e33ac44fe55d84e9b3d995f2431554d1d200 100644 (file)
@@ -16,11 +16,11 @@ define Build/at91-sdcard
        ::$(DEVICE_NAME)-fit.itb
 
   mcopy -i $@.boot \
-       $(BIN_DIR)/u-boot-at91sam9x5ek_mmc/u-boot.bin \
+       $(BIN_DIR)/u-boot-$(if $(findstring sam9x60,$@),$(DEVICE_DTS:at91-%=%),at91sam9x5ek)_mmc/u-boot.bin \
        ::u-boot.bin
 
   mcopy -i $@.boot \
-       $(BIN_DIR)/at91bootstrap-at91sam9x5eksd_uboot/at91bootstrap.bin \
+       $(BIN_DIR)/at91bootstrap-$(if $(findstring sam9x60,$@),$(DEVICE_DTS:at91-%=%),at91sam9x5ek)sd_uboot/at91bootstrap.bin \
        ::BOOT.bin
 
   $(CP) uboot-env.txt $@-uboot-env.txt
@@ -112,6 +112,15 @@ define Device/atmel_at91sam9x35ek
 endef
 TARGET_DEVICES += atmel_at91sam9x35ek
 
+define Device/microchip_sam9x60ek
+  $(Device/evaluation-dtb)
+  DEVICE_VENDOR := Microchip
+  DEVICE_MODEL := SAM9X60-EK
+  DEVICE_DTS := at91-sam9x60ek
+  $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += microchip_sam9x60ek
+
 define Device/calamp_lmu5000
   $(Device/production)
   DEVICE_VENDOR := CalAmp