procd: update to git HEAD
authorDaniel Golle <daniel@makrotopia.org>
Fri, 27 Nov 2020 01:14:31 +0000 (01:14 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 27 Nov 2020 01:23:43 +0000 (01:23 +0000)
 3019f50 jail: leak less memory
 7e01453 jail: fix segfault on missing name and refactor
 5abee8f jail: fix and simplify userns uid/gid maps from OCI
 4ba72ec jail: relax /etc/resolv.conf creation
 db5ef86 jail: don't use NULL arguments for mount syscall
 19ac9df jail: don't fail if can't mount-bind /etc/resolv.conf
 acf36f2 jail: seteuid before clone(CLONE_NEWUSER)
 e40828f jail: fix typo in usage output
 b87984b jail: don't attempt to mount /sys with noatime
 b275b11 jail: enter existing cgroups namespace if given
 31e0a46 jail: properly initialize timens_fd

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/system/procd/Makefile

index ae7c018ea8f3e9fad1f3a6cd0f743277e9eeba70..aa68b37f41691d83055194c8c46c0bfa83ca58db 100644 (file)
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
-PKG_SOURCE_DATE:=2020-11-23
-PKG_SOURCE_VERSION:=e935c0c043b12415fa36aca01cfc757cadb9fac4
-PKG_MIRROR_HASH:=6bb79a7b5c87afbfc7227758cffbebcc5c9752e791bb5a39280a9aebd159250b
+PKG_SOURCE_DATE:=2020-11-27
+PKG_SOURCE_VERSION:=31e0a46ded22a517c03cb899f890207f0db75fb8
+PKG_MIRROR_HASH:=66014cf40e87f45b3dce23b10ed0218fc458ec620e6ab1fd33e4af0c2aca2442
 CMAKE_INSTALL:=1
 
 PKG_LICENSE:=GPL-2.0