toolchain: gcc: update to 12.3.0
authorNick Hainke <vincent@systemli.org>
Tue, 9 May 2023 21:47:01 +0000 (23:47 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 12 May 2023 10:11:20 +0000 (12:11 +0200)
Release notes:
https://gcc.gnu.org/gcc-12/changes.html

Refresh patches:
- 230-musl_libssp.patch
- 910-mbsd_multi.patch
- 920-specs_nonfatal_getenv.patch
- 970-macos_arm64-building-fix.patch

Signed-off-by: Nick Hainke <vincent@systemli.org>
toolchain/gcc/Config.version
toolchain/gcc/common.mk
toolchain/gcc/patches-12.x/230-musl_libssp.patch
toolchain/gcc/patches-12.x/910-mbsd_multi.patch
toolchain/gcc/patches-12.x/920-specs_nonfatal_getenv.patch
toolchain/gcc/patches-12.x/970-macos_arm64-building-fix.patch

index 1c1b0a04a1036b84c83ca10d2fac99bbbcfa8a7b..7126a0c883fd6350ecfb03e801c633511a3a6e9c 100644 (file)
@@ -10,4 +10,4 @@ config GCC_VERSION
        string
        default "11.3.0"        if GCC_VERSION_11
        default "13.1.0"        if GCC_VERSION_13
-       default "12.2.0"
+       default "12.3.0"
index ebe4b484cfd62fc31d37e6afb9af43ac8345998d..677fb2538181812e8b4cf46176b2f35306c9da00 100644 (file)
@@ -33,8 +33,8 @@ ifeq ($(PKG_VERSION),11.3.0)
   PKG_HASH:=b47cf2818691f5b1e21df2bb38c795fac2cfbd640ede2d0a5e1c89e338a3ac39
 endif
 
-ifeq ($(PKG_VERSION),12.2.0)
-  PKG_HASH:=e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff
+ifeq ($(PKG_VERSION),12.3.0)
+  PKG_HASH:=949a5d4f99e786421a93b532b22ffab5578de7321369975b91aec97adfda8c3b
 endif
 
 ifeq ($(PKG_VERSION),13.1.0)
index 3ce5e49587f2cec9d63b1df17647804091d52cf8..a909d638750d4e57381de11d28a34f386057c5d0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/gcc.cc
 +++ b/gcc/gcc.cc
-@@ -985,7 +985,9 @@ proper position among the other output f
+@@ -987,7 +987,9 @@ proper position among the other output f
  #endif
  
  #ifndef LINK_SSP_SPEC
index 4033c5b23bcf876f394239780974494983c40cea..0f75d0ce0eb04e7ae4c8f9d0d03ba85b6c81da46 100644 (file)
@@ -134,7 +134,7 @@ Date:   Tue Jul 31 00:52:27 2007 +0000
  @opindex Wno-stack-protector
 --- a/gcc/opts.cc
 +++ b/gcc/opts.cc
-@@ -2692,6 +2692,9 @@ common_handle_option (struct gcc_options
+@@ -2699,6 +2699,9 @@ common_handle_option (struct gcc_options
        add_comma_separated_to_vector (&opts->x_flag_ignored_attributes, arg);
        break;
  
index 0f7d40b244dc7d22ada64c548aa82187746ebe33..59bd350044533767cd6c8b6a1c5d97faa26a6664 100644 (file)
@@ -7,7 +7,7 @@ Date:   Sat Apr 21 03:02:39 2012 +0000
 
 --- a/gcc/gcc.cc
 +++ b/gcc/gcc.cc
-@@ -10213,8 +10213,10 @@ getenv_spec_function (int argc, const ch
+@@ -10186,8 +10186,10 @@ getenv_spec_function (int argc, const ch
      }
  
    if (!value)
index 86fa68e1b105775d9ff8a158adec16c5534f9b4d..89730449f5547a0d313b08567fcfd31cec3398c7 100644 (file)
@@ -17,7 +17,7 @@ Date:   Mon Aug 16 13:16:21 2021 +0100
 
 --- a/gcc/config/aarch64/aarch64.h
 +++ b/gcc/config/aarch64/aarch64.h
-@@ -1290,7 +1290,7 @@ extern const char *aarch64_rewrite_mcpu
+@@ -1293,7 +1293,7 @@ extern const char *aarch64_rewrite_mcpu
  #define MCPU_TO_MARCH_SPEC_FUNCTIONS \
    { "rewrite_mcpu", aarch64_rewrite_mcpu },