modules: hwmon: package driver for LTC4151 current sensor
authorDaniel Golle <daniel@makrotopia.org>
Fri, 26 Sep 2014 19:52:49 +0000 (21:52 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 16 May 2016 16:00:34 +0000 (18:00 +0200)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/linux/modules/hwmon.mk

index effae14a207acf11d3986017a048ca232b2e3fd0..d9186879cefbe00bca55691a8be56a73b7907cc3 100644 (file)
@@ -195,6 +195,20 @@ endef
 
 $(eval $(call KernelPackage,hwmon-lm95241))
 
+define KernelPackage/hwmon-ltc4151
+  TITLE:=LTC4151 monitoring support
+  KCONFIG:=CONFIG_SENSORS_LTC4151
+  FILES:=$(LINUX_DIR)/drivers/hwmon/ltc4151.ko
+  AUTOLOAD:=$(call AutoProbe,ltc4151)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-ltc4151/description
+ Kernel module for Linear Technology LTC4151 current and voltage monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-ltc4151))
+
 define KernelPackage/hwmon-sht21
   TITLE:=Sensiron SHT21 and compat. monitoring support
   KCONFIG:=CONFIG_SENSORS_SHT21