kernel: package f71882fg hwmon driver
authorNick Bowler <nbowler@draconx.ca>
Wed, 25 Mar 2020 02:00:28 +0000 (22:00 -0400)
committerPetr Štetiar <ynezz@true.cz>
Sat, 28 Mar 2020 12:03:02 +0000 (13:03 +0100)
This driver enables hardware monitoring support using the sensors
found in many Fintek Super-IO chips.

Signed-off-by: Nick Bowler <nbowler@draconx.ca>
package/kernel/linux/modules/hwmon.mk

index 1f4e4558a9d3d8e98cf4d918c9ad3dbc434be309..2552a32a560b5d1138e4129dd2ec84503f4c28cf 100644 (file)
@@ -107,6 +107,21 @@ endef
 $(eval $(call KernelPackage,hwmon-gpiofan))
 
 
+define KernelPackage/hwmon-f71882fg
+  TITLE:=F71882FG compatible monitoring support
+  KCONFIG:=CONFIG_SENSORS_F71882FG
+  FILES:=$(LINUX_DIR)/drivers/hwmon/f71882fg.ko
+  AUTOLOAD:=$(call AutoProbe,f71882fg)
+  $(call AddDepends/hwmon,@TARGET_x86)
+endef
+
+define KernelPackage/hwmon-f71882fg/description
+ Kernel module for hardware monitoring via many Fintek Super-IO chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-f71882fg))
+
+
 define KernelPackage/hwmon-ina209
   TITLE:=INA209 monitoring support
   KCONFIG:=CONFIG_SENSORS_INA209