arm-trusted-firmware-sunxi: Replace with official ARM version
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 19 Dec 2018 12:12:49 +0000 (13:12 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Jan 2019 16:35:14 +0000 (17:35 +0100)
Instead of using a fork of the ARM trusted firmware specifically for the
Allwinner SoCs, use the official version from ARM now, this version
supports the Allwinner SoCs now and the older ATF repository is
deprecated.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/arm-trusted-firmware-sunxi/Makefile

index 7bd042bdaba71ffcb03b0af53046d9a618702a83..0211e5e03049812e8c0ac54571763ba18e2b2e6e 100644 (file)
@@ -11,10 +11,10 @@ PKG_NAME:=arm-trusted-firmware-sunxi
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL=https://github.com/apritzel/arm-trusted-firmware
-PKG_SOURCE_DATE:=2018-02-10
-PKG_SOURCE_VERSION:=c9f55c023164a6c8c49f70f7ac6c68c626839d6f
-PKG_MIRROR_HASH:=94b5338592cf0bcc353b55da5fdd62c91ae8e6263822f73724cb72ecde3dbbf9
+PKG_SOURCE_URL=https://github.com/ARM-software/arm-trusted-firmware
+PKG_SOURCE_DATE:=2018-10-02
+PKG_SOURCE_VERSION:=dbc8d9496ead9ecdd7c2a276b542a4fbbbf64027
+PKG_MIRROR_HASH:=c81521a27b86f606e927b4e346286540b862828c8d49292eae1f5c6adfc24001
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=license.md
@@ -37,12 +37,12 @@ MAKE_VARS = \
        CROSS_COMPILE="$(TARGET_CROSS)"
 
 MAKE_FLAGS += \
-       PLAT=sun50iw1p1 \
+       PLAT=sun50i_a64 \
        bl31
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
-       $(CP) $(PKG_BUILD_DIR)/build/sun50iw1p1/release/bl31.bin $(STAGING_DIR_IMAGE)/bl31.bin
+       $(CP) $(PKG_BUILD_DIR)/build/sun50i_a64/release/bl31.bin $(STAGING_DIR_IMAGE)/bl31.bin
 endef
 
 define Package/arm-trusted-firmware-sunxi/install