lua: add -ldl for glibc builds
authorRosen Penev <rosenp@gmail.com>
Sat, 2 Jan 2021 23:56:25 +0000 (15:56 -0800)
committerPaul Spooren <mail@aparcar.org>
Thu, 7 Jan 2021 01:38:57 +0000 (15:38 -1000)
For glibc, lua needs an explicit link to libdl as glibc has it separate

Fixes the following error in at least collectd:

ld: usr/lib/liblua.so: undefined reference to `dlopen'
ld: usr/lib/liblua.so: undefined reference to `dlclose'
ld: usr/lib/liblua.so: undefined reference to `dlerror'
ld: usr/lib/liblua.so: undefined reference to `dlsym'

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/utils/lua/Makefile

index 3cdb2bcdb60ce2a1763f2c8e090c30f9bc843f28..a54ef7d25a8759488e4eb503ce96afc6be42fba4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lua
 PKG_VERSION:=5.1.5
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
@@ -99,7 +99,7 @@ define Build/Compile
                RANLIB="$(TARGET_CROSS)ranlib" \
                INSTALL_ROOT=/usr \
                CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
-               MYLDFLAGS="$(TARGET_LDFLAGS) $(if $(CONFIG_USE_GLIBC),-lm)" \
+               MYLDFLAGS="$(TARGET_LDFLAGS) $(if $(CONFIG_USE_GLIBC),-lm -ldl)" \
                PKG_VERSION=$(PKG_VERSION) \
                linux
        rm -rf $(PKG_INSTALL_DIR)