lantiq: ltq-ptm: vr9: fix skb handling in ptm_hard_start_xmit()
authorMartin Schiller <ms@dev.tdt.de>
Tue, 21 Jan 2020 09:42:33 +0000 (10:42 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Jan 2020 17:38:17 +0000 (18:38 +0100)
Call skb_orphan(skb) to call the owner's destructor function and make
the skb unowned.

This is necessary to prevent sk_wmem_alloc of a socket from overflowing,
which leads to ENOBUFS errors on application level.

Signed-off-by: Martin Schiller <ms@dev.tdt.de>
package/kernel/lantiq/ltq-ptm/Makefile
package/kernel/lantiq/ltq-ptm/src/ifxmips_ptm_vdsl.c

index 73fd63f42bcb5628887cc04d39ced811de304d40..8f4db69411fb1aea4f012cb7068ee3fba0b7f4bc 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-ptm
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=John Crispin <john@phrozen.org>
 PKG_LICENSE:=GPL-2.0+
index 9e24c69d943e995c16916e325a0583648a2be8e5..46a52e29d8359235f3b89f0c6271d506a6569c5c 100644 (file)
@@ -336,6 +336,9 @@ static int ptm_hard_start_xmit(struct sk_buff *skb, struct net_device *dev)
         dma_cache_wback((unsigned long)skb->data, skb->len);
     }
 
+    /* make the skb unowned */
+    skb_orphan(skb);
+
     *(struct sk_buff **)((unsigned int)skb->data - byteoff - sizeof(struct sk_buff *)) = skb;
     /*  write back to physical memory   */
     dma_cache_wback((unsigned long)skb->data - byteoff - sizeof(struct sk_buff *), skb->len + byteoff + sizeof(struct sk_buff *));