kernel: kmod-zram: break the strict dependency from lz4
authorRui Salvaterra <rsalvaterra@gmail.com>
Thu, 25 Jun 2020 14:20:23 +0000 (15:20 +0100)
committerPetr Štetiar <ynezz@true.cz>
Sat, 11 Jul 2020 11:33:28 +0000 (13:33 +0200)
Zram is only strictly dependent on lzo, not lz4. Break this dependency and
make the lz4 module visible in the configuration, in order for the user to
have the choice of enabling/disabling it, if (s)he sees fit.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
package/kernel/linux/modules/lib.mk
package/kernel/linux/modules/other.mk

index e14c6b31c0103d6f074ba1b677564e448b355fbd..1289cc1f255450e3634c1908b1d3193adf30fde7 100644 (file)
@@ -147,7 +147,6 @@ define KernelPackage/lib-lz4
   SUBMENU:=$(LIB_MENU)
   TITLE:=LZ4 support
   DEPENDS:=+kmod-crypto-acompress
-  HIDDEN:=1
   KCONFIG:= \
        CONFIG_CRYPTO_LZ4 \
        CONFIG_LZ4_COMPRESS \
index f74c622ed728cda768b7f994198015a6486b6f69..6eb9404837fdb988e7f8df0af1bf1ccc4d9fe153 100644 (file)
@@ -930,15 +930,14 @@ $(eval $(call KernelPackage,ikconfig))
 define KernelPackage/zram
   SUBMENU:=$(OTHER_MENU)
   TITLE:=ZRAM
-  DEPENDS:=+kmod-lib-lzo +kmod-lib-lz4
+  DEPENDS:=+kmod-lib-lzo
   KCONFIG:= \
        CONFIG_ZSMALLOC \
        CONFIG_ZRAM \
        CONFIG_ZRAM_DEBUG=n \
        CONFIG_PGTABLE_MAPPING=n \
        CONFIG_ZRAM_WRITEBACK=n \
-       CONFIG_ZSMALLOC_STAT=n \
-       CONFIG_ZRAM_LZ4_COMPRESS=y
+       CONFIG_ZSMALLOC_STAT=n
   FILES:= \
        $(LINUX_DIR)/mm/zsmalloc.ko \
        $(LINUX_DIR)/drivers/block/zram/zram.ko