lua: create lua symlink for host installation
authorDavid Bauer <mail@david-bauer.net>
Wed, 28 Aug 2019 18:47:02 +0000 (20:47 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sat, 31 Aug 2019 08:31:00 +0000 (10:31 +0200)
Since the binaries for both lua as well as lua5.3 contain the version
number, invocations of the "lua" binary are failing, as it's not created
anymore for the host package.

Fixes: fe59b46 ("lua: include version number in installed files")
Signed-off-by: David Bauer <mail@david-bauer.net>
package/utils/lua/Makefile

index a2870448bda73c61042042146f7da5835839af64..e376e8c472e77cf779bd36ab541a783d0898fb1b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lua
 PKG_VERSION:=5.1.5
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
@@ -133,6 +133,8 @@ define Host/Install
        $(MAKE) -C $(HOST_BUILD_DIR) \
                INSTALL_TOP="$(STAGING_DIR_HOSTPKG)" \
                install
+
+       $(LN) $(STAGING_DIR_HOSTPKG)/bin/lua5.1 $(STAGING_DIR_HOSTPKG)/bin/lua
 endef
 
 define Build/InstallDev