bcm63xx: loader-lzma: use default lzma
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Sun, 3 May 2020 15:19:03 +0000 (17:19 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 12 May 2020 10:34:57 +0000 (12:34 +0200)
Specific CFE LZMA parameters aren't needed for LZMA Loader.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bcm63xx/image/Makefile
target/linux/bcm63xx/image/bcm63xx.mk

index f6d2bf4bbd1c16540be57c79abaf6c5b229513d2..9ef7a91ce75c64dd2c6137634128e5b4329579b8 100644 (file)
@@ -53,20 +53,16 @@ define Build/loader-lzma
        rm -rf $@.src
 endef
 
-define Build/lzma
+define Build/lzma-cfe
        # CFE is a LZMA nazi! It took me hours to find out the parameters!
        # Also I think lzma has a bug cause it generates different output depending on
        # if you use stdin / stdout or not. Use files instead of stdio here, cause
        # otherwise CFE will complain and not boot the image.
-       $(STAGING_DIR_HOST)/bin/lzma e $@ -d22 -fb64 -a1 $@.lzma
-       mv $@.lzma $@
-endef
-
-define Build/lzma-cfe
+       $(call Build/lzma-no-dict,-d22 -fb64 -a1)
        # Strip out the length, CFE doesn't like this
-       dd if=$@ of=$@.lzma.cfe bs=5 count=1
-       dd if=$@ of=$@.lzma.cfe ibs=13 obs=5 skip=1 seek=1 conv=notrunc
-       mv $@.lzma.cfe $@
+       dd if=$@ of=$@.new bs=5 count=1
+       dd if=$@ of=$@.new ibs=13 obs=5 skip=1 seek=1 conv=notrunc
+       mv $@.new $@
 endef
 
 define Build/relocate-kernel
index 64ddb6374d397aedbf393fd06e3b1756b7e4c3f2..d5601e2c3c7335de0f37b72b8ec21f973561071d 100644 (file)
@@ -19,7 +19,7 @@ endef
 
 define Device/bcm63xx
   FILESYSTEMS := squashfs jffs2-64k jffs2-128k
-  KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | lzma-cfe
+  KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma-cfe
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-lzma elf
   IMAGES := cfe.bin
   IMAGE/cfe.bin := cfe-bin --pad $$$$(shell expr $$$$(FLASH_MB) / 2)