gdb: Do not link against xxhash
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Dec 2022 21:10:39 +0000 (22:10 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Dec 2022 21:34:44 +0000 (22:34 +0100)
libxxhash is now available in the OpenWrt package feed and gdb will link
against it if gdb finds this library. Explicitly deactivate the usage
of xxhash.

This should fix the build of gdb in build bots.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/devel/gdb/Makefile

index 7acf26d60b9678d6ea7a7da3934d75eaef3ec7f1..1b059dcc50bc178490da946d7dcdb87a2d5dcf89 100644 (file)
@@ -66,6 +66,7 @@ CONFIGURE_ARGS+= \
        --without-mpc \
        --without-mpfr \
        --without-isl \
+       --without-xxhash \
        --with-libgmp-prefix=$(STAGING_DIR)/usr
 
 CONFIGURE_VARS+= \