ath10k-ct: update to 2022-05-13
authorRobert Marko <robimarko@gmail.com>
Sat, 14 May 2022 18:14:14 +0000 (20:14 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 19 May 2022 09:07:02 +0000 (11:07 +0200)
Update ath10k-ct to the latest version which includes the backported
ath10k commit for requesting API 1 BDF-s with a unique name like caldata.

Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/ath10k-ct/Makefile
package/kernel/ath10k-ct/patches/120-ath10k-fetch-calibration-data-via-nvmem-subsystem.patch
package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch

index 278f6d737e3a593fbd75c53afc9950fb5b912f4c..acdaa5a6fc91466c0c4747e37c86fe36ed0bd8ae 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2021-11-28
-PKG_SOURCE_VERSION:=dc350bbf41d987c5b2db54405bcc9ef3cd66d5db
-PKG_MIRROR_HASH:=92422485c7b92be840a40bf8d157bb6731d14d3811907b6cb4e4cfab0777b60d
+PKG_SOURCE_DATE:=2022-05-13
+PKG_SOURCE_VERSION:=f808496fcc6b1f68942914117aebf8b3f8d52bb3
+PKG_MIRROR_HASH:=39527b3408696594eda5579521a9fb798417be4dda73fa08e8b3a8c7b0d3f3d9
 
 # Build the 5.15 ath10k-ct driver version.
 # Probably this should match as closely as
index 2a4b09ac271fa227b48b9f259d81c5c3283a66af..c935d8575eed2eeee3acfcbc024b01a9216f765e 100644 (file)
@@ -34,7 +34,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
  #include <asm/byteorder.h>
  #include <linux/ctype.h>
  
-@@ -988,7 +989,8 @@ static int ath10k_core_get_board_id_from
+@@ -1005,7 +1006,8 @@ static int ath10k_core_get_board_id_from
        }
  
        if (ar->cal_mode == ATH10K_PRE_CAL_MODE_DT ||
@@ -44,7 +44,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
                bmi_board_id_param = BMI_PARAM_GET_FLASH_BOARD_ID;
        else
                bmi_board_id_param = BMI_PARAM_GET_EEPROM_BOARD_ID;
-@@ -2087,7 +2089,8 @@ static int ath10k_download_and_run_otp(s
+@@ -2115,7 +2117,8 @@ static int ath10k_download_and_run_otp(s
  
        /* As of now pre-cal is valid for 10_4 variants */
        if (ar->cal_mode == ATH10K_PRE_CAL_MODE_DT ||
@@ -54,7 +54,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
                bmi_otp_exe_param = BMI_PARAM_FLASH_SECTION_ALL;
  
        ret = ath10k_bmi_execute(ar, address, bmi_otp_exe_param, &result);
-@@ -2221,6 +2224,39 @@ struct ath10k_bss_rom_ie {
+@@ -2249,6 +2252,39 @@ struct ath10k_bss_rom_ie {
        __le32 rom_len;
  } __packed;
  
@@ -94,7 +94,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
  int ath10k_core_fetch_firmware_api_n(struct ath10k *ar, const char *name,
                                     struct ath10k_fw_file *fw_file)
  {
-@@ -2597,6 +2633,18 @@ static int ath10k_core_pre_cal_download(
+@@ -2625,6 +2661,18 @@ static int ath10k_core_pre_cal_download(
  {
        int ret;
  
@@ -113,7 +113,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
        ret = ath10k_download_cal_file(ar, ar->pre_cal_file);
        if (ret == 0) {
                ar->cal_mode = ATH10K_PRE_CAL_MODE_FILE;
-@@ -2663,6 +2711,18 @@ static int ath10k_download_cal_data(stru
+@@ -2691,6 +2739,18 @@ static int ath10k_download_cal_data(stru
                   "pre cal download procedure failed, try cal file: %d\n",
                   ret);
  
index 0f75c496e7672f365e98e5398ef60136d4cb1223..2cc7c1e678babb1d868edf716b3ea8e98fbdc9b9 100644 (file)
@@ -129,7 +129,7 @@ v13:
                .patch_load_addr = QCA988X_HW_2_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_ALL,
-@@ -141,6 +143,7 @@ static const struct ath10k_hw_params ath
+@@ -143,6 +145,7 @@ static const struct ath10k_hw_params ath
                .dev_id = QCA9887_1_0_DEVICE_ID,
                .bus = ATH10K_BUS_PCI,
                .name = "qca9887 hw1.0",
@@ -137,7 +137,7 @@ v13:
                .patch_load_addr = QCA9887_HW_1_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_ALL,
-@@ -352,6 +355,7 @@ static const struct ath10k_hw_params ath
+@@ -360,6 +363,7 @@ static const struct ath10k_hw_params ath
                .dev_id = QCA99X0_2_0_DEVICE_ID,
                .bus = ATH10K_BUS_PCI,
                .name = "qca99x0 hw2.0",
@@ -145,7 +145,7 @@ v13:
                .patch_load_addr = QCA99X0_HW_2_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
                .otp_exe_param = 0x00000700,
-@@ -393,6 +397,7 @@ static const struct ath10k_hw_params ath
+@@ -402,6 +406,7 @@ static const struct ath10k_hw_params ath
                .dev_id = QCA9984_1_0_DEVICE_ID,
                .bus = ATH10K_BUS_PCI,
                .name = "qca9984/qca9994 hw1.0",
@@ -153,7 +153,7 @@ v13:
                .patch_load_addr = QCA9984_HW_1_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
-@@ -441,6 +446,7 @@ static const struct ath10k_hw_params ath
+@@ -451,6 +456,7 @@ static const struct ath10k_hw_params ath
                .dev_id = QCA9888_2_0_DEVICE_ID,
                .bus = ATH10K_BUS_PCI,
                .name = "qca9888 hw2.0",
@@ -161,7 +161,7 @@ v13:
                .patch_load_addr = QCA9888_HW_2_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
-@@ -3942,6 +3948,10 @@ int ath10k_core_start(struct ath10k *ar,
+@@ -3977,6 +3983,10 @@ int ath10k_core_start(struct ath10k *ar,
                        ath10k_wmi_check_apply_board_power_ctl_table(ar);
        }
  
@@ -172,7 +172,7 @@ v13:
        return 0;
  
  err_hif_stop:
-@@ -4203,9 +4213,18 @@ static void ath10k_core_register_work(st
+@@ -4238,9 +4248,18 @@ static void ath10k_core_register_work(st
                goto err_spectral_destroy;
        }
  
@@ -191,7 +191,7 @@ v13:
  err_spectral_destroy:
        ath10k_spectral_destroy(ar);
  err_debug_destroy:
-@@ -4265,6 +4284,8 @@ void ath10k_core_unregister(struct ath10
+@@ -4300,6 +4319,8 @@ void ath10k_core_unregister(struct ath10
        if (!test_bit(ATH10K_FLAG_CORE_REGISTERED, &ar->dev_flags))
                return;
  
@@ -456,7 +456,7 @@ v13:
  static const struct wmi_peer_flags_map wmi_tlv_peer_flags_map = {
 --- a/ath10k-5.15/wmi.c
 +++ b/ath10k-5.15/wmi.c
-@@ -8409,6 +8409,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
+@@ -8413,6 +8413,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
        return skb;
  }
  
@@ -506,7 +506,7 @@ v13:
  static struct sk_buff *
  ath10k_wmi_op_gen_set_psmode(struct ath10k *ar, u32 vdev_id,
                             enum wmi_sta_ps_mode psmode)
-@@ -10240,6 +10283,9 @@ static const struct wmi_ops wmi_ops = {
+@@ -10244,6 +10287,9 @@ static const struct wmi_ops wmi_ops = {
        .fw_stats_fill = ath10k_wmi_main_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
        .gen_echo = ath10k_wmi_op_gen_echo,
@@ -516,7 +516,7 @@ v13:
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10310,6 +10356,8 @@ static const struct wmi_ops wmi_10_1_ops
+@@ -10314,6 +10360,8 @@ static const struct wmi_ops wmi_10_1_ops
        .fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
        .gen_echo = ath10k_wmi_op_gen_echo,
@@ -525,7 +525,7 @@ v13:
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10389,6 +10437,8 @@ static const struct wmi_ops wmi_10_2_ops
+@@ -10393,6 +10441,8 @@ static const struct wmi_ops wmi_10_2_ops
        .gen_delba_send = ath10k_wmi_op_gen_delba_send,
        .fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
@@ -534,7 +534,7 @@ v13:
        /* .gen_pdev_enable_adaptive_cca not implemented */
  };
  
-@@ -10460,6 +10510,8 @@ static const struct wmi_ops wmi_10_2_4_o
+@@ -10464,6 +10514,8 @@ static const struct wmi_ops wmi_10_2_4_o
                ath10k_wmi_op_gen_pdev_enable_adaptive_cca,
        .get_vdev_subtype = ath10k_wmi_10_2_4_op_get_vdev_subtype,
        .gen_bb_timing = ath10k_wmi_10_2_4_op_gen_bb_timing,
@@ -543,7 +543,7 @@ v13:
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10542,6 +10594,8 @@ static const struct wmi_ops wmi_10_4_ops
+@@ -10546,6 +10598,8 @@ static const struct wmi_ops wmi_10_4_ops
        .gen_pdev_bss_chan_info_req = ath10k_wmi_10_2_op_gen_pdev_bss_chan_info,
        .gen_echo = ath10k_wmi_op_gen_echo,
        .gen_pdev_get_tpc_config = ath10k_wmi_10_2_4_op_gen_pdev_get_tpc_config,
index 4c4a0edd57971f9ea4f2f32680ac5c2651470655..fb8468b9c00e3aebcd83065d22599833f3297987 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        if (ret)
 --- a/ath10k-5.15/mac.c
 +++ b/ath10k-5.15/mac.c
-@@ -11521,7 +11521,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -11544,7 +11544,7 @@ int ath10k_mac_register(struct ath10k *a
        ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
  
  #ifdef CPTCFG_MAC80211_LEDS