kernel: add kmod-hwmon-tps23861 support
authorAlexandru Gagniuc <mr.nuke.me@gmail.com>
Wed, 20 Jul 2022 01:27:49 +0000 (20:27 -0500)
committerSander Vanheule <sander@svanheule.net>
Sat, 13 Aug 2022 17:59:47 +0000 (19:59 +0200)
Package the tps23861.ko module, which supports Texas Instruments
TPS23861 PoE+ controller.

Signed-off-by: Alexandru Gagniuc <mr.nuke.me@gmail.com>
package/kernel/linux/modules/hwmon.mk

index b75c741ba0a2f35efec0a1dc2851846c65f5f95a..42df3a94f76622a99699f5632afb0890b6629ac2 100644 (file)
@@ -519,6 +519,20 @@ endef
 $(eval $(call KernelPackage,hwmon-tmp421))
 
 
+define KernelPackage/hwmon-tps23861
+  TITLE:=Texas Instruments TPS23861 PoE PSE
+  KCONFIG:=CONFIG_SENSORS_TPS23861
+  FILES:=$(LINUX_DIR)/drivers/hwmon/tps23861.ko
+  AUTOLOAD:=$(call AutoProbe,tps23861)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-tps23861/description
+  Kernel module for the Texas Instruments TPS23861 802.3at PoE PSE chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-tps23861))
+
 define KernelPackage/hwmon-vid
   TITLE:=VID/VRM/VRD voltage conversion module.
   KCONFIG:=CONFIG_HWMON_VID