rockchip: allow for multiple boot-scripts
authorDavid Bauer <mail@david-bauer.net>
Sat, 11 Jul 2020 12:02:23 +0000 (14:02 +0200)
committerDavid Bauer <mail@david-bauer.net>
Tue, 28 Jul 2020 13:52:44 +0000 (15:52 +0200)
Add support for select a bootscript depending on the device built. This
is necessary, as the FriendlyARM NanoPi R2S needs a different bootcmd in
order to produce output on the debug UART.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/rockchip/image/Makefile

index 22854d9d02df519376503c922514bdad9e2c8584..3c17e963bebee8839a04916eb139343151378555 100644 (file)
@@ -24,7 +24,7 @@ endef
 
 define Build/boot-script
        # Make an U-boot image and copy it to the boot partition
-       mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d mmc.bootscript $@.boot/boot.scr
+       mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d $(if $(1),$(1),mmc).bootscript $@.boot/boot.scr
 endef
 
 define Build/pine64-img