gettext-full: avoid using iconv for host builds
authorJo-Philipp Wich <jo@mein.io>
Wed, 11 Jan 2017 02:44:51 +0000 (03:44 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 11 Jan 2017 02:48:30 +0000 (03:48 +0100)
The gettext-full host build might pick up iconv-stub host build  headers
during the build, leading to stray linker errors with unresolved references
to libiconv_open(), libiconv() and libiconv_close().

Since we're not needing iconv support on the host, pass the appropriate
cache variables to configure to prevent detection and linking of iconv.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/libs/gettext-full/Makefile

index d293e30eac95442875b677f744035eb6995c4f5b..deb4840109f63ec2d6f848d05ada7fb56e4e433d 100644 (file)
@@ -71,7 +71,10 @@ HOST_CONFIGURE_ARGS += \
 
 
 HOST_CONFIGURE_VARS += \
-       EMACS="no"
+       EMACS="no" \
+       am_cv_lib_iconv=no \
+       am_cv_func_iconv=no \
+       ac_cv_header_iconv_h=no \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/libintl-full/include