kernel: bump 4.19 to 4.19.66
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 12 Aug 2019 09:52:25 +0000 (11:52 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 14 Aug 2019 16:23:08 +0000 (18:23 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.19/950-0011-spi-bcm2835-Support-pin-groups-other-than-7-11.patch
target/linux/brcm2708/patches-4.19/950-0012-spi-bcm2835-Disable-forced-software-CS.patch
target/linux/brcm2708/patches-4.19/950-0013-spi-bcm2835-Remove-unused-code.patch
target/linux/brcm2708/patches-4.19/950-0106-cgroup-Disable-cgroup-memory-by-default.patch
target/linux/brcm2708/patches-4.19/950-0430-Revert-cgroup-Disable-cgroup-memory-by-default.patch
target/linux/brcm2708/patches-4.19/950-0553-spi-bcm2835-enable-shared-interrupt-support.patch
target/linux/generic/pending-4.19/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/mvebu/patches-4.19/402-net-phylink-only-call-mac_config-during-resolve-when.patch
target/linux/mvebu/patches-4.19/403-net-phylink-ensure-inband-AN-works-correctly.patch
target/linux/mvebu/patches-4.19/404-sfp-provide-netdev-sfp_bus-and-use-for-start-stop.patch

index fff92f6f07315a6d6e6c76523dad3f19cb12f182..c03c8a369ae04c11f28ed6bb8a2807c080515e09 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .189
 LINUX_VERSION-4.14 = .138
-LINUX_VERSION-4.19 = .65
+LINUX_VERSION-4.19 = .66
 
 LINUX_KERNEL_HASH-4.9.189 = 93d945661246f726b694455c80c140717d2beff5a718445a51183439bbe5d0b3
 LINUX_KERNEL_HASH-4.14.138 = f250bd1de3a83c1f015f8e6e9bfa9f20eaef3dc24a6cd60116e49979314b837b
-LINUX_KERNEL_HASH-4.19.65 = e59939186916c0286289c5bf78b83fac0d71a807241c6b1899bfe7a84486dedf
+LINUX_KERNEL_HASH-4.19.66 = c981abe15c4b9496cdadb04e4f4afb88b3a78f31ced8d07684ee9c58b3fadb64
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 2063d5a0bef1d4845b0d29ec195b2ecb45c44a7e..35c6449724cd977e7b366800cde696de2aa6b9d1 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/spi/spi-bcm2835.c
 +++ b/drivers/spi/spi-bcm2835.c
-@@ -686,6 +686,8 @@ static int bcm2835_spi_setup(struct spi_
+@@ -687,6 +687,8 @@ static int bcm2835_spi_setup(struct spi_
  {
        int err;
        struct gpio_chip *chip;
@@ -28,7 +28,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        /*
         * sanity checking the native-chipselects
         */
-@@ -702,15 +704,42 @@ static int bcm2835_spi_setup(struct spi_
+@@ -703,15 +705,42 @@ static int bcm2835_spi_setup(struct spi_
                        "setup: only two native chip-selects are supported\n");
                return -EINVAL;
        }
index ace41e47a3f41422a0d4a0927cfebefa27d5c02a..c60f7636d665be0589729a514df9398a18637fa1 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/spi/spi-bcm2835.c
 +++ b/drivers/spi/spi-bcm2835.c
-@@ -705,6 +705,7 @@ static int bcm2835_spi_setup(struct spi_
+@@ -706,6 +706,7 @@ static int bcm2835_spi_setup(struct spi_
                return -EINVAL;
        }
  
@@ -24,7 +24,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        /* now translate native cs to GPIO */
        /* first look for chip select pins in the devices pin groups */
        for (pingroup_index = 0;
-@@ -754,6 +755,7 @@ static int bcm2835_spi_setup(struct spi_
+@@ -755,6 +756,7 @@ static int bcm2835_spi_setup(struct spi_
                        spi->chip_select, spi->cs_gpio, err);
                return err;
        }
index 72429e85e9a7d1bc6c59f2a61af51dc50eaf9ce6..b8041da92972573fb0f9eb36881822930a9f9eb8 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH 013/725] spi-bcm2835: Remove unused code
 
 --- a/drivers/spi/spi-bcm2835.c
 +++ b/drivers/spi/spi-bcm2835.c
-@@ -677,17 +677,8 @@ static void bcm2835_spi_set_cs(struct sp
+@@ -678,17 +678,8 @@ static void bcm2835_spi_set_cs(struct sp
        bcm2835_wr(bs, BCM2835_SPI_CS, cs);
  }
  
@@ -27,7 +27,7 @@ Subject: [PATCH 013/725] spi-bcm2835: Remove unused code
        /*
         * sanity checking the native-chipselects
         */
-@@ -705,58 +696,6 @@ static int bcm2835_spi_setup(struct spi_
+@@ -706,58 +697,6 @@ static int bcm2835_spi_setup(struct spi_
                return -EINVAL;
        }
  
index 40d8ec044d0223e5ae70f64d6c23ad13b922a9a9..2e144548e7e2454e3571f494d3025dbb02b64aae 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/kernel/cgroup/cgroup.c
 +++ b/kernel/cgroup/cgroup.c
-@@ -5296,6 +5296,8 @@ int __init cgroup_init_early(void)
+@@ -5334,6 +5334,8 @@ int __init cgroup_init_early(void)
  }
  
  static u16 cgroup_disable_mask __initdata;
@@ -26,7 +26,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
  /**
   * cgroup_init - cgroup initialization
-@@ -5336,6 +5338,12 @@ int __init cgroup_init(void)
+@@ -5374,6 +5376,12 @@ int __init cgroup_init(void)
  
        mutex_unlock(&cgroup_mutex);
  
@@ -39,7 +39,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        for_each_subsys(ss, ssid) {
                if (ss->early_init) {
                        struct cgroup_subsys_state *css =
-@@ -5719,6 +5727,28 @@ static int __init cgroup_disable(char *s
+@@ -5765,6 +5773,28 @@ static int __init cgroup_disable(char *s
  }
  __setup("cgroup_disable=", cgroup_disable);
  
index 2ed5dc03b286e07c34e320d29849bd8e01ee2863..af86702d646ddb1e8bcbb0368cb80ec65af9109a 100644 (file)
@@ -10,7 +10,7 @@ This reverts commit cd6ce4d0ded13c94ff5208c679ed5e030263149b.
 
 --- a/kernel/cgroup/cgroup.c
 +++ b/kernel/cgroup/cgroup.c
-@@ -5296,8 +5296,6 @@ int __init cgroup_init_early(void)
+@@ -5334,8 +5334,6 @@ int __init cgroup_init_early(void)
  }
  
  static u16 cgroup_disable_mask __initdata;
@@ -19,7 +19,7 @@ This reverts commit cd6ce4d0ded13c94ff5208c679ed5e030263149b.
  
  /**
   * cgroup_init - cgroup initialization
-@@ -5338,12 +5336,6 @@ int __init cgroup_init(void)
+@@ -5376,12 +5374,6 @@ int __init cgroup_init(void)
  
        mutex_unlock(&cgroup_mutex);
  
@@ -32,7 +32,7 @@ This reverts commit cd6ce4d0ded13c94ff5208c679ed5e030263149b.
        for_each_subsys(ss, ssid) {
                if (ss->early_init) {
                        struct cgroup_subsys_state *css =
-@@ -5727,28 +5719,6 @@ static int __init cgroup_disable(char *s
+@@ -5773,28 +5765,6 @@ static int __init cgroup_disable(char *s
  }
  __setup("cgroup_disable=", cgroup_disable);
  
index 9fd6608542a85796ae6879f0bf0ff4107d556098..ab951cd67e05af2e134b31c78e7a65e89ae5f3ab 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Martin Sperl <kernel@martin.sperl.org>
        /* Read as many bytes as possible from FIFO */
        bcm2835_rd_fifo(bs);
        /* Write as many bytes as possible to FIFO */
-@@ -755,7 +759,8 @@ static int bcm2835_spi_probe(struct plat
+@@ -756,7 +760,8 @@ static int bcm2835_spi_probe(struct plat
        bcm2835_wr(bs, BCM2835_SPI_CS,
                   BCM2835_SPI_CS_CLEAR_RX | BCM2835_SPI_CS_CLEAR_TX);
  
index e21f510fee2c0368bf9bcebc83a3d27fcc4fff7a..d5f4a4c969bd2619d4aa24162f0ae88c24df246e 100644 (file)
@@ -300,7 +300,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  /**
   * ip6_tnl_addr_conflict - compare packet addresses to tunnel's own
   *   @t: the outgoing tunnel device
-@@ -1309,6 +1449,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1308,6 +1448,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
  {
        struct ip6_tnl *t = netdev_priv(dev);
        struct ipv6hdr *ipv6h;
@@ -309,8 +309,8 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        __u16 offset;
        struct flowi6 fl6;
 @@ -1373,6 +1514,18 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
        fl6.flowi6_uid = sock_net_uid(dev_net(dev), NULL);
+       dsfield = INET_ECN_encapsulate(dsfield, ipv6_get_dsfield(ipv6h));
  
 +      /* try to find matching FMR */
 +      for (fmr = t->parms.fmrs; fmr; fmr = fmr->next) {
@@ -327,7 +327,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        if (iptunnel_handle_offloads(skb, SKB_GSO_IPXIP6))
                return -1;
  
-@@ -1504,6 +1657,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
+@@ -1502,6 +1655,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
        t->parms.link = p->link;
        t->parms.proto = p->proto;
        t->parms.fwmark = p->fwmark;
@@ -342,7 +342,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        dst_cache_reset(&t->dst_cache);
        ip6_tnl_link_config(t);
        return 0;
-@@ -1542,6 +1703,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
+@@ -1540,6 +1701,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
        p->flowinfo = u->flowinfo;
        p->link = u->link;
        p->proto = u->proto;
@@ -350,7 +350,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        memcpy(p->name, u->name, sizeof(u->name));
  }
  
-@@ -1928,6 +2090,15 @@ static int ip6_tnl_validate(struct nlatt
+@@ -1926,6 +2088,15 @@ static int ip6_tnl_validate(struct nlatt
        return 0;
  }
  
@@ -366,7 +366,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  static void ip6_tnl_netlink_parms(struct nlattr *data[],
                                  struct __ip6_tnl_parm *parms)
  {
-@@ -1965,6 +2136,46 @@ static void ip6_tnl_netlink_parms(struct
+@@ -1963,6 +2134,46 @@ static void ip6_tnl_netlink_parms(struct
  
        if (data[IFLA_IPTUN_FWMARK])
                parms->fwmark = nla_get_u32(data[IFLA_IPTUN_FWMARK]);
@@ -413,7 +413,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  }
  
  static bool ip6_tnl_netlink_encap_parms(struct nlattr *data[],
-@@ -2080,6 +2291,12 @@ static void ip6_tnl_dellink(struct net_d
+@@ -2078,6 +2289,12 @@ static void ip6_tnl_dellink(struct net_d
  
  static size_t ip6_tnl_get_size(const struct net_device *dev)
  {
@@ -426,7 +426,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return
                /* IFLA_IPTUN_LINK */
                nla_total_size(4) +
-@@ -2109,6 +2326,24 @@ static size_t ip6_tnl_get_size(const str
+@@ -2107,6 +2324,24 @@ static size_t ip6_tnl_get_size(const str
                nla_total_size(0) +
                /* IFLA_IPTUN_FWMARK */
                nla_total_size(4) +
@@ -451,7 +451,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
                0;
  }
  
-@@ -2116,6 +2351,9 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -2114,6 +2349,9 @@ static int ip6_tnl_fill_info(struct sk_b
  {
        struct ip6_tnl *tunnel = netdev_priv(dev);
        struct __ip6_tnl_parm *parm = &tunnel->parms;
@@ -461,7 +461,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  
        if (nla_put_u32(skb, IFLA_IPTUN_LINK, parm->link) ||
            nla_put_in6_addr(skb, IFLA_IPTUN_LOCAL, &parm->laddr) ||
-@@ -2125,9 +2363,27 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -2123,9 +2361,27 @@ static int ip6_tnl_fill_info(struct sk_b
            nla_put_be32(skb, IFLA_IPTUN_FLOWINFO, parm->flowinfo) ||
            nla_put_u32(skb, IFLA_IPTUN_FLAGS, parm->flags) ||
            nla_put_u8(skb, IFLA_IPTUN_PROTO, parm->proto) ||
@@ -490,7 +490,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        if (nla_put_u16(skb, IFLA_IPTUN_ENCAP_TYPE, tunnel->encap.type) ||
            nla_put_be16(skb, IFLA_IPTUN_ENCAP_SPORT, tunnel->encap.sport) ||
            nla_put_be16(skb, IFLA_IPTUN_ENCAP_DPORT, tunnel->encap.dport) ||
-@@ -2167,6 +2423,7 @@ static const struct nla_policy ip6_tnl_p
+@@ -2165,6 +2421,7 @@ static const struct nla_policy ip6_tnl_p
        [IFLA_IPTUN_ENCAP_DPORT]        = { .type = NLA_U16 },
        [IFLA_IPTUN_COLLECT_METADATA]   = { .type = NLA_FLAG },
        [IFLA_IPTUN_FWMARK]             = { .type = NLA_U32 },
index 611999baea13f86b26dc4d98a43e08713a6c8ac6..0e272ea891a4c429f6e874e68b65a9aec81fab9a 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
 
 --- a/drivers/net/phy/phylink.c
 +++ b/drivers/net/phy/phylink.c
-@@ -337,6 +337,13 @@ static void phylink_mac_config(struct ph
+@@ -339,6 +339,13 @@ static void phylink_mac_config(struct ph
        pl->ops->mac_config(pl->netdev, pl->link_an_mode, state);
  }
  
@@ -27,7 +27,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
  static void phylink_mac_an_restart(struct phylink *pl)
  {
        if (pl->link_config.an_enabled &&
-@@ -440,12 +447,12 @@ static void phylink_resolve(struct work_
+@@ -442,12 +449,12 @@ static void phylink_resolve(struct work_
                case MLO_AN_PHY:
                        link_state = pl->phy_state;
                        phylink_resolve_flow(pl, &link_state);
index a0cdf838b2af8fb8fa7f36feeb371d0dc4e70d73..746aca2e5ae51e32e25bdf66d9005659d6709bfd 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
 
 --- a/drivers/net/phy/phylink.c
 +++ b/drivers/net/phy/phylink.c
-@@ -457,28 +457,21 @@ static void phylink_resolve(struct work_
+@@ -459,28 +459,21 @@ static void phylink_resolve(struct work_
  
                case MLO_AN_INBAND:
                        phylink_get_mac_state(pl, &link_state);
index e174ad0084ff81390e311df0f005c1dcd91a647c..f2581ca6b7332e6137281d1562e7dd6e6df26616 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
 
 --- a/drivers/net/phy/phylink.c
 +++ b/drivers/net/phy/phylink.c
-@@ -947,8 +947,8 @@ void phylink_start(struct phylink *pl)
+@@ -949,8 +949,8 @@ void phylink_start(struct phylink *pl)
  
        if (pl->link_an_mode == MLO_AN_FIXED && !IS_ERR(pl->link_gpio))
                mod_timer(&pl->link_poll, jiffies + HZ);
@@ -26,7 +26,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
        if (pl->phydev)
                phy_start(pl->phydev);
  }
-@@ -969,8 +969,8 @@ void phylink_stop(struct phylink *pl)
+@@ -971,8 +971,8 @@ void phylink_stop(struct phylink *pl)
  
        if (pl->phydev)
                phy_stop(pl->phydev);