base-files: drop default setup for vconfig
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 10 Sep 2020 15:24:52 +0000 (17:24 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 16 Sep 2020 15:28:20 +0000 (17:28 +0200)
vconfig has been disabled by default since 2015 [1] and there are
no remaining uses in entire OpenWrt trunk. However, we still set up
a specific name_type for it during boot.

While this setup is properly implemented to be only triggered when
vconfig is present, it still seems anachronistic and unnecessary
to set up a standard for a tool that is not used anymore.

Therefore, this removes the set_name_type initialization and leaves
it for those people actually using the tool to configure it as needed.

[1] 899a23227e55 ("busybox: improve applets & deprecate ifconfig, route")

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/base-files/Makefile
package/base-files/files/etc/init.d/boot

index 73455174db4653fafa05bc45bd7b6c7fe51ec968..db9be216e6815aa806f9a491cfbd9540312afb37 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=229
+PKG_RELEASE:=230
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index 958a67599e82b536a4e402e71e1563991392136f..b36323a97e2a88d08893c6ebfbfee76e0b1e4c25 100755 (executable)
@@ -20,7 +20,6 @@ uci_apply_defaults() {
 boot() {
        [ -f /proc/mounts ] || /sbin/mount_root
        [ -f /proc/jffs2_bbc ] && echo "S" > /proc/jffs2_bbc
-       [ -f /proc/net/vlan/config ] && vconfig set_name_type DEV_PLUS_VID_NO_PAD
 
        mkdir -p /var/run
        mkdir -p /var/log