kernel: bump 5.10 to 5.10.57
authorRui Salvaterra <rsalvaterra@gmail.com>
Mon, 9 Aug 2021 21:05:05 +0000 (22:05 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 14 Aug 2021 15:32:34 +0000 (16:32 +0100)
No deleted or manually refreshed patches.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
include/kernel-version.mk
target/linux/lantiq/patches-5.10/0028-NET-lantiq-various-etop-fixes.patch
target/linux/octeon/patches-5.10/110-er200-ethernet_probe_order.patch
target/linux/octeon/patches-5.10/700-allocate_interface_by_label.patch
target/linux/octeon/patches-5.10/701-honor_sgmii_node_device_tree_status.patch
target/linux/ramips/patches-5.10/700-net-ethernet-mediatek-support-net-labels.patch
target/linux/rockchip/patches-5.10/002-net-usb-r8152-add-LED-configuration-from-OF.patch

index 3ef1aba6c39d069c8e6aed4fc610aea74ca4e303..7e5798861b75467e35d8b69961273aa3e21e4f70 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .138
-LINUX_VERSION-5.10 = .56
+LINUX_VERSION-5.10 = .57
 
 LINUX_KERNEL_HASH-5.4.138 = a43957727a54e5e1035d7372a1e64203ae8e3060c52a3816916157967f9a8657
-LINUX_KERNEL_HASH-5.10.56 = 4d6a0d5f9c50fa44890e0b61e1fb63f6efe6be448ceddfe1ad7c0cbd2890ec6b
+LINUX_KERNEL_HASH-5.10.57 = 00bbaeaac17f82d9a6d93cbc42cafd39d3b2fa3a6087333503d2344fa5e3142d
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 0a42fd59e4663f0539afc6bd16aedea621fe6a36..eb47010fa06280bdd0630d6a8e3d1bf46ee78a34 100644 (file)
@@ -744,7 +744,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
        res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
        if (!res) {
-@@ -651,31 +860,62 @@ ltq_etop_probe(struct platform_device *p
+@@ -651,31 +859,62 @@ ltq_etop_probe(struct platform_device *p
                goto err_out;
        }
  
@@ -822,7 +822,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
        err = register_netdev(dev);
        if (err)
-@@ -704,31 +946,22 @@ ltq_etop_remove(struct platform_device *
+@@ -704,31 +943,22 @@ ltq_etop_remove(struct platform_device *
        return 0;
  }
  
index 58312f0c451e8859bd751eafce6460ea88024213..b816e9c430194851b70dd990f82d4187b832aad7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/staging/octeon/ethernet.c
 +++ b/drivers/staging/octeon/ethernet.c
-@@ -683,6 +683,7 @@ static int cvm_oct_probe(struct platform
+@@ -679,6 +679,7 @@ static int cvm_oct_probe(struct platform
        int interface;
        int fau = FAU_NUM_PACKET_BUFFERS_TO_FREE;
        int qos;
@@ -8,7 +8,7 @@
        struct device_node *pip;
        int mtu_overhead = ETH_HLEN + ETH_FCS_LEN;
  
-@@ -804,13 +805,19 @@ static int cvm_oct_probe(struct platform
+@@ -800,13 +801,19 @@ static int cvm_oct_probe(struct platform
        }
  
        num_interfaces = cvmx_helper_get_number_of_interfaces();
index 4ee6f8466099faaf29bf4a08158a3d870c9b50ac..e4dc3f96e52823b7bca9ab94a786fbc687ca2a1f 100644 (file)
@@ -12,19 +12,20 @@ Tested-by: Johannes Kimmel <fff@bareminimum.eu>
 Signed-off-by: Roman Kuzmitskii <damex.pp@icloud.com>
 --- a/drivers/staging/octeon/ethernet.c
 +++ b/drivers/staging/octeon/ethernet.c
-@@ -408,7 +408,11 @@ int cvm_oct_common_init(struct net_devic
+@@ -407,8 +407,12 @@ static int cvm_oct_common_set_mac_addres
  int cvm_oct_common_init(struct net_device *dev)
  {
        struct octeon_ethernet *priv = netdev_priv(dev);
 +      const u8 *label = NULL;
-       int ret;
-+
+       int ret;
 +      if (priv->of_node)
 +              label = of_get_property(priv->of_node, "label", NULL);
++
        ret = of_get_mac_address(priv->of_node, dev->dev_addr);
        if (ret)
-@@ -445,6 +448,9 @@ int cvm_oct_common_init(struct net_devic
+               eth_hw_addr_random(dev);
+@@ -441,6 +445,9 @@ int cvm_oct_common_init(struct net_devic
        if (dev->netdev_ops->ndo_stop)
                dev->netdev_ops->ndo_stop(dev);
  
index d11503c2c1d5ee59c2b24b7cb564262cc5f50383..4185fcba70d13f4a81f231ba3cf7943523a00c60 100644 (file)
@@ -12,7 +12,7 @@ Tested-by: Johannes Kimmel <fff@bareminimum.eu>
 Signed-off-by: Roman Kuzmitskii <damex.pp@icloud.com>
 --- a/drivers/staging/octeon/ethernet.c
 +++ b/drivers/staging/octeon/ethernet.c
-@@ -883,8 +883,10 @@ static int cvm_oct_probe(struct platform
+@@ -880,8 +880,10 @@ static int cvm_oct_probe(struct platform
  
                        case CVMX_HELPER_INTERFACE_MODE_SGMII:
                                priv->phy_mode = PHY_INTERFACE_MODE_SGMII;
index 8f4a2d98481ab823a909e7ff45e31a27435066b8..531a23ef4a78f58692ca10defa210731dc1cfcae 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: RenĂ© van Dorst <opensource@vdorst.com>
 
 --- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
 +++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
-@@ -2914,6 +2914,7 @@ static const struct net_device_ops mtk_n
+@@ -2911,6 +2911,7 @@ static const struct net_device_ops mtk_n
  
  static int mtk_add_mac(struct mtk_eth *eth, struct device_node *np)
  {
@@ -22,9 +22,9 @@ Signed-off-by: RenĂ© van Dorst <opensource@vdorst.com>
        const __be32 *_id = of_get_property(np, "reg", NULL);
        phy_interface_t phy_mode;
        struct phylink *phylink;
-@@ -3008,6 +3009,9 @@ static int mtk_add_mac(struct mtk_eth *e
-       
-       of_platform_device_create(np, NULL, NULL);
+@@ -3003,6 +3004,9 @@ static int mtk_add_mac(struct mtk_eth *e
+       eth->netdev[id]->max_mtu = MTK_MAX_RX_LENGTH - MTK_RX_ETH_HLEN;
  
 +      if (name)
 +              strlcpy(eth->netdev[id]->name, name, IFNAMSIZ);
index c1e2a6727294ebc1e919f6cba232a918cb07b7b9..f94d16c0ffa2375ddbbab19211511f24b127d05c 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  #include <linux/crc32.h>
  #include <linux/if_vlan.h>
  #include <linux/uaccess.h>
-@@ -5300,6 +5301,22 @@ static void rtl_tally_reset(struct r8152
+@@ -5301,6 +5302,22 @@ static void rtl_tally_reset(struct r8152
        ocp_write_word(tp, MCU_TYPE_PLA, PLA_RSTTALLY, ocp_data);
  }
  
@@ -45,7 +45,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  static void r8152b_init(struct r8152 *tp)
  {
        u32 ocp_data;
-@@ -5341,6 +5358,8 @@ static void r8152b_init(struct r8152 *tp
+@@ -5342,6 +5359,8 @@ static void r8152b_init(struct r8152 *tp
        ocp_data = ocp_read_word(tp, MCU_TYPE_USB, USB_USB_CTRL);
        ocp_data &= ~(RX_AGG_DISABLE | RX_ZERO_EN);
        ocp_write_word(tp, MCU_TYPE_USB, USB_USB_CTRL, ocp_data);
@@ -54,7 +54,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  }
  
  static void r8153_init(struct r8152 *tp)
-@@ -5486,6 +5505,8 @@ static void r8153_init(struct r8152 *tp)
+@@ -5487,6 +5506,8 @@ static void r8153_init(struct r8152 *tp)
                tp->coalesce = COALESCE_SLOW;
                break;
        }
@@ -63,7 +63,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  }
  
  static void r8153b_init(struct r8152 *tp)
-@@ -5572,6 +5593,8 @@ static void r8153b_init(struct r8152 *tp
+@@ -5573,6 +5594,8 @@ static void r8153b_init(struct r8152 *tp
        rtl_tally_reset(tp);
  
        tp->coalesce = 15000;   /* 15 us */