valgrind: bump to 3.19.0
authorRui Salvaterra <rsalvaterra@gmail.com>
Mon, 23 May 2022 09:59:30 +0000 (10:59 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Jun 2022 22:57:15 +0000 (00:57 +0200)
Patches automatically rebased.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
package/devel/valgrind/Makefile
package/devel/valgrind/patches/100-fix_configure_check.patch
package/devel/valgrind/patches/130-fix_arm_arch_detection.patch
package/devel/valgrind/patches/130-mips_fix_soft_float.patch

index e6ebff4b3003985e9a22ff353b28d839489f9be1..270aab6dba2702c40dc67e87dd7b37509f30d1f5 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=valgrind
-PKG_VERSION:=3.18.1
+PKG_VERSION:=3.19.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://sourceware.org/pub/valgrind/
-PKG_HASH:=00859aa13a772eddf7822225f4b46ee0d39afbe071d32778da4d99984081f7f5
+PKG_HASH:=dd5e34486f1a483ff7be7300cc16b4d6b24690987877c3278d797534d6738f02
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_LICENSE:=GPL-2.0+
index 6e9384ff8873d97a0a792a2cb6c9a41d8ed66ee5..38269bb14cd263d9c9d6cba2ad95fbb50dc0b8d1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -345,7 +345,7 @@ case "${host_os}" in
+@@ -368,7 +368,7 @@ case "${host_os}" in
          # Ok, this is linux. Check the kernel version
          AC_MSG_CHECKING([for the kernel version])
  
index 26291f777bb7b7c4cbbf673f74701bde8edcbe09..957e5c930fb6c46453e6547f4491c00b1665c573 100644 (file)
@@ -6,7 +6,7 @@ Last-Update: 2013-11-30
 
 --- a/configure.ac
 +++ b/configure.ac
-@@ -252,7 +252,7 @@ case "${host_cpu}" in
+@@ -275,7 +275,7 @@ case "${host_cpu}" in
          ARCH_MAX="s390x"
          ;;
  
index 427aa85524c38c976e155e4e83a835ae6ff9be68..9d3482815c49b1a7e3affd985317d51ef25aaf8e 100644 (file)
@@ -48,7 +48,7 @@ This fixes the following error message when compiling with a GCC 10 MIPS BE 32:
  
 --- a/coregrind/m_machine.c
 +++ b/coregrind/m_machine.c
-@@ -2103,6 +2103,7 @@ Bool VG_(machine_get_hwcaps)( void )
+@@ -2106,6 +2106,7 @@ Bool VG_(machine_get_hwcaps)( void )
             we are using alternative way to determine FP mode */
          ULong result = 0;
  
@@ -56,7 +56,7 @@ This fixes the following error message when compiling with a GCC 10 MIPS BE 32:
          if (!VG_MINIMAL_SETJMP(env_unsup_insn)) {
             __asm__ volatile (
                ".set push\n\t"
-@@ -2120,6 +2121,9 @@ Bool VG_(machine_get_hwcaps)( void )
+@@ -2123,6 +2124,9 @@ Bool VG_(machine_get_hwcaps)( void )
  
             fpmode = (result != 0x3FF0000000000000ull);
          }