image: introduce 'append-image-stage' build command
authorDaniel Golle <daniel@makrotopia.org>
Fri, 23 Apr 2021 22:05:54 +0000 (23:05 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 23 Apr 2021 22:16:49 +0000 (23:16 +0100)
Similar to 'append-image' this new command appends an existing binary.
'append-image-stage' also makes a copy of that binary and keeps it in
$(STAGING_DIR_IMAGE). When called from within the ImageBuilder, this
copy is used instead of expecting the binary to be present.
This is useful for artifacts which include the initramfs/recovery image
which is usually not included in the ImageBuilder.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/image-commands.mk

index 2c56ed8d1dafbebbb19ff5a2b1c535280f238ef7..4c9075c35b01f17704a7752c10da5d00cc7e5004 100644 (file)
@@ -31,6 +31,18 @@ define Build/append-image
        dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
 endef
 
+ifdef IB
+define Build/append-image-stage
+       dd if=$(STAGING_DIR_IMAGE)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
+endef
+else
+define Build/append-image-stage
+       dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) of=$(STAGING_DIR_IMAGE)/$(DEVICE_IMG_PREFIX)-$(1)
+       dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
+endef
+endif
+
+
 compat_version=$(if $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)
 json_quote=$(subst ','\'',$(subst ",\",$(1)))
 #")')