ath79: specify factory.bin recipe for ASUS RP-AC51
authorSungbo Eo <mans0n@gorani.run>
Sat, 17 Sep 2022 16:07:32 +0000 (01:07 +0900)
committerSungbo Eo <mans0n@gorani.run>
Sat, 17 Sep 2022 18:09:19 +0000 (03:09 +0900)
Currently factory.bin image recipe of ASUS RP-AC51 is not specified
explicitly and is thus set to the leaked one from the device recipe
right above, i.e. ASUS PL-AC56. Fix it to avoid potential breakage.

Fixes: 416d4483e878 ("ath79: add support for ASUS RP-AC51")
Signed-off-by: Sungbo Eo <mans0n@gorani.run>
target/linux/ath79/image/generic.mk

index 1ba02fc0fc512b9610bc0774f362db08573c2669..9d8b70712de1ee01139ae5acef5500c95df37e06 100644 (file)
@@ -402,6 +402,8 @@ define Device/asus_rp-ac51
   DEVICE_MODEL := RP-AC51
   IMAGE_SIZE := 16000k
   IMAGES += factory.bin
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+       append-rootfs | pad-rootfs
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct \
        -swconfig
 endef