at91bootstrap: use sdmmc0 as booting media for sama5d27_som1_ek
authorClaudiu Beznea <claudiu.beznea@microchip.com>
Thu, 28 Jul 2022 10:14:59 +0000 (13:14 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 2 Sep 2022 18:43:51 +0000 (20:43 +0200)
Commit 0b7c66c ("at91bootstrap: add sama5d27_som1_eksd1_uboot as
default defconfig") changed default booting media for sama5d27_som1_ek
board w/o any reason. Changed it back to sdmmc0 as it is for all the
other Microchip supported distributions for this board (Buildroot,
Yocto Project). The initial commit cannot be cleanly reverted.

Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
package/boot/at91bootstrap/Makefile
target/linux/at91/image/sama5.mk

index 1dd0f38fc2d218de7ee33196b530e114a1f4b344..efd42ecf5cc02c0fa2dd16e918865347b0bb16d7 100644 (file)
@@ -136,12 +136,6 @@ define AT91Bootstrap/sama5d27_som1_eksd_uboot
   BUILD_DEVICES:=microchip_sama5d27-som1-ek
 endef
 
-define AT91Bootstrap/sama5d27_som1_eksd1_uboot
-  TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard1)
-  BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=microchip_sama5d27-som1-ek
-endef
-
 define AT91Bootstrap/sama5d27_som1_ekqspi_uboot
   TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (QSPI Flash)
   BUILD_SUBTARGET:=sama5
@@ -193,7 +187,7 @@ AT91BOOTSTRAP_TARGETS := \
        sama5d4_xplainednf_uboot_secure \
        sama5d4_xplaineddf_uboot_secure \
        sama5d4_xplainedsd_uboot_secure \
-       sama5d27_som1_eksd1_uboot \
+       sama5d27_som1_eksd_uboot \
        sama5d27_som1_ekqspi_uboot \
        sama5d27_wlsom1_eksd_uboot \
        sama5d27_wlsom1_ekdf_qspi_uboot \
index d108d27908eabc0d1b9b165cce44bae369ca2e42..39db3e1cd022b3d140d659d772cc36b699cf434e 100644 (file)
@@ -19,8 +19,8 @@ define Build/at91-sdcard
        $(BIN_DIR)/u-boot-$(DEVICE_DTS:at91-%=%)_mmc/u-boot.bin \
        ::u-boot.bin
 
-      $(if $(findstring sama5d4-xplained,$@), \
-          mcopy -i $@.boot \
+  $(if $(findstring sama5d4-xplained,$@), \
+         mcopy -i $@.boot \
               $(BIN_DIR)/at91bootstrap-$(DEVICE_DTS:at91-%=%)sd_uboot_secure/at91bootstrap.bin \
               ::BOOT.bin,
           mcopy -i $@.boot \