ath79: combine OCEDO dual firmware-partitions
authorDavid Bauer <mail@david-bauer.net>
Tue, 15 Nov 2022 14:25:40 +0000 (15:25 +0100)
committerDavid Bauer <mail@david-bauer.net>
Sat, 7 Jan 2023 00:32:58 +0000 (01:32 +0100)
In order to maximize the available space on OCEDO boards using a
dual-image partition layout, combine the two OS partitions into a single
partition.

This allows users to access more usable space for additional packages.

Don't limit the usable image size to the size of a single OS partition.
The initial installation has to be done with an older version of OpenWrt
in case the generated image exceeds the space of a single OS
partition in the future.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/dts/ar9344_ocedo_raccoon.dts
target/linux/ath79/dts/qca9558_ocedo_koala.dts
target/linux/ath79/dts/qca9558_ocedo_ursus.dts
target/linux/ath79/image/generic.mk

index 8678315a44ac922dd92a04a689a9f55be522861d..11205413f4ce434f29d4db0c866765d3a2eb8e43 100644 (file)
                        };
 
                        partition@50000 {
+                               /* Dual-Flash layout combined */
                                compatible = "denx,uimage";
                                label = "firmware";
-                               reg = <0x050000 0x740000>;
-                       };
-
-                       partition@790000 {
-                               label = "vendor";
-                               reg = <0x790000 0x740000>;
-                               read-only;
+                               reg = <0x050000 0xe80000>;
                        };
 
                        partition@ed0000 {
index 8441e5c9a3c84b7b826d9b110ee1280d7696278b..85fd43699eec92c000fb4a44e191969e4faca03a 100644 (file)
                        };
 
                        partition@50000 {
+                               /* Dual-Flash layout combined */
                                compatible = "denx,uimage";
                                label = "firmware";
-                               reg = <0x050000 0x740000>;
-                       };
-
-                       partition@790000 {
-                               label = "vendor";
-                               reg = <0x790000 0x740000>;
-                               read-only;
+                               reg = <0x050000 0xe80000>;
                        };
 
                        partition@ed0000 {
index e99059df04740c238199a7d9ec830625a9915c11..be958d19a08cc2cf2143d61c2b402a40bcc5ec4c 100644 (file)
                        };
 
                        partition@50000 {
+                               /* Dual-Flash layout combined */
                                compatible = "denx,uimage";
                                label = "firmware";
-                               reg = <0x050000 0x740000>;
-                       };
-
-                       partition@790000 {
-                               label = "vendor";
-                               reg = <0x790000 0x740000>;
-                               read-only;
+                               reg = <0x050000 0xe80000>;
                        };
 
                        partition@ed0000 {
index 59bc449f125bd058a0ecfb3bf58bde4d18eea5ad..ec7cbb950ae094a690e74570818e6bbc443fd0ef 100644 (file)
@@ -1907,7 +1907,7 @@ define Device/ocedo_koala
   DEVICE_MODEL := Koala
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
   SUPPORTED_DEVICES += koala
-  IMAGE_SIZE := 7424k
+  IMAGE_SIZE := 14848k
 endef
 TARGET_DEVICES += ocedo_koala
 
@@ -1915,7 +1915,7 @@ define Device/ocedo_raccoon
   SOC := ar9344
   DEVICE_VENDOR := Ocedo
   DEVICE_MODEL := Raccoon
-  IMAGE_SIZE := 7424k
+  IMAGE_SIZE := 14848k
 endef
 TARGET_DEVICES += ocedo_raccoon
 
@@ -1924,7 +1924,7 @@ define Device/ocedo_ursus
   DEVICE_VENDOR := Ocedo
   DEVICE_MODEL := Ursus
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
-  IMAGE_SIZE := 7424k
+  IMAGE_SIZE := 14848k
 endef
 TARGET_DEVICES += ocedo_ursus