treewide: provide global default for SUPPORTED_DEVICES
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 19 Jan 2021 19:05:35 +0000 (20:05 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 23 Jan 2021 11:45:21 +0000 (12:45 +0100)
The majority of our targets provide a default value for the variable
SUPPORTED_DEVICES, which is used in images to check against the
compatible on a running device:

  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))

At the moment, this is implemented in the Device/Default block of
the individual targets or even subtargets. However, since we
standardized device names and compatible in the recent past, almost
all targets are following the same scheme now:

  device/image name:  vendor_model
  compatible:         vendor,model

The equal redundant definitions are a symptom of this process.

Consequently, this patch moves the definition to image.mk making it
a global default. For the few targets not using the scheme above,
SUPPORTED_DEVICES will be defined to a different value in
Device/Default anyway, overwriting the default. In other words:
This change is supposed to be cosmetic.

This can be used as a global measure to get the current compatible
with: $(firstword $(SUPPORTED_DEVICES))
(Though this is not precisely an achievement of this commit.)

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
23 files changed:
include/image.mk
target/linux/apm821xx/image/Makefile
target/linux/at91/image/Makefile
target/linux/ath79/image/Makefile
target/linux/bcm63xx/image/bcm63xx_nand.mk
target/linux/gemini/image/Makefile
target/linux/ipq40xx/image/Makefile
target/linux/ipq806x/image/Makefile
target/linux/kirkwood/image/Makefile
target/linux/lantiq/image/Makefile
target/linux/layerscape/image/armv7.mk
target/linux/layerscape/image/armv8_64b.mk
target/linux/mediatek/image/Makefile
target/linux/mpc85xx/image/Makefile
target/linux/mvebu/image/Makefile
target/linux/omap/image/Makefile
target/linux/oxnas/image/ox810se.mk
target/linux/oxnas/image/ox820.mk
target/linux/ramips/image/Makefile
target/linux/realtek/image/Makefile
target/linux/rockchip/image/Makefile
target/linux/sunxi/image/Makefile
target/linux/tegra/image/Makefile

index 8f46c75ffe55c1b9d8e7ad18554cdeb5b45c6116..6843b935f722e26953c08552125cc76bea5d27eb 100644 (file)
@@ -404,7 +404,7 @@ define Device/Init
   UIMAGE_NAME :=
   DEVICE_COMPAT_VERSION := 1.0
   DEVICE_COMPAT_MESSAGE :=
-  SUPPORTED_DEVICES :=
+  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   IMAGE_METADATA :=
 
   FILESYSTEMS := $(TARGET_FILESYSTEMS)
index 2331947e332e5447aec9becf779bfd7f7c7b6975..c1cb2bcfdd4ba92b400ba42e66b071fe80802011 100644 (file)
@@ -88,7 +88,6 @@ define Device/Default
   KERNEL_LOADADDR := 0x00000000
   DEVICE_DTS_DIR := ../dts
   DEVICE_DTS = $(subst _,-,$(1))
-  SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
 endef
 
 include $(SUBTARGET).mk
index 05f0b58af70eef41f7b309e999bfb5aefedbe391..25fc34eba026a8d07664d055fe790e2b0f348cd7 100644 (file)
@@ -25,7 +25,6 @@ define Device/Default
   PROFILES := Default
   FILESYSTEMS := squashfs ubifs ext4
   DEVICE_DTS = $(lastword $(subst _, ,$(1)))
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   KERNEL_NAME := zImage
   KERNEL_SIZE := 4096k
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
index 9bec159cf0ca6ce09f244bbf30202c0c6de4594d..4a51cf1fbfa0544e217142a81bf0575edc1ba3d3 100644 (file)
@@ -65,7 +65,6 @@ define Device/Default
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
   COMPILE :=
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \
        append-rootfs | pad-rootfs | append-metadata | check-size
index 81c328b712ec0bb31d115cbce87c31b9c5a38d10..5903d03632d1979ad14b593a1544a2f2cd029e04 100644 (file)
@@ -34,7 +34,6 @@ define Device/bcm63xx-nand
   CFE_WFI_FLAGS :=
   UBINIZE_OPTS := -E 5
   DEVICE_PACKAGES += nand-utils
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
 define Device/sercomm-nand
index 83f3d222d98b1a6843b7bbb079b12ce0f95f64b4..0eae4c6bd854559c29a03eeabb096dc81d0fbfbc 100644 (file)
@@ -130,7 +130,6 @@ define Device/Default
        KERNEL_NAME := zImage
        KERNEL := kernel-bin | append-dtb
        BLOCKSIZE := 128k
-       SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
 # A reasonable set of default packages handling the NAS type
index a764cb60af75ab965277c0189c1b3242ba238c1f..2be262936f7247da780e6673d1acae43b607b459 100644 (file)
@@ -8,7 +8,6 @@ define Device/Default
        KERNEL_PREFIX := $$(IMAGE_PREFIX)
        KERNEL_LOADADDR := 0x80208000
        DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
-       SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
        IMAGE/sysupgrade.bin/squashfs :=
index bc917d4fa481073fb8f423a81937c0b37af30a51..bab1da0090b5c603a8de872ef50b00197f7e1a2e 100644 (file)
@@ -30,7 +30,6 @@ define Device/Default
        KERNEL_PREFIX := $$(IMAGE_PREFIX)
        KERNEL_LOADADDR = 0x42208000
        DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
-       SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
        IMAGE/sysupgrade.bin/squashfs :=
index a9aad01f7f60de66e3bafbf805afc33bace733a2..9d2d60e55f2d69d12a1d42063424493dabdc7495 100644 (file)
@@ -30,7 +30,6 @@ define Device/Default
   IMAGES := sysupgrade.bin factory.bin
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   IMAGE/factory.bin := append-ubi
-  SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
 endef
 
 define Device/checkpoint_l-50
index b169d93859c1fd1c1389ecf97b4ecc9d9b1ebbb0..a4ba22dfc4b01bd2573b19fa75c1bafea009a46b 100644 (file)
@@ -65,7 +65,6 @@ define Device/Default
   FILESYSTEMS := squashfs
   SOC := $(DEFAULT_SOC)
   DEVICE_DTS = $$(SOC)_$(1)
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
 endef
index 08ef6cb9a1db3c487310df5ff979d198d0176215..62921a5ef964dd3de250c7b149d443bb913b7b69 100644 (file)
@@ -15,7 +15,6 @@ define Device/Default
   KERNEL_LOADADDR := 0x80008000
   KERNEL_ENTRY_POINT := 0x80008000
   DEVICE_DTS = $(lastword $(subst _, ,$(1)))
-  SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
   IMAGE_SIZE := 64m
   IMAGE/sysupgrade.bin = \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 1M | \
index 264f7dfd84d1e97c2715a15588ff9413f09945cf..a3f442829951dc2a1ea85d7a592bc4a53bc60e4f 100644 (file)
@@ -14,7 +14,6 @@ define Device/Default
   KERNEL_LOADADDR := 0x80080000
   KERNEL_ENTRY_POINT := 0x80080000
   DEVICE_DTS = freescale/$(subst _,-,$(1))
-  SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
   IMAGE_SIZE := 64m
   IMAGE/sysupgrade.bin = \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 1M | \
index 724bf430ef884b9f21ae5bb3ddb08813c57b5862..36ecdd5a9b12869d39511acb2cc19b0434f8d923 100644 (file)
@@ -31,7 +31,6 @@ define Device/Default
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := append-kernel | pad-to 128k | append-rootfs | \
        pad-rootfs | append-metadata
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
 include $(SUBTARGET).mk
index eb70db04db74ccfef323bda771da9ddbba706248..618b8c71358f849cf8d75ba798202eb373e6ff0c 100644 (file)
@@ -16,7 +16,6 @@ define Device/Default
   KERNEL_ENTRY := 0x00000000
   KERNEL_LOADADDR := 0x00000000
   KERNEL := kernel-bin
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
 include $(SUBTARGET).mk
index 502e081ec39ca285d10b4b609641cac84104509a..77548d683ee5f06b46f3e1c0c1bc5bfe2118b717 100644 (file)
@@ -105,7 +105,6 @@ define Device/Default
   KERNEL := kernel-bin | append-dtb | uImage none
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
-  SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
   UBINIZE_OPTS := -E 5
   UBOOT :=
   BOOT_SCRIPT :=
index ce6377f29b486488c875c22097eb82997a1de0fc..24c22165c292f3019225e1ab864dacafa99d0cb2 100644 (file)
@@ -38,7 +38,6 @@ define Device/Default
   DEVICE_DTS = $(lastword $(subst _, ,$(1)))
   IMAGES := sdcard.img.gz
   IMAGE/sdcard.img.gz := omap-sdcard | append-metadata | gzip
-  SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
 endef
 
 #uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
index b9bb5e7117c9d264ea728003fe3481b4a6497acd..77bdcc771609fb2646472a1140f8d4b1b33a39a8 100644 (file)
@@ -6,7 +6,6 @@ define Device/Default
   KERNEL_INSTALL := 1
   FILESYSTEMS := squashfs ext4
   PROFILES := Default
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   DEVICE_DTS := ox810se-$(subst _,-,$(1))
   IMAGES := sysupgrade.tar
   IMAGE/sysupgrade.tar := sysupgrade-tar | append-metadata
index a52e09786b8a66e1566ca4d71a87555e7195292f..8dea842503578edf60ea26790094174d780ec685 100644 (file)
@@ -10,7 +10,6 @@ define Device/Default
   SUBPAGESIZE := 512
   FILESYSTEMS := squashfs ubifs
   PROFILES := Default
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   DEVICE_DTS := ox820-$(subst _,-,$(1))
   KERNEL := kernel-bin | append-dtb | uImage none
   IMAGES := ubinized.bin sysupgrade.tar
index 4274c24884a7579d15274422b8b66127b286fd65..2fb13dcf08dd1786d1b9d40f5b1fdbb7a9c75e56 100644 (file)
@@ -187,7 +187,6 @@ define Device/Default
   DEVICE_DTS = $$(SOC)_$(1)
   IMAGES := sysupgrade.bin
   COMPILE :=
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   sysupgrade_bin := append-kernel | append-rootfs | pad-rootfs
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
 endef
index 1251b47c933db3dba69038aec25c46a6dd122b3d..87c616c3f20ab341ee44c380435d73419d543719 100644 (file)
@@ -13,7 +13,6 @@ define Device/Default
   KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | uImage gzip
   DEVICE_DTS_DIR := ../dts
   DEVICE_DTS = $$(SOC)_$(1)
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | \
        append-metadata | check-size
index 3c17e963bebee8839a04916eb139343151378555..022661623a993eaa8a1913192c80ea5c48777ca9 100644 (file)
@@ -52,7 +52,6 @@ define Device/Default
   PROFILES := Default
   KERNEL := kernel-bin
   IMAGES := sysupgrade.img.gz
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   DEVICE_DTS = rockchip/$$(SOC)-$(lastword $(subst _, ,$(1)))
 endef
 
index 01e9742b4602a4e72d086a868fe995c98201d70a..572c0597e8c6ac967447d7270009eee9f3c91d25 100644 (file)
@@ -37,7 +37,6 @@ define Device/Default
   KERNEL := kernel-bin | uImage none
   IMAGES := sdcard.img.gz
   IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   SUNXI_DTS_DIR :=
   SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
 endef
index 71a5fc581d83d901cfa35e07887e90b6ad6eef91..97f97e3cc2e42a6a657cd69efa2bc4803a9debdc 100644 (file)
@@ -38,7 +38,6 @@ define Device/Default
   KERNEL_NAME := zImage
   KERNEL := kernel-bin
   PROFILES := Default
-  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
 define Device/compulab_trimslice