cmake: Disable use of package registries
authorJeffery To <jeffery.to@gmail.com>
Mon, 17 Aug 2020 18:10:25 +0000 (02:10 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 24 Aug 2020 16:53:59 +0000 (18:53 +0200)
CMake provides a user package registry (stored in ~/.cmake/packages) and
a system package registry (not available on non-Windows platforms).

The "export(PACKAGE)" command may store information in the user package
registry, and the "find_package()" command may search both user and
system package registries for information.

This sets various variables to disable the use of these package
registries (both saving and retrieval of package information).

This also sets deprecated variables that perform similar functions, in
case external toolchains include older versions of CMake.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
include/cmake.mk

index a5ba7d31bf92a5463986009b2735d37a3859ad39..9dd95f5a64caba294c810db36110a2db524326a9 100644 (file)
@@ -71,6 +71,12 @@ define Build/Configure/Default
                        -DDL_LIBRARY=$(STAGING_DIR) \
                        -DCMAKE_PREFIX_PATH=$(STAGING_DIR) \
                        -DCMAKE_SKIP_RPATH=TRUE  \
+                       -DCMAKE_EXPORT_PACKAGE_REGISTRY=FALSE \
+                       -DCMAKE_EXPORT_NO_PACKAGE_REGISTRY=TRUE \
+                       -DCMAKE_FIND_USE_PACKAGE_REGISTRY=FALSE \
+                       -DCMAKE_FIND_PACKAGE_NO_PACKAGE_REGISTRY=TRUE \
+                       -DCMAKE_FIND_USE_SYSTEM_PACKAGE_REGISTRY=FALSE \
+                       -DCMAKE_FIND_PACKAGE_NO_SYSTEM_PACKAGE_REGISTRY=TRUE \
                        $(CMAKE_OPTIONS) \
                $(CMAKE_SOURCE_DIR) \
        )
@@ -104,6 +110,12 @@ define Host/Configure/Default
                        -DCMAKE_PREFIX_PATH=$(HOST_BUILD_PREFIX) \
                        -DCMAKE_SKIP_RPATH=TRUE  \
                        -DCMAKE_INSTALL_LIBDIR=lib \
+                       -DCMAKE_EXPORT_PACKAGE_REGISTRY=FALSE \
+                       -DCMAKE_EXPORT_NO_PACKAGE_REGISTRY=TRUE \
+                       -DCMAKE_FIND_USE_PACKAGE_REGISTRY=FALSE \
+                       -DCMAKE_FIND_PACKAGE_NO_PACKAGE_REGISTRY=TRUE \
+                       -DCMAKE_FIND_USE_SYSTEM_PACKAGE_REGISTRY=FALSE \
+                       -DCMAKE_FIND_PACKAGE_NO_SYSTEM_PACKAGE_REGISTRY=TRUE \
                        $(CMAKE_HOST_OPTIONS) \
                $(HOST_CMAKE_SOURCE_DIR) \
        )