procd: create /dev/fd symlink
authorErik Karlsson <erik.karlsson@genexis.eu>
Wed, 6 Sep 2023 10:33:17 +0000 (12:33 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 16 Sep 2023 18:48:34 +0000 (20:48 +0200)
This is needed for ksh/bash style process substitution such as
<(command) and >(command) which was introduced in ash as of busybox
version 1.34.0 to work.

Signed-off-by: Erik Karlsson <erik.karlsson@genexis.eu>
package/system/procd/Makefile
package/system/procd/files/hotplug.json

index d0576c12595dee044f00c1089af43caffd4c2d44..7c829260d5ef89321f05a0b0f1d6acc2d95b4972 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
index b930b307a4f3cb34bc3346192987f95ff3f27e31..9fecddae6be1f088e6ec5e7ab68a1d186cf5251c 100644 (file)
@@ -11,6 +11,7 @@
                                                [ "eq", "DEVNAME", "null" ],
                                                [
                                                        [ "makedev", "/dev/%DEVNAME%", "0666" ],
+                                                       [ "exec", "/bin/ln", "-s", "/proc/self/fd", "/dev/fd" ],
                                                        [ "exec", "/bin/ln", "-s", "/proc/self/fd/0", "/dev/stdin" ],
                                                        [ "exec", "/bin/ln", "-s", "/proc/self/fd/1", "/dev/stdout" ],
                                                        [ "exec", "/bin/ln", "-s", "/proc/self/fd/2", "/dev/stderr" ],