build: make sure modules are modposted after initramfs image is built
authorFelix Fietkau <nbd@openwrt.org>
Sun, 5 Oct 2014 16:58:16 +0000 (16:58 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 5 Oct 2014 16:58:16 +0000 (16:58 +0000)
Otherwise the modpost steps for individual modules that are compiled
manually (using make package/<name_of_module>/install) will give warning
of missing symbols when that module depends other modules.

This is caused by the Module.symvers file not containing any symbols
anymore of external modules when the initramfs image is built without
specifically giving the modules target.

Signed-off-by: Tjalling Hattink <t.hattink@fugro.nl>
SVN-Revision: 42773

include/kernel-defaults.mk

index da06abd0a54e0bd7f8068d53cf7eb8294d09e4a9..523cd5c4837533492fa7e1c222d78d30a3687be9 100644 (file)
@@ -150,7 +150,7 @@ endef
 
 define Kernel/CompileImage/Default
        rm -f $(TARGET_DIR)/init
-       +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME))
+       +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME)) modules
        #")
        $(call Kernel/CopyImage)
 endef
@@ -160,7 +160,7 @@ define Kernel/CompileImage/Initramfs
        $(call Kernel/Configure/Initramfs)
        $(CP) $(GENERIC_PLATFORM_DIR)/base-files/init $(TARGET_DIR)/init
        rm -rf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/usr/initramfs_data.cpio*
-       +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME))
+       +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME)) modules
        #")
        #")
        $(call Kernel/CopyImage,-initramfs)