base-files: wifi: add support for 802.11ad
authorDaniel Golle <daniel@makrotopia.org>
Mon, 4 Jan 2021 18:53:40 +0000 (18:53 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 5 Jan 2021 02:16:24 +0000 (02:16 +0000)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/base-files/Makefile
package/base-files/files/sbin/wifi

index da3976424f35881326a3c0646992fe2da409c5da..8d40eb0e49cbc8afe1ee3f0c747a45e2dd426ed0 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=244
+PKG_RELEASE:=245
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index a8b4451c605ec1b3cd683854a67d975119a2e1cd..75759b94f34a9e9f7724023808d5ea18f79a9947 100755 (executable)
@@ -79,6 +79,7 @@ wifi_fixup_hwmode() {
        case "$hwmode" in
                11bg) hwmode=bg;;
                11a) hwmode=a;;
+               11ad) hwmode=ad;;
                11b) hwmode=b;;
                11g) hwmode=g;;
                11n*)