ar71xx: add support for the TRENDNet TEW-673GRU board
authorGabor Juhos <juhosg@openwrt.org>
Wed, 8 Feb 2012 16:26:25 +0000 (16:26 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 8 Feb 2012 16:26:25 +0000 (16:26 +0000)
SVN-Revision: 30376

12 files changed:
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/network
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-2.6.39
target/linux/ar71xx/config-3.2
target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-tew-673gru.c [new file with mode: 0644]
target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/machtype.h
target/linux/ar71xx/files-3.2/arch/mips/ath79/mach-tew-673gru.c [new file with mode: 0644]
target/linux/ar71xx/patches-3.2/611-MIPS-ath79-TEW673GRU-support.patch [new file with mode: 0644]

index 775911301565ff4a32b75e78c6dacc677da6d771..3d57854afad98dbe0c50f9239ed09d4e8c488fc1 100755 (executable)
@@ -98,6 +98,9 @@ get_status_led() {
        tew-632brp)
                status_led="tew-632brp:green:status"
                ;;
+       tew-673gru)
+               status_led="trendnet:blue:wps"
+               ;;
        tl-mr3020)
                status_led="tp-link:green:wps"
                ;;
index 613b2a0e87a26fb1d9a9787df6dfaba0387955ed..4dfb43c6733b9915eda40ba03add2a6af530256d 100755 (executable)
@@ -25,7 +25,8 @@ db120)
        ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 4"
        ;;
 
-dir-825-b1)
+dir-825-b1|\
+tew-673gru)
        ucidef_set_interfaces_lan_wan "eth0.1" "eth1"
        ucidef_add_switch "rtl8366s" "1" "1"
        ucidef_add_switch_vlan "rtl8366s" "1" "0 1 2 3 5t"
index 82b53f161793cc9483b350cab1f9570773347e89..ab619f1694b25a0a73e74f6c8c7ca5f2379f568e 100755 (executable)
@@ -256,6 +256,9 @@ ar71xx_board_detect() {
        *TEW-632BRP)
                name="tew-632brp"
                ;;
+       *TEW-673GRU)
+               name="tew-673gru"
+               ;;
        *TL-WR1043ND)
                name="tl-wr1043nd"
                ;;
index 3adfcd58b34ea15eae12ee1f61884230c75733c5..91b04c5deaa09ee0e84eed8ea7bf59dfa20b9780 100755 (executable)
@@ -102,6 +102,7 @@ platform_check_image() {
        mzk-w04nu | \
        mzk-w300nh | \
        tew-632brp | \
+       tew-673gru | \
        wrt400n | \
        airrouter | \
        bullet-m | \
index 4f51b1a2b97424032766d1d54c3f72b23d886110..dd422b107807a754a0918936bd08f0f1d1611615 100644 (file)
@@ -41,6 +41,7 @@ CONFIG_AR71XX_MACH_RB4XX=y
 CONFIG_AR71XX_MACH_RB750=y
 CONFIG_AR71XX_MACH_RW2458N=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
+CONFIG_AR71XX_MACH_TEW_673GRU=y
 CONFIG_AR71XX_MACH_TL_MR11U=y
 CONFIG_AR71XX_MACH_TL_MR3020=y
 CONFIG_AR71XX_MACH_TL_MR3X20=y
index 50fe18fd95af8670fe146b554e617ba2c69e687c..dd05e9401ed5b2dcb598ed4b7cd16bfa58cc0041 100644 (file)
@@ -50,6 +50,7 @@ CONFIG_ATH79_MACH_RB4XX=y
 CONFIG_ATH79_MACH_RB750=y
 CONFIG_ATH79_MACH_RW2458N=y
 CONFIG_ATH79_MACH_TEW_632BRP=y
+CONFIG_ATH79_MACH_TEW_673GRU=y
 CONFIG_ATH79_MACH_TL_MR11U=y
 CONFIG_ATH79_MACH_TL_MR3020=y
 CONFIG_ATH79_MACH_TL_MR3X20=y
index 02d88c876f4d94cd1496a62bb68fdd7411651d08..f40c8d992f30a84a33c595c376297c3b2c571969 100644 (file)
@@ -425,6 +425,15 @@ config AR71XX_MACH_TEW_632BRP
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_NVRAM
 
+config AR71XX_MACH_TEW_673GRU
+       bool "TRENDnet TEW-673GRU support"
+       select SOC_AR71XX
+       select AR71XX_DEV_M25P80
+       select AR71XX_DEV_AP94_PCI if PCI
+       select AR71XX_DEV_GPIO_BUTTONS
+       select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
+
 config AR71XX_MACH_UBNT
        bool "Ubiquiti AR71xx based boards support"
        select SOC_AR71XX
index 22e32e5acc69979ef329cd69b3f57e389d6ff557..23c95cad572217954d811cb5f03dc3c23dfe9d0b 100644 (file)
@@ -56,7 +56,8 @@ obj-$(CONFIG_AR71XX_MACH_RB4XX)               += mach-rb4xx.o
 obj-$(CONFIG_AR71XX_MACH_RB750)                += mach-rb750.o
 obj-$(CONFIG_AR71XX_MACH_RW2458N)      += mach-rw2458n.o
 obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)   += mach-tew-632brp.o
-obj-$(CONFIG_AR71XX_MACH_TL_MR11U)     += mach-tl-mr11u.o
+obj-$(CONFIG_AR71XX_MACH_TEW_673GRU)   += mach-tew-673gru.o
+obj-$(CONFIG_AR71XX_MACH_TL_MR11U)     += mach-tl-mr11u.o
 obj-$(CONFIG_AR71XX_MACH_TL_MR3020)    += mach-tl-mr3020.o
 obj-$(CONFIG_AR71XX_MACH_TL_MR3X20)    += mach-tl-mr3x20.o
 obj-$(CONFIG_AR71XX_MACH_TL_WA901ND)   += mach-tl-wa901nd.o
diff --git a/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-tew-673gru.c b/target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-tew-673gru.c
new file mode 100644 (file)
index 0000000..f1d26e6
--- /dev/null
@@ -0,0 +1,220 @@
+/*
+ *  TRENDnet TEW-673GRU board support
+ *
+ *  Copyright (C) 2012 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/delay.h>
+#include <linux/rtl8366.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/spi_gpio.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "machtype.h"
+#include "devices.h"
+#include "dev-m25p80.h"
+#include "dev-ap94-pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-usb.h"
+
+#define TEW673GRU_GPIO_LCD_SCK         0
+#define TEW673GRU_GPIO_LCD_MOSI                1
+#define TEW673GRU_GPIO_LCD_MISO                2
+#define TEW673GRU_GPIO_LCD_CS          6
+
+#define TEW673GRU_GPIO_LED_WPS         9
+
+#define TEW673GRU_GPIO_BTN_RESET       3
+#define TEW673GRU_GPIO_BTN_WPS         8
+
+#define TEW673GRU_GPIO_RTL8366_SDA     5
+#define TEW673GRU_GPIO_RTL8366_SCK     7
+
+#define TEW673GRU_KEYS_POLL_INTERVAL   20 /* msecs */
+#define TEW673GRU_KEYS_DEBOUNCE_INTERVAL (3 * TEW673GRU_KEYS_POLL_INTERVAL)
+
+#define TEW673GRU_CAL_LOCATION_0       0x1f661000
+#define TEW673GRU_CAL_LOCATION_1       0x1f665000
+#define TEW673GRU_MAC_LOCATION_0       0x1f66ffa0
+#define TEW673GRU_MAC_LOCATION_1       0x1f66ffb4
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition tew673gru_partitions[] = {
+       {
+               .name           = "uboot",
+               .offset         = 0,
+               .size           = 0x040000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "config",
+               .offset         = 0x040000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "firmware",
+               .offset         = 0x050000,
+               .size           = 0x610000,
+       }, {
+               .name           = "caldata",
+               .offset         = 0x660000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "unknown",
+               .offset         = 0x670000,
+               .size           = 0x190000,
+               .mask_flags     = MTD_WRITEABLE,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data tew673gru_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .parts          = tew673gru_partitions,
+       .nr_parts       = ARRAY_SIZE(tew673gru_partitions),
+#endif
+};
+
+static struct gpio_led tew673gru_leds_gpio[] __initdata = {
+       {
+               .name           = "trendnet:blue:wps",
+               .gpio           = TEW673GRU_GPIO_LED_WPS,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button tew673gru_gpio_keys[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = TEW673GRU_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TEW673GRU_GPIO_BTN_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = TEW673GRU_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TEW673GRU_GPIO_BTN_WPS,
+               .active_low     = 1,
+       }
+};
+
+static struct rtl8366_initval tew673gru_rtl8366s_initvals[] = {
+       { .reg = 0x06, .val = 0x0108 },
+};
+
+static struct rtl8366_platform_data tew673gru_rtl8366s_data = {
+       .gpio_sda       = TEW673GRU_GPIO_RTL8366_SDA,
+       .gpio_sck       = TEW673GRU_GPIO_RTL8366_SCK,
+       .num_initvals   = ARRAY_SIZE(tew673gru_rtl8366s_initvals),
+       .initvals       = tew673gru_rtl8366s_initvals,
+};
+
+static struct platform_device tew673gru_rtl8366s_device = {
+       .name           = RTL8366S_DRIVER_NAME,
+       .id             = -1,
+       .dev = {
+               .platform_data  = &tew673gru_rtl8366s_data,
+       }
+};
+
+static struct spi_board_info tew673gru_spi_info[] = {
+       {
+               .bus_num        = 1,
+               .chip_select    = 0,
+               .max_speed_hz   = 400000,
+               .modalias       = "spidev",
+               .mode           = SPI_MODE_2,
+               .controller_data = (void *) TEW673GRU_GPIO_LCD_CS,
+       },
+};
+
+static struct spi_gpio_platform_data tew673gru_spi_data = {
+       .sck            = TEW673GRU_GPIO_LCD_SCK,
+       .miso           = TEW673GRU_GPIO_LCD_MISO,
+       .mosi           = TEW673GRU_GPIO_LCD_MOSI,
+       .num_chipselect = 1,
+};
+
+static struct platform_device tew673gru_spi_device = {
+       .name           = "spi_gpio",
+       .id             = 1,
+       .dev = {
+               .platform_data = &tew673gru_spi_data,
+       },
+};
+
+static void tew673gru_read_ascii_mac(u8 *dest, unsigned int src_addr)
+{
+       int ret;
+       u8 *src = (u8 *)KSEG1ADDR(src_addr);
+
+       ret = sscanf(src, "%02hhx:%02hhx:%02hhx:%02hhx:%02hhx:%02hhx",
+                    &dest[0], &dest[1], &dest[2],
+                    &dest[3], &dest[4], &dest[5]);
+
+       if (ret != ETH_ALEN) memset(dest, 0, ETH_ALEN);
+}
+
+static void __init tew673gru_setup(void)
+{
+       u8 mac1[ETH_ALEN], mac2[ETH_ALEN];
+
+       tew673gru_read_ascii_mac(mac1, TEW673GRU_MAC_LOCATION_0);
+       tew673gru_read_ascii_mac(mac2, TEW673GRU_MAC_LOCATION_1);
+
+       ar71xx_add_device_mdio(0, 0x0);
+
+       ar71xx_init_mac(ar71xx_eth0_data.mac_addr, mac1, 2);
+       ar71xx_eth0_data.mii_bus_dev = &tew673gru_rtl8366s_device.dev;
+       ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ar71xx_eth0_data.speed = SPEED_1000;
+       ar71xx_eth0_data.duplex = DUPLEX_FULL;
+       ar71xx_eth0_pll_data.pll_1000 = 0x11110000;
+
+       ar71xx_init_mac(ar71xx_eth1_data.mac_addr, mac1, 3);
+       ar71xx_eth1_data.mii_bus_dev = &tew673gru_rtl8366s_device.dev;
+       ar71xx_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ar71xx_eth1_data.phy_mask = 0x10;
+       ar71xx_eth1_pll_data.pll_1000 = 0x11110000;
+
+       ar71xx_add_device_eth(0);
+       ar71xx_add_device_eth(1);
+
+       ar71xx_add_device_m25p80(&tew673gru_flash_data);
+
+       ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(tew673gru_leds_gpio),
+                                       tew673gru_leds_gpio);
+
+       ar71xx_register_gpio_keys_polled(-1, TEW673GRU_KEYS_POLL_INTERVAL,
+                                        ARRAY_SIZE(tew673gru_gpio_keys),
+                                        tew673gru_gpio_keys);
+
+       ar71xx_add_device_usb();
+
+       platform_device_register(&tew673gru_rtl8366s_device);
+
+       ap94_pci_setup_wmac_led_pin(0, 5);
+       ap94_pci_setup_wmac_led_pin(1, 5);
+
+       ap94_pci_init((u8 *) KSEG1ADDR(TEW673GRU_CAL_LOCATION_0), mac1,
+                     (u8 *) KSEG1ADDR(TEW673GRU_CAL_LOCATION_1), mac2);
+
+       spi_register_board_info(tew673gru_spi_info,
+                               ARRAY_SIZE(tew673gru_spi_info));
+       platform_device_register(&tew673gru_spi_device);
+}
+
+MIPS_MACHINE(AR71XX_MACH_TEW_673GRU, "TEW-673GRU", "TRENDnet TEW-673GRU",
+            tew673gru_setup);
index 82fc944cb36c671e05f42715e94a99896bb0fb35..f114017ecca21b41ca3876a5dccf0ea6338a2242 100644 (file)
@@ -53,6 +53,7 @@ enum ar71xx_mach_type {
        AR71XX_MACH_RB_750,     /* MikroTik RouterBOARD 750 */
        AR71XX_MACH_RW2458N,    /* Redwave RW2458N */
        AR71XX_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
+       AR71XX_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
        AR71XX_MACH_TL_MR11U,  /* TP-LINK TL-MR11U */
        AR71XX_MACH_TL_MR3020,  /* TP-LINK TL-MR3020 */
        AR71XX_MACH_TL_MR3220,  /* TP-LINK TL-MR3220 */
diff --git a/target/linux/ar71xx/files-3.2/arch/mips/ath79/mach-tew-673gru.c b/target/linux/ar71xx/files-3.2/arch/mips/ath79/mach-tew-673gru.c
new file mode 100644 (file)
index 0000000..71f2ec0
--- /dev/null
@@ -0,0 +1,217 @@
+/*
+ *  TRENDnet TEW-673GRU board support
+ *
+ *  Copyright (C) 2012 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/delay.h>
+#include <linux/rtl8366.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/spi_gpio.h>
+
+#include <asm/mach-ath79/ath79.h>
+
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "machtypes.h"
+
+#define TEW673GRU_GPIO_LCD_SCK         0
+#define TEW673GRU_GPIO_LCD_MOSI                1
+#define TEW673GRU_GPIO_LCD_MISO                2
+#define TEW673GRU_GPIO_LCD_CS          6
+
+#define TEW673GRU_GPIO_LED_WPS         9
+
+#define TEW673GRU_GPIO_BTN_RESET       3
+#define TEW673GRU_GPIO_BTN_WPS         8
+
+#define TEW673GRU_GPIO_RTL8366_SDA     5
+#define TEW673GRU_GPIO_RTL8366_SCK     7
+
+#define TEW673GRU_KEYS_POLL_INTERVAL   20 /* msecs */
+#define TEW673GRU_KEYS_DEBOUNCE_INTERVAL (3 * TEW673GRU_KEYS_POLL_INTERVAL)
+
+#define TEW673GRU_CAL_LOCATION_0       0x1f661000
+#define TEW673GRU_CAL_LOCATION_1       0x1f665000
+
+#define TEW673GRU_MAC_LOCATION_0       0x1f66ffa0
+#define TEW673GRU_MAC_LOCATION_1       0x1f66ffb4
+
+static struct mtd_partition tew673gru_partitions[] = {
+       {
+               .name           = "uboot",
+               .offset         = 0,
+               .size           = 0x040000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "config",
+               .offset         = 0x040000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "firmware",
+               .offset         = 0x050000,
+               .size           = 0x610000,
+       }, {
+               .name           = "caldata",
+               .offset         = 0x660000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "unknown",
+               .offset         = 0x670000,
+               .size           = 0x190000,
+               .mask_flags     = MTD_WRITEABLE,
+       }
+};
+
+static struct flash_platform_data tew673gru_flash_data = {
+       .parts          = tew673gru_partitions,
+       .nr_parts       = ARRAY_SIZE(tew673gru_partitions),
+};
+
+static struct gpio_led tew673gru_leds_gpio[] __initdata = {
+       {
+               .name           = "trendnet:blue:wps",
+               .gpio           = TEW673GRU_GPIO_LED_WPS,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button tew673gru_gpio_keys[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = TEW673GRU_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TEW673GRU_GPIO_BTN_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = TEW673GRU_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TEW673GRU_GPIO_BTN_WPS,
+               .active_low     = 1,
+       }
+};
+
+static struct rtl8366_initval tew673gru_rtl8366s_initvals[] = {
+       { .reg = 0x06, .val = 0x0108 },
+};
+
+static struct rtl8366_platform_data tew673gru_rtl8366s_data = {
+       .gpio_sda       = TEW673GRU_GPIO_RTL8366_SDA,
+       .gpio_sck       = TEW673GRU_GPIO_RTL8366_SCK,
+       .num_initvals   = ARRAY_SIZE(tew673gru_rtl8366s_initvals),
+       .initvals       = tew673gru_rtl8366s_initvals,
+};
+
+static struct platform_device tew673gru_rtl8366s_device = {
+       .name           = RTL8366S_DRIVER_NAME,
+       .id             = -1,
+       .dev = {
+               .platform_data  = &tew673gru_rtl8366s_data,
+       }
+};
+
+static struct spi_board_info tew673gru_spi_info[] = {
+       {
+               .bus_num        = 1,
+               .chip_select    = 0,
+               .max_speed_hz   = 400000,
+               .modalias       = "spidev",
+               .mode           = SPI_MODE_2,
+               .controller_data = (void *) TEW673GRU_GPIO_LCD_CS,
+       },
+};
+
+static struct spi_gpio_platform_data tew673gru_spi_data = {
+       .sck            = TEW673GRU_GPIO_LCD_SCK,
+       .miso           = TEW673GRU_GPIO_LCD_MISO,
+       .mosi           = TEW673GRU_GPIO_LCD_MOSI,
+       .num_chipselect = 1,
+};
+
+static struct platform_device tew673gru_spi_device = {
+       .name           = "spi_gpio",
+       .id             = 1,
+       .dev = {
+               .platform_data = &tew673gru_spi_data,
+       },
+};
+
+static void tew673gru_read_ascii_mac(u8 *dest, unsigned int src_addr)
+{
+       int ret;
+       u8 *src = (u8 *)KSEG1ADDR(src_addr);
+
+       ret = sscanf(src, "%02hhx:%02hhx:%02hhx:%02hhx:%02hhx:%02hhx",
+                    &dest[0], &dest[1], &dest[2],
+                    &dest[3], &dest[4], &dest[5]);
+
+       if (ret != ETH_ALEN) memset(dest, 0, ETH_ALEN);
+}
+
+static void __init tew673gru_setup(void)
+{
+       u8 mac1[ETH_ALEN], mac2[ETH_ALEN];
+
+       tew673gru_read_ascii_mac(mac1, TEW673GRU_MAC_LOCATION_0);
+       tew673gru_read_ascii_mac(mac2, TEW673GRU_MAC_LOCATION_1);
+
+       ath79_register_mdio(0, 0x0);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac1, 2);
+       ath79_eth0_data.mii_bus_dev = &tew673gru_rtl8366s_device.dev;
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ath79_eth0_data.speed = SPEED_1000;
+       ath79_eth0_data.duplex = DUPLEX_FULL;
+       ath79_eth0_pll_data.pll_1000 = 0x11110000;
+
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac1, 3);
+       ath79_eth1_data.mii_bus_dev = &tew673gru_rtl8366s_device.dev;
+       ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ath79_eth1_data.phy_mask = 0x10;
+       ath79_eth1_pll_data.pll_1000 = 0x11110000;
+
+       ath79_register_eth(0);
+       ath79_register_eth(1);
+
+       ath79_register_m25p80(&tew673gru_flash_data);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(tew673gru_leds_gpio),
+                                tew673gru_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, TEW673GRU_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(tew673gru_gpio_keys),
+                                       tew673gru_gpio_keys);
+
+       ath79_register_usb();
+
+       platform_device_register(&tew673gru_rtl8366s_device);
+
+       ap9x_pci_setup_wmac_led_pin(0, 5);
+       ap9x_pci_setup_wmac_led_pin(1, 5);
+
+       ap94_pci_init((u8 *) KSEG1ADDR(TEW673GRU_CAL_LOCATION_0), mac1,
+                     (u8 *) KSEG1ADDR(TEW673GRU_CAL_LOCATION_1), mac2);
+
+       spi_register_board_info(tew673gru_spi_info,
+                               ARRAY_SIZE(tew673gru_spi_info));
+       platform_device_register(&tew673gru_spi_device);
+}
+
+MIPS_MACHINE(ATH79_MACH_TEW_673GRU, "TEW-673GRU", "TRENDnet TEW-673GRU",
+            tew673gru_setup);
diff --git a/target/linux/ar71xx/patches-3.2/611-MIPS-ath79-TEW673GRU-support.patch b/target/linux/ar71xx/patches-3.2/611-MIPS-ath79-TEW673GRU-support.patch
new file mode 100644 (file)
index 0000000..0758c99
--- /dev/null
@@ -0,0 +1,40 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -491,6 +491,17 @@ config ATH79_MACH_TEW_632BRP
+       select ATH79_DEV_WMAC
+       select ATH79_NVRAM
++config ATH79_MACH_TEW_673GRU
++      bool "TRENDnet TEW-673GRU support"
++      select SOC_AR71XX
++      select ATH79_DEV_AP9X_PCI if PCI
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_USB
++      select ATH79_NVRAM
++
+ config ATH79_MACH_UBNT
+       bool "Ubiquiti AR71xx based boards support"
+       select SOC_AR71XX
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -53,6 +53,7 @@ enum ath79_mach_type {
+       ATH79_MACH_RB_750,              /* MikroTik RouterBOARD 750 */
+       ATH79_MACH_RW2458N,             /* Redwave RW2458N */
+       ATH79_MACH_TEW_632BRP,          /* TRENDnet TEW-632BRP */
++      ATH79_MACH_TEW_673GRU,          /* TRENDnet TEW-673GRU */
+       ATH79_MACH_TL_MR11U,            /* TP-LINK TL-MR11U */
+       ATH79_MACH_TL_MR3020,           /* TP-LINK TL-MR3020 */
+       ATH79_MACH_TL_MR3220,           /* TP-LINK TL-MR3220 */
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -64,6 +64,7 @@ obj-$(CONFIG_ATH79_MACH_RB4XX)               += mach-
+ obj-$(CONFIG_ATH79_MACH_RB750)                += mach-rb750.o
+ obj-$(CONFIG_ATH79_MACH_RW2458N)      += mach-rw2458n.o
+ obj-$(CONFIG_ATH79_MACH_TEW_632BRP)   += mach-tew-632brp.o
++obj-$(CONFIG_ATH79_MACH_TEW_673GRU)   += mach-tew-673gru.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR11U)     += mach-tl-mr11u.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR3020)    += mach-tl-mr3020.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR3X20)    += mach-tl-mr3x20.o