ramips: Added WIZnet WizFi630A Platform based on Ralink RT5350
authorJohn Crispin <john@openwrt.org>
Mon, 14 Sep 2015 20:09:31 +0000 (20:09 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 14 Sep 2015 20:09:31 +0000 (20:09 +0000)
This patch is to add the WIZnet WizFi630A board as a new platform. The board is in mini pci express form factor.

Signed-off-by: Tobias Welz <tw@wiznet.eu>
SVN-Revision: 46921

target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WIZFI630A.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/wiznet.mk [new file with mode: 0644]

index 02cd6824d094e35b86120fd17f3bf0335e38a1c2..75cccae0fb7cec75fb562c4398595166333417e3 100755 (executable)
@@ -218,6 +218,12 @@ ramips_setup_interfaces()
                ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 6t"
                ucidef_add_switch_vlan "switch0" "2" "5 6t"
                ;;
+       wizfi630a)
+               ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
+               ucidef_add_switch "switch0" "1" "1"
+               ucidef_add_switch_vlan "switch0" "1" "1 2 6t"
+               ucidef_add_switch_vlan "switch0" "2" "0 6t"
+               ;;
        y1s)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "switch0" "1" "1"
@@ -328,6 +334,10 @@ ramips_setup_macs()
                wan_mac=$(mtd_get_mac_binary factory 4)
                lan_mac=$wan_mac
                ;;
+       wizfi630a)
+               lan_mac=$(mtd_get_mac_binary factory 4)
+               wan_mac=$(mtd_get_mac_binary factory 40)
+               ;;
        wsr-1166)
                local index="$(find_mtd_index "board_data")"
                wan_mac="$(grep -m1 mac= "/dev/mtd${index}" | cut -d= -f2)"
index f886b5da8accfb409c9016b035a4bc64217009b3..7fc6f29727e1cc2e3c41096f13d9ca3f9ecbe807 100644 (file)
@@ -166,6 +166,9 @@ get_status_led() {
        wzr-agl300nh)
                status_led="$board:green:router"
                ;;
+       wizfi630a)
+               status_led="$board::run"
+               ;;
        wsr-1166|\
        wsr-600)
                status_led="$board:orange:diag"
index 5b6808e0b314f17c1f9390da21f800c61def9ae4..d24223556449f838cff6d2f68ff67d6226c25532 100755 (executable)
@@ -370,6 +370,9 @@ ramips_board_detect() {
        *"WIZARD 8800")
                name="wizard8800"
                ;;
+       *"WizFi630A")
+               name="wizfi630a"
+               ;;                
        *"WL-330N")
                name="wl-330n"
                ;;
index 844ed5db95dc54f9529694fec69d787a667cb838..2f6c6246ab5a7e2b7e57861edc83665b9cd679db 100755 (executable)
@@ -108,6 +108,7 @@ platform_check_image() {
        whr-300hp2|\
        whr-600d|\
        whr-g300n|\
+       wizfi630a|\
        wl-330n|\
        wl-330n3g|\
        wl-341v3|\
diff --git a/target/linux/ramips/dts/WIZFI630A.dts b/target/linux/ramips/dts/WIZFI630A.dts
new file mode 100644 (file)
index 0000000..f2818ce
--- /dev/null
@@ -0,0 +1,180 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "wizfi630a", "ralink,rt5350-soc";
+       model = "WIZnet WizFi630A";
+
+       chosen {
+               bootargs = "console=ttyS1,115200";
+       };
+
+       palmbus@10000000 {
+               gpio1: gpio@660 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "w25q128";
+                               reg = <0>;
+                               linux,modalias = "m25p80", "w25q128";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "uboot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "uboot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+                       };
+               };
+
+               uart@500 {
+                       compatible = "ralink,mt7620a-uart", "ralink,rt2880-uart", "ns16550a";
+                       reg = <0x500 0x100>;
+                       resets = <&rstctrl 12>;
+                       reset-names = "uart";
+                       interrupt-parent = <&intc>;
+                       interrupts = <5>;
+                       reg-shift = <2>;
+                       status = "okay";
+               };
+
+               uartlite@c00 {
+                       compatible = "ralink,mt7620a-uart", "ralink,rt2880-uart", "ns16550a";
+                       reg = <0xc00 0x100>;
+                       resets = <&rstctrl 19>;
+                       reset-names = "uartl";
+                       interrupt-parent = <&intc>;
+                       interrupts = <12>;
+                       reg-shift = <2>;
+                       pinctrl-names = "default";
+                       pinctrl-0 = <&uartlite_pins>;
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "jtag" ;
+                               ralink,function = "gpio";
+                       };
+               };
+
+               uartf_gpio_pins: uartf_gpio {
+                       uartf_gpio {
+                               ralink,group = "uartf";
+                               ralink,function = "uartf";
+                       };
+               };
+
+               uartlite_pins: uartlite {
+                       uart {
+                               ralink,group = "uartlite";
+                               ralink,function = "uartlite";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x17>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       gpio-export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               run {
+                       label = "wizfi630a::run";
+                       gpios = <&gpio0 1 1>;
+               };
+
+               wps {
+                       label = "wizfi630a::wps";
+                       gpios = <&gpio0 20 1>;
+               };
+
+               uart1 {
+                       label = "wizfi630a::uart1";
+                       gpios = <&gpio0 18 1>;
+               };
+
+               uart2 {
+                       label = "wizfi630a::uart2";
+                       gpios = <&gpio0 21 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 17 1>;
+                       linux,code = <0x198>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 0 1>;
+                       linux,code = <0x211>;
+               };
+               
+               scm1 {
+                       label = "SCM1";
+                       gpios = <&gpio0 19 1>;
+                       linux,code = <0x100>;
+               };
+
+               scm2 {
+                       label = "SCM2";
+                       gpios = <&gpio0 2 1>;
+                       linux,code = <0x101>;
+               };
+       };
+};
index 4632ad2cd3447ac0e2eb8cabbe82367e5f482ba1..c24d220032420ffb8f2d633e2c183977b0a688ae 100644 (file)
@@ -608,7 +608,6 @@ Image/Build/Profile/W502U=$(call BuildFirmware/Default8M/$(1),$(1),w502u,W502U)
 
 Image/Build/Profile/WCR150GN=$(call BuildFirmware/Default4M/$(1),$(1),wcr150gn,WCR150GN)
 
-
 Image/Build/Profile/MZK-DP150N=$(call BuildFirmware/Default4M/$(1),$(1),mzk-dp150n,MZK-DP150N)
 
 buffalo_whrg300n_mtd_size=3801088
@@ -631,6 +630,8 @@ Image/Build/Profile/WHRG300N=$(call BuildFirmware/WHRG300N/$(1),$(1))
 
 Image/Build/Profile/WIZARD8800=$(call BuildFirmware/Default8M/$(1),$(1),wizard-8800,WIZARD8800,Linux Kernel Image)
 
+Image/Build/Profile/WIZFI630A=$(call BuildFirmware/Default16M/$(1),$(1),wizfi630a,WIZFI630A)
+
 Image/Build/Profile/WL-330N=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n,WL-330N)
 
 Image/Build/Profile/WL-330N3G=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n3g,WL-330N3G)
@@ -763,6 +764,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/WCR150GN,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
        $(call Image/Build/Profile/WIZARD8800,$(1))
+       $(call Image/Build/Profile/WIZFI630A,$(1))
        $(call Image/Build/Profile/WL-330N,$(1))
        $(call Image/Build/Profile/WL-330N3G,$(1))
        $(call Image/Build/Profile/WL-341V3,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/wiznet.mk b/target/linux/ramips/rt305x/profiles/wiznet.mk
new file mode 100644 (file)
index 0000000..f8e8324
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WIZFI630A
+       NAME:=WIZnet WizFi630A
+       PACKAGES:=\
+               kmod-usb2 
+endef
+
+define Profile/WIZFI630A/Description
+       Package set for WIZnet WizFi630A board
+endef
+$(eval $(call Profile,WIZFI630A))