[toolchain/gcc]: simplify configuration
authorImre Kaloz <kaloz@openwrt.org>
Sat, 2 Jul 2011 07:50:26 +0000 (07:50 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sat, 2 Jul 2011 07:50:26 +0000 (07:50 +0000)
SVN-Revision: 27353

toolchain/gcc/Config.in
toolchain/gcc/common.mk

index 556a56955fc5f5a9478804310561c94a0543169d..75d388dc65353179550ed7e2a1936147b7c21fd7 100644 (file)
@@ -25,7 +25,7 @@ endchoice
 config GCC_USE_GRAPHITE
        bool
        prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
-       depends GCC_VERSION_4_4 || GCC_VERSION_4_5 || GCC_VERSION_4_6
+       depends !GCC_VERSION_LLVM
 
 config GCC_USE_SYSTEM_PPL_CLOOG
        bool
index 2762f6ad09236cbb6a469c781d172ecbdb6ceef1..d2177c54680274506cd602dfa31af86ced29e5f0 100644 (file)
@@ -104,27 +104,20 @@ GCC_CONFIGURE:= \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
                $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
 
-ifneq ($(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
-  ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
-    GCC_CONFIGURE += --with-mips-plt
-  endif
-endif
-
 ifeq ($(CONFIG_GCC_LLVM),)
   GCC_BUILD_TARGET_LIBGCC:=y
   GCC_CONFIGURE+= \
                --with-gmp=$(TOPDIR)/staging_dir/host \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
                --disable-decimal-float
+  ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+    GCC_CONFIGURE += --with-mips-plt
+  endif
 endif
 
 ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
-  GCC_BUILD_TARGET_LIBGCC:=y
   GCC_CONFIGURE+= \
-                --with-gmp=$(TOPDIR)/staging_dir/host \
-                --with-mpc=$(TOPDIR)/staging_dir/host \
-                --with-mpfr=$(TOPDIR)/staging_dir/host \
-                --disable-decimal-float
+               --with-mpc=$(TOPDIR)/staging_dir/host
 endif
 
 ifneq ($(CONFIG_SSP_SUPPORT),)