[package] mac80211: configure hostapd logging options
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 20 Aug 2011 00:14:48 +0000 (00:14 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 20 Aug 2011 00:14:48 +0000 (00:14 +0000)
SVN-Revision: 28057

package/mac80211/Makefile
package/mac80211/files/lib/wifi/mac80211.sh

index cb1080fd3ec32795101a0229bab8acca8486c4f5..307916216c450584d4558939f47a52857f0b1a20 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=2011-08-10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 PKG_MD5SUM:=fb2ee04eaafbdf4117c475ba78f8f5b9
 
index 86ec75cec300d05c4f1eb179ac19369a12adf46c..9ef1d12623054e7d20d499b7b2d27ff6bbd05aa5 100644 (file)
@@ -16,6 +16,9 @@ mac80211_hostapd_setup_base() {
        config_get beacon_int "$device" beacon_int
        config_get basic_rate_list "$device" basic_rate
        config_get_bool noscan "$device" noscan
+
+       hostapd_set_log_options base_cfg "$device"
+
        [ -n "$channel" -a -z "$hwmode" ] && wifi_fixup_hwmode "$device"
 
        [ "$channel" = auto ] && {