Add freetype package
authorNicolas Thill <nico@openwrt.org>
Wed, 10 Aug 2005 21:09:56 +0000 (21:09 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 10 Aug 2005 21:09:56 +0000 (21:09 +0000)
SVN-Revision: 1601

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/freetype/Config.in [new file with mode: 0644]
openwrt/package/freetype/Makefile [new file with mode: 0644]
openwrt/package/freetype/ipkg/libfreetype.control [new file with mode: 0644]

index e562df838470bd3bb755fff67531cc21c77c6d91..fdec45a054bf000a09fd24119ed154dd1e98595e 100644 (file)
@@ -109,6 +109,7 @@ source "package/libamsel/Config.in"
 source "package/libdb/Config.in"
 source "package/libelf/Config.in"
 source "package/libevent/Config.in"
+source "package/freetype/Config.in"  # libfreetype
 source "package/libgcrypt/Config.in"
 source "package/libgd/Config.in"
 source "package/libgdbm/Config.in"
index 008b4bf55a71bf6a03b0904ab9df337811d1c84c..7ba30f968551dd88a13ab8642da64ee7e8a18842 100644 (file)
@@ -32,6 +32,7 @@ package-$(BR2_PACKAGE_FPING) += fping
 package-$(BR2_PACKAGE_FPROBE) += fprobe
 package-$(BR2_PACKAGE_FPROBE_ULOG) += fprobe-ulog
 package-$(BR2_PACKAGE_FREERADIUS) += freeradius
+package-$(BR2_PACKAGE_FREETYPE) += freetype
 package-$(BR2_PACKAGE_FRICKIN) += frickin
 package-$(BR2_PACKAGE_FUSE) += fuse
 package-$(BR2_PACKAGE_GDBSERVER) += gdbserver
@@ -167,6 +168,7 @@ bind-compile: openssl-compile
 cyrus-sasl-compile: openssl-compile
 dropbear-compile: zlib-compile
 dsniff-compile: libnids-compile openssl-compile libgdbm-compile
+freetype-compile: zlib-compile
 fprobe-compile: libpcap-compile
 gdbserver-compile: ncurses-compile
 gnutls-compile: libgcrypt-compile opencdk-compile libtasn1-compile
diff --git a/openwrt/package/freetype/Config.in b/openwrt/package/freetype/Config.in
new file mode 100644 (file)
index 0000000..1bed3cf
--- /dev/null
@@ -0,0 +1,26 @@
+config BR2_PACKAGE_FREETYPE
+       bool
+       default n
+       depends BR2_PACKAGE_LIBFREETYPE
+
+config BR2_PACKAGE_LIBFREETYPE
+       tristate "libfreetype - A free, high-quality and portable font engine"
+#      default m if CONFIG_DEVEL
+       default n
+       select BR2_PACKAGE_FREETYPE
+       select BR2_PACKAGE_ZLIB
+       help
+         The FreeType project is a team of volunteers who develop free,
+         portable and high-quality software solutions for digital typography.
+         They specifically target embedded systems and focus on bringing small,
+         efficient and ubiquitous products.
+         
+         The FreeType 2 library is their new software font engine.  It has been
+         designed to provide the following important features:
+          * A universal and simple API to manage font files
+          * Support for several font formats through loadable modules
+          * High-quality anti-aliasing
+          * High portability & performance
+         
+         http://www.freetype.org/
+         
diff --git a/openwrt/package/freetype/Makefile b/openwrt/package/freetype/Makefile
new file mode 100644 (file)
index 0000000..c99cb72
--- /dev/null
@@ -0,0 +1,88 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libfreetype
+PKG_VERSION:=2.1.9
+PKG_RELEASE:=1
+PKG_MD5SUM:=ec1b903e4be5f073caa72458ea58c29c
+
+PKG_SOURCE_URL:=@SF/freetype
+PKG_SOURCE:=freetype-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/freetype-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBFREETYPE,libfreetype,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               $(TARGET_CONFIGURE_OPTS) \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --sbindir=/usr/sbin \
+                       --libexecdir=/usr/lib \
+                       --sysconfdir=/etc \
+                       --datadir=/usr/share \
+                       --localstatedir=/var \
+                       --mandir=/usr/man \
+                       --infodir=/usr/info \
+                       $(DISABLE_NLS) \
+                       $(DISABLE_LARGEFILE) \
+                       --enable-shared=yes \
+                       --enable-static=yes \
+                       --disable-rpath \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_LIBFREETYPE):
+       install -d -m0755 $(IDIR_LIBFREETYPE)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libfreetype.so.* $(IDIR_LIBFREETYPE)/usr/lib/
+       $(RSTRIP) $(IDIR_LIBFREETYPE)
+       $(IPKG_BUILD) $(IDIR_LIBFREETYPE) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/libfreetype.so: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(STAGING_DIR)/usr/bin/
+       mkdir -p $(STAGING_DIR)/usr/include
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/freetype2 $(STAGING_DIR)/usr/include/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/ft2build.h $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libfreetype.{a,so*} $(STAGING_DIR)/usr/lib/
+       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       touch $@
+
+install-dev: $(STAGING_DIR)/usr/lib/libfreetype.so
+
+uninstall-dev:
+       rm -rf \
+               $(STAGING_DIR)/usr/bin/freetype-config \
+               $(STAGING_DIR)/usr/include/freetype2 \
+               $(STAGING_DIR)/usr/include/ft2build.h \
+               $(STAGING_DIR)/usr/lib/libfreetype.{a,so*} \
+               $(STAGING_DIR)/usr/lib/pkgconfig/freetype2.pc \
+
+compile: install-dev
+clean: uninstall-dev
diff --git a/openwrt/package/freetype/ipkg/libfreetype.control b/openwrt/package/freetype/ipkg/libfreetype.control
new file mode 100644 (file)
index 0000000..bf9f9c7
--- /dev/null
@@ -0,0 +1,18 @@
+Package: libfreetype
+Priority: optional
+Section: libs
+Maintainer: Oliver Ertl <oliver@ertl-net.net>, OpenWrt Developers <bugs@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/freetype/
+Depends: zlib
+Description: A free, high-quality and portable font engine. 
+ The FreeType project is a team of volunteers who develop free,
+ portable and high-quality software solutions for digital typography.
+ They specifically target embedded systems and focus on bringing small,
+ efficient and ubiquitous products.
+         
+ The FreeType 2 library is their new software font engine.  It has been
+ designed to provide the following important features:
+  * A universal and simple API to manage font files
+  * Support for several font formats through loadable modules
+  * High-quality anti-aliasing
+  * High portability & performance