[package] 6in4: automatically determine wan interface in hotplug events
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 9 Jul 2010 00:17:31 +0000 (00:17 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 9 Jul 2010 00:17:31 +0000 (00:17 +0000)
SVN-Revision: 22102

package/6in4/Makefile
package/6in4/files/6in4.hotplug

index d88ee160668000f3472aa5f7bdf6248ba4d3cc51..75e7848825c5e4ec60e0345ddd2dfbdcc7cbbb3d 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=2
+PKG_VERSION:=3
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 0a196c25b0feb10623959679e896bcbdac4a411b..96b046d14d39d107a4388e2c82271068d10d16fb 100644 (file)
@@ -14,7 +14,7 @@ if [ "$ACTION" = ifup ]; then
                [ "$proto" = 6in4 ] || return 0
 
                local wandev
-               config_get wandev "$cfg" wan_device
+               config_get wandev "$cfg" wan_device "$(find_6in4_wanif)"
                [ "$wandev" = "$DEVICE" ] || return 0
 
                local oldip