update motion package, add a patch to honor CPPFLAGS,
authorNicolas Thill <nico@openwrt.org>
Mon, 27 Mar 2006 20:36:45 +0000 (20:36 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 27 Mar 2006 20:36:45 +0000 (20:36 +0000)
explicitely remove database support, add MD5SUMS,
add dependency on libpthread in ipkg/control file,
standardize.

SVN-Revision: 3509

openwrt/package/motion/Makefile
openwrt/package/motion/ipkg/motion.control
openwrt/package/motion/patches/02-honor_cppflags.patch [new file with mode: 0644]

index 1cc30398e0ac3117e382e7f697b8b96f8793d46d..a5a5681815071e63172bae3b82a34356215e7c4e 100644 (file)
@@ -1,8 +1,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
-PKG_VERSION:=3.2.5.1
+PKG_VERSION:=3.2.6
 PKG_RELEASE:=1
+PKG_MD5SUM:=71e6bd13fcca70372e9b7c7806d62b30
 
 PKG_SOURCE_URL:=http://superb.dl.sourceforge.net/sourceforge/motion
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -18,15 +19,33 @@ $(eval $(call PKG_template,MOTION,motion,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        (cd $(PKG_BUILD_DIR); \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --prefix=/usr \
-               --sysconfdir=/etc \
-               --with-jpeg-mmx="$(STAGING_DIR)/usr" \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --without-ffmpeg \
+                       --without-jpeg-mmx \
+                       --without-mysql \
+                       --without-pgsql \
        );
        touch $@
 
@@ -34,18 +53,16 @@ $(PKG_BUILD_DIR)/.built:
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
        touch $@
 
 $(IPKG_MOTION):
        install -d -m0755 $(IDIR_MOTION)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/motion $(IDIR_MOTION)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/motion $(IDIR_MOTION)/usr/bin/
        $(RSTRIP) $(IDIR_MOTION)
        $(IPKG_BUILD) $(IDIR_MOTION) $(PACKAGE_DIR)
 
 mostlyclean:
-       make -C $(PKG_BUILD_DIR) clean
-       rm $(PKG_BUILD_DIR)/.built
-
+       -$(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm -f $(PKG_BUILD_DIR)/.built
index 5bf192298e3b31cbed993c00cb0f8b77069135a6..44a0c2b9147d6635596a212afed993376f8f020e 100644 (file)
@@ -1,8 +1,5 @@
 Package: motion
 Priority: optional
 Section: multimedia
-Maintainer: Jeroen Vreeken <pe1rxq@amsat.org>
-Source: http://www.lavrsen.dk
-Depends: libjpeg
+Depends: libjpeg, libpthread
 Description: Webcam motion sensing and logging
-
diff --git a/openwrt/package/motion/patches/02-honor_cppflags.patch b/openwrt/package/motion/patches/02-honor_cppflags.patch
new file mode 100644 (file)
index 0000000..322fb77
--- /dev/null
@@ -0,0 +1,20 @@
+diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
+--- motion-3.2.5.1-old/Makefile.in     2006-03-07 22:52:49.000000000 +0100
++++ motion-3.2.5.1-new/Makefile.in     2006-03-27 22:04:34.000000000 +0200
+@@ -32,6 +32,7 @@
+ ################################################################################
+ CFLAGS       = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
+              -Dsysconfdir=\"$(sysconfdir)\"
++CPPFLAGS     = @CPPFLAGS@
+ LDFLAGS      = @LDFLAGS@
+ LIBS         = @LIBS@ 
+ VIDEO_OBJ    = @VIDEO@
+@@ -115,7 +116,7 @@
+ ################################################################################
+ $(DEPEND_FILE): *.h $(SRC)
+       @echo "Generating dependencies, please wait..."
+-      @$(CC) $(CFLAGS) -M $(SRC) > .tmp
++      @$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
+       @mv -f .tmp $(DEPEND_FILE)
+       @echo