kernel: add garmin_gps module
authorJohn Crispin <john@openwrt.org>
Thu, 2 Apr 2015 14:31:10 +0000 (14:31 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 2 Apr 2015 14:31:10 +0000 (14:31 +0000)
OpenWrt on sailboats
requested: https://forum.openwrt.org/viewtopic.php?id=56586

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 45232

package/kernel/linux/modules/usb.mk

index e3d7165f47e3a51369a338734f75518c06a202f3..fc47568dbc646a81665e83b7af655ec294bda671 100644 (file)
@@ -631,6 +631,21 @@ endef
 $(eval $(call KernelPackage,usb-serial-ftdi))
 
 
+define KernelPackage/usb-serial-garmin
+  TITLE:=Support for Garmin GPS devices
+  KCONFIG:=CONFIG_USB_SERIAL_GARMIN
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/garmin_gps.ko
+  AUTOLOAD:=$(call AutoProbe,garmin_gps)
+  $(call AddDepends/usb-serial)
+endef
+
+define KernelPackage/usb-serial-garmin/description
+ Should work with most Garmin GPS devices which have a native USB port.
+endef
+
+$(eval $(call KernelPackage,usb-serial-garmin))
+
+
 define KernelPackage/usb-serial-ti-usb
   TITLE:=Support for TI USB 3410/5052
   KCONFIG:=CONFIG_USB_SERIAL_TI