package/dnsmasq: update to 2.59 (thanks to Raphael Huck)
authorNicolas Thill <nico@openwrt.org>
Fri, 25 Nov 2011 00:53:13 +0000 (00:53 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 25 Nov 2011 00:53:13 +0000 (00:53 +0000)
SVN-Revision: 29329

package/dnsmasq/Makefile
package/dnsmasq/patches/101-ipv6.patch

index 1294a8b45fa897c40f15be49936b1d76d6776fd4..1f99b5014b3d3fd3a5f644fbaf2b8eddfaf8af97 100644 (file)
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.58
-PKG_RELEASE:=2
+PKG_VERSION:=2.59
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=14c5c81debb324adc261db971730f4c6
+PKG_MD5SUM:=b5757ef2d7b651748eeebb88af29d7d6
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -35,20 +37,15 @@ endef
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               BINDIR="/usr/sbin" \
-               MANDIR="/usr/man" \
-               AWK="awk" \
-               LDFLAGS="-Wl,--gc-sections" \
-               all
-endef
+MAKE_FLAGS := \
+       $(TARGET_CONFIGURE_OPTS) \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       LDFLAGS="-Wl,--gc-sections" \
+       PREFIX="/usr"
 
 define Package/dnsmasq/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dnsmasq $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
        $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
index dff18d41d7449401b685a277d8b925f0905ef8f5..5a0c01b141a1962167504c61c8fe9c8bac1fec5c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/config.h
 +++ b/src/config.h
-@@ -257,8 +257,9 @@ NOTES:
+@@ -263,8 +263,9 @@ NOTES:
  /* We assume that systems which don't have IPv6
     headers don't have ntop and pton either */