brcm63xx: Add DT support for AR-5381u
authorJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:18 +0000 (11:28 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:18 +0000 (11:28 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42239

27 files changed:
target/linux/brcm63xx/dts/ar-5381u.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/550-alice_gate2_leds.patch
target/linux/brcm63xx/patches-3.14/551-96348gw_a_leds.patch
target/linux/brcm63xx/patches-3.14/552-board_96348gw-10_reset_button.patch
target/linux/brcm63xx/patches-3.14/553-boards_probe_switch.patch
target/linux/brcm63xx/patches-3.14/554-board_DWVS0_leds_buttons.patch
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/comtrend.mk

diff --git a/target/linux/brcm63xx/dts/ar-5381u.dts b/target/linux/brcm63xx/dts/ar-5381u.dts
new file mode 100644 (file)
index 0000000..812108a
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6328.dtsi"
+
+/ {
+       model = "Comtrend AR-5381u";
+       compatible = "comtrend,ar-5381u", "brcm,bcm6328";
+};
index f3782ee941ee2ffd4131cede136e499cc46fc33b..3050d2c588212b311f523532b8b2041d4c08734f 100755 (executable)
@@ -271,8 +271,6 @@ define Image/Build
        # Sagem F@ST2504n
        $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
 
-       # Comtrend AR-5381u
-       $(call Image/Build/CFE,$(1),96328A-1241N,6328,AR-5381u,,--pad 8)
        # Comtrend AR-5387un
        $(call Image/Build/CFE,$(1),96328A-1441N1,6328,AR-5387un,,--pad 8)
        # Comtrend VR-3025u
@@ -357,6 +355,8 @@ $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-16M-fl
 
 # Asmax AR 1004g
 $(eval $(call CfeImageDTB,AR1004G,ar1004g,96348GW-10,6348,AR1004G))
+# Comtrend AR-5381u
+$(eval $(call CfeImageDTB,AR5381u,ar-5381u,96328A-1241N,6328,AR-5381u,,--pad 8))
 # Comtrend 536, 5621
 $(eval $(call CfeImageDTB,CT536_CT5621,ct536plus,96348GW-11,6348,CT536_CT5621))
 # Comtrend CT-5365
index 118af0e4d5aab9d3990190dc05dc9e61e888273a..ada24fffb9127a7cff46440962aef7ed999868d9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -166,6 +166,91 @@ static struct board_info __initdata boar
+@@ -166,6 +166,92 @@ static struct board_info __initdata boar
        },
  };
  
@@ -15,6 +15,7 @@
 +
 +static struct board_info __initdata board_AR5381u = {
 +      .name                                   = "96328A-1241N",
++      .of_board_id                            = "comtrend,ar-5381u",
 +      .expected_cpu_id                        = 0x6328,
 +
 +      .has_uart0                              = 1,
@@ -92,7 +93,7 @@
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
-@@ -2930,6 +3015,7 @@ static const struct board_info __initcon
+@@ -2930,6 +3016,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 64ca2cd94b44aa377481d9eec2860e532ecb6cc8..cc650d96d7deab06670773d9b3f3ac8e6a2229e7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -838,6 +838,55 @@ static struct board_info __initdata boar
+@@ -839,6 +839,55 @@ static struct board_info __initdata boar
  
        .has_uart0                      = 1,
  };
@@ -56,7 +56,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3029,6 +3078,7 @@ static const struct board_info __initcon
+@@ -3030,6 +3079,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
index 29f3d7c5aad7fc22b6315b6f45d12f0335ca48da..d0f7ef99c293c06976a14fe5d378a7a7663cb5ad 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -2676,6 +2677,405 @@ static struct board_info __initdata boar
+@@ -2677,6 +2678,405 @@ static struct board_info __initdata boar
        },
  };
  
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
-@@ -3114,6 +3514,9 @@ static const struct board_info __initcon
+@@ -3115,6 +3515,9 @@ static const struct board_info __initcon
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_HW553,
index b22334a5b49cecee86ff5ce076c02420d1e21d77..01da5fbb1dfa9597d42c78c01997e65f3afe0a2a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -888,6 +888,60 @@ static struct board_info __initdata boar
+@@ -889,6 +889,60 @@ static struct board_info __initdata boar
                },
        },
  };
@@ -61,7 +61,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3479,6 +3533,7 @@ static const struct board_info __initcon
+@@ -3480,6 +3534,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
index 6ff06481504a639367af5f9229247f52390ec0e8..9ebeb06a423e9992af14967d94fd786c8fe13b25 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -662,6 +662,122 @@ static struct board_info __initdata boar
+@@ -663,6 +663,122 @@ static struct board_info __initdata boar
                },
        },
  };
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -3523,6 +3639,7 @@ static const struct board_info __initcon
+@@ -3524,6 +3640,7 @@ static const struct board_info __initcon
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
index cc8ca322583ed03eb33db1ad984f03a7ae5311cd..109868c233f356c50c6d6fe09a36df5b3c46d7f4 100644 (file)
@@ -6,7 +6,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3478,6 +3478,96 @@ static struct board_info __initdata boar
+@@ -3479,6 +3479,96 @@ static struct board_info __initdata boar
        .devs = nb6_devices,
        .num_devs = ARRAY_SIZE(nb6_devices),
  };
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
-@@ -3695,6 +3785,7 @@ static const struct board_info __initcon
+@@ -3696,6 +3786,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
index 8245cbbfdf92ef722df8e69540fc6de099aefd30..2cc1db357ffc68445adb899e4f4380919e082d21 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2303,6 +2303,99 @@ static struct board_info __initdata boar
+@@ -2304,6 +2304,99 @@ static struct board_info __initdata boar
  
        .has_ohci0 = 1,
        .has_ehci0 = 1,
index 43a841e1d14abb02ab2bd718dd8ea2f18edcfcdf..50017095f7e696c303eabbce612c359fd4760387 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1774,6 +1774,19 @@ static struct board_info __initdata boar
+@@ -1775,6 +1775,19 @@ static struct board_info __initdata boar
        },
  
        .has_ohci0 = 1,
index 6da086edea7a9e9630347dfece694f3caf2695dd..b6ed7930e9a1489cc792ae0dc9a8203e23d24f27 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1170,6 +1170,17 @@ static struct board_info __initdata boar
+@@ -1171,6 +1171,17 @@ static struct board_info __initdata boar
                        .active_low     = 1,
                },
        },
index be615ba25cc6245583732352842a6886e933bc6a..7f735e05a642645f972e222de5f67de32f09819f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -792,6 +792,8 @@ static struct board_info __initdata boar
+@@ -793,6 +793,8 @@ static struct board_info __initdata boar
        .has_uart0                      = 1,
        .has_enet0                      = 1,
        .enet0 = {
@@ -9,7 +9,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -836,6 +838,8 @@ static struct board_info __initdata boar
+@@ -837,6 +839,8 @@ static struct board_info __initdata boar
        .has_uart0                      = 1,
        .has_enet0                      = 1,
        .enet0 = {
@@ -18,7 +18,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1126,6 +1130,8 @@ static struct board_info __initdata boar
+@@ -1127,6 +1131,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -27,7 +27,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1200,6 +1206,8 @@ static struct board_info __initdata boar
+@@ -1201,6 +1207,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -36,7 +36,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1481,6 +1489,8 @@ static struct board_info __initdata boar
+@@ -1482,6 +1490,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -45,7 +45,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1660,6 +1670,8 @@ static struct board_info __initdata boar
+@@ -1661,6 +1671,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -54,7 +54,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1736,6 +1748,8 @@ static struct board_info __initdata boar
+@@ -1737,6 +1749,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -63,7 +63,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1759,6 +1773,8 @@ static struct board_info __initdata boar
+@@ -1760,6 +1774,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -72,7 +72,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1780,6 +1796,8 @@ static struct board_info __initdata boar
+@@ -1781,6 +1797,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -81,7 +81,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2125,6 +2143,8 @@ static struct board_info __initdata boar
+@@ -2126,6 +2144,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -90,7 +90,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2179,6 +2199,8 @@ static struct board_info __initdata boar
+@@ -2180,6 +2200,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -99,7 +99,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2321,6 +2343,8 @@ static struct board_info __initdata boar
+@@ -2322,6 +2344,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2440,6 +2464,8 @@ static struct board_info __initdata boar
+@@ -2441,6 +2465,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
index 998a4d7bff6d498808c2175b5050caa4e7ab6155..56840a8d1cbea38b8fe3608e1c07c96b2efb1579 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2472,6 +2472,94 @@ static struct board_info __initdata boar
+@@ -2473,6 +2473,94 @@ static struct board_info __initdata boar
  
        .has_ohci0                      = 1,
        .has_ehci0                      = 1,
index a4de6a286b9785345039b53f985ba4374a05d06f..081a9bbc137c19f26c087e8bf50eca8b4dd47c2f 100644 (file)
@@ -94,7 +94,7 @@
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
-@@ -3953,6 +4040,9 @@ static const struct board_info __initcon
+@@ -3954,6 +4041,9 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
index dbe0ebaa3c0265c377abf0a2b0da25c78ba88678..25cfde937c4b67c38aff7c210a5c6ae0dae33de8 100644 (file)
@@ -95,7 +95,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -4042,6 +4130,7 @@ static const struct board_info __initcon
+@@ -4043,6 +4131,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
index 093cdcbb072820e966044b81abaab98422022be4..16f6283b1be1b9c98a476a3cb310f69c4d46d571 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4122,6 +4122,75 @@ static struct board_info __initdata boar
+@@ -4123,6 +4123,75 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
@@ -76,7 +76,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4202,6 +4271,9 @@ static const struct board_info __initcon
+@@ -4203,6 +4272,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
index 7438e1617f73382f68a58ece2511aa66946edbb1..1060e71d82a3109664a84c0858dac71f536f61d8 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1432,6 +1432,52 @@ static struct board_info __initdata boar
+@@ -1433,6 +1433,52 @@ static struct board_info __initdata boar
        },
  };
  
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -4242,6 +4288,7 @@ static const struct board_info __initcon
+@@ -4243,6 +4289,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
index 6ddfd22621de720fb28a49b26ad1fe7e000b467d..1c76d9f67d637e2b298ac5a5a7c835c715c24da0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4234,6 +4234,108 @@ static struct board_info __initdata boar
+@@ -4235,6 +4235,108 @@ static struct board_info __initdata boar
                },
        },
  };
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -4320,6 +4422,7 @@ static const struct board_info __initcon
+@@ -4321,6 +4423,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
index 97d5a343b7233a3a2ed3e4026a9075285cbcfef3..023dc0bdc0448e45739368022a638ef58489b140 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4171,6 +4171,131 @@ static struct board_info __initdata boar
+@@ -4172,6 +4172,131 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -4421,6 +4546,7 @@ static const struct board_info __initcon
+@@ -4422,6 +4547,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 89d93aead57de64584cd53111b0ce1315000bd73..ffff144b6fc991d3fb0c9eb0d1e3c061cf0a553c 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4165,6 +4166,117 @@ static struct board_info __initdata boar
+@@ -4166,6 +4167,117 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4544,6 +4656,7 @@ static const struct board_info __initcon
+@@ -4545,6 +4657,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 38c6e073b46a9257e06ae1325da8d2aaf97c4a81..65aef42deb89b7680c9ad715cb58b4308533fc84 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4167,6 +4167,116 @@ static struct board_info __initdata boar
+@@ -4168,6 +4168,116 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4656,6 +4766,7 @@ static const struct board_info __initcon
+@@ -4657,6 +4767,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index f23ba8594d2a50461ecf3848053722fb80abaf39..d97a5f9af53b3b2e888c86b4d1021c1171fd655d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4277,6 +4277,116 @@ static struct board_info __initdata boar
+@@ -4278,6 +4278,116 @@ static struct board_info __initdata boar
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4767,6 +4877,7 @@ static const struct board_info __initcon
+@@ -4768,6 +4878,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index cb4a17406bde45f0776e975b65310afbd4e6bf85..2facb47bded08009b400e338510e07e115fb8f1f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4176,6 +4176,96 @@ static struct sprom_fixup __initdata vr3
+@@ -4177,6 +4177,96 @@ static struct sprom_fixup __initdata vr3
        { .offset = 115, .value = 0xfad9 },
  };
  
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .expected_cpu_id                = 0x6368,
-@@ -4876,6 +4966,7 @@ static const struct board_info __initcon
+@@ -4877,6 +4967,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index e8409818f6f6abf6cd21ff2cf2c8e858027a5fc0..d2619d721f5b6c9da2253e7b2159789756d29281 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3223,6 +3223,56 @@ static struct board_info __initdata boar
+@@ -3224,6 +3224,56 @@ static struct board_info __initdata boar
        .num_spis = ARRAY_SIZE(ct6373_spi_devices),
  };
  
@@ -57,7 +57,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -4950,6 +5000,7 @@ static const struct board_info __initcon
+@@ -4951,6 +5001,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index 0d2fabcb19e42f400846cef47e8afe277bb30484..614bf3013d8c6e8e5eeed042b7f0591e4a9b8c54 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -607,6 +607,95 @@ static struct board_info __initdata boar
+@@ -608,6 +608,95 @@ static struct board_info __initdata boar
        },
  };
  
@@ -96,7 +96,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .expected_cpu_id                        = 0x6328,
-@@ -4951,6 +5040,7 @@ static const struct board_info __initcon
+@@ -4952,6 +5041,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index 6cdd3bec0c93f9661e262b2bc9dcab4eb6af904b..f4aa659e3aae6d90ccb945106e5293b828ca3486 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5034,6 +5169,7 @@ static const struct board_info __initcon
+@@ -5035,6 +5170,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index 4a1f133c8a94a4750ab98ea25e59912536cd30e2..80a57040cb2a53dee1fe53a58457a25ff5656f69 100644 (file)
@@ -5,6 +5,16 @@
 # See /LICENSE for more information.
 #
 
+define Profile/AR5381u
+  NAME:=Comtrend AR-5381u
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/AR5381u/Description
+  Package set optimized for AR-5381u.
+endef
+$(eval $(call Profile,AR5381u))
+
 define Profile/CT536_CT5621
   NAME:=Comtrend CT-536+/CT-5621
   PACKAGES:=kmod-b43 wpad-mini