[kernel] update to 2.6.27.8 and refresh patches
authorGabor Juhos <juhosg@openwrt.org>
Sat, 6 Dec 2008 09:59:55 +0000 (09:59 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 6 Dec 2008 09:59:55 +0000 (09:59 +0000)
SVN-Revision: 13528

13 files changed:
include/kernel-version.mk
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm63xx/Makefile
target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch
target/linux/olpc/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc40x/patches/003-ppc40x_simple_platform_support.patch
target/linux/ppc40x/patches/004-acadia_cuboot.patch
target/linux/ppc40x/patches/005-magicboxv1.patch
target/linux/ppc40x/patches/006-magicboxv2.patch
target/linux/ppc44x/Makefile
target/linux/x86/Makefile

index d31320020b137481ed8ca1890a7a137ab0744589..e8c84a0eaacd30dc1bcfa262df5d1beddca7df60 100644 (file)
@@ -28,8 +28,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.26.8)
   LINUX_KERNEL_MD5SUM:=05dd0d4f8f110b4219ae6ec7a36c046d
 endif
-ifeq ($(LINUX_VERSION),2.6.27.7)
-  LINUX_KERNEL_MD5SUM:=db323884c7dc46e4cd33d0d944fa59a9
+ifeq ($(LINUX_VERSION),2.6.27.8)
+  LINUX_KERNEL_MD5SUM:=cbdc1b350ef79dd323b9aeda5cf7f1b6
 endif
 
 # disable the md5sum check for unknown kernel versions
index 303fb2f1f15d37f4c308a58a2d1b35aaa157a901..d8519d776ae8f340b7f7621ca643f7208bd34896 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=au1000
 BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 
-LINUX_VERSION:=2.6.27.7
+LINUX_VERSION:=2.6.27.8
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += yamonenv
index 67524d95f15baadcdfc7846b8276abbd916968e4..ea46a321a3b96e07c5624b7478645b1ada1da76a 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.27.7
+LINUX_VERSION:=2.6.27.8
 
 include $(INCLUDE_DIR)/target.mk
 
index a45a259f0df008b6c860543842f13f669933cce5..a68583330798af4d920f3ac9d94cfed80a3e5860 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm
-LINUX_VERSION:=2.6.27.7
+LINUX_VERSION:=2.6.27.8
 
 include $(INCLUDE_DIR)/target.mk
 
index 28ffe1d36192c1b3ce49854a2199138693e413f9..243b650b62a962a21a318313a67c1e8e2a2c637c 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
 
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1040,6 +1040,11 @@ MODULE_LICENSE ("GPL");
+@@ -1039,6 +1039,11 @@ MODULE_LICENSE ("GPL");
  #define       PLATFORM_DRIVER         ixp4xx_ehci_driver
  #endif
  
index d9ec52a39a35d23d63620757d5f5d23f1917f5a7..2860feb30df49a75b7fb339d8c596425cfe66ec4 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=olpc
 BOARDNAME:=OLPC XO-1
 FEATURES:=squashfs ext2
 
-LINUX_VERSION:=2.6.27.7
+LINUX_VERSION:=2.6.27.8
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
index 163e5add9530bc995a8ce47d51613b628e5cff77..44a4af86f2a7ba14a9fc957db9e6c3e51368227c 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.27.7
+LINUX_VERSION:=2.6.27.8
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 3f07ee5e8a433d50b663322e6f13c3e17e3091b8..1f7fe7efd6a806a578cbca35618585947f768370 100644 (file)
@@ -1,5 +1,3 @@
-diff --git a/arch/powerpc/platforms/40x/Kconfig b/arch/powerpc/platforms/40x/Kconfig
-index a9260e2..72ba3a7 100644
 --- a/arch/powerpc/platforms/40x/Kconfig
 +++ b/arch/powerpc/platforms/40x/Kconfig
 @@ -14,6 +14,15 @@
@@ -45,8 +43,6 @@ index a9260e2..72ba3a7 100644
  config 405GPR
        bool
  
-diff --git a/arch/powerpc/platforms/40x/Makefile b/arch/powerpc/platforms/40x/Makefile
-index 5533a5c..1d93273 100644
 --- a/arch/powerpc/platforms/40x/Makefile
 +++ b/arch/powerpc/platforms/40x/Makefile
 @@ -3,3 +3,4 @@ obj-$(CONFIG_MAKALU)                           += makalu.o
@@ -54,9 +50,6 @@ index 5533a5c..1d93273 100644
  obj-$(CONFIG_XILINX_VIRTEX_GENERIC_BOARD)     += virtex.o
  obj-$(CONFIG_EP405)                           += ep405.o
 +obj-$(CONFIG_PPC40x_SIMPLE)           += ppc40x_simple.o
-diff --git a/arch/powerpc/platforms/40x/ppc40x_simple.c b/arch/powerpc/platforms/40x/ppc40x_simple.c
-new file mode 100644
-index 0000000..4498a86
 --- /dev/null
 +++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
 @@ -0,0 +1,80 @@
index 6c415ea655e175e5a9c827896a2d717af1ee7ab0..1962d34add6afc5ac9e6665e413b7335e5fa2852 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
-index 6403275..5f4a59c 100644
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -68,7 +68,8 @@ src-plat := of.c cuboot-52xx.c cuboot-824x.c cuboot-83xx.c cuboot-85xx.c holly.c
+@@ -68,7 +68,8 @@ src-plat := of.c cuboot-52xx.c cuboot-82
                fixed-head.S ep88xc.c ep405.c cuboot-c2k.c \
                cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
                cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
@@ -12,7 +10,7 @@ index 6403275..5f4a59c 100644
  src-boot := $(src-wlib) $(src-plat) empty.c
  
  src-boot := $(addprefix $(obj)/, $(src-boot))
-@@ -211,6 +212,7 @@ image-$(CONFIG_DEFAULT_UIMAGE)             += uImage
+@@ -211,6 +212,7 @@ image-$(CONFIG_DEFAULT_UIMAGE)             += uImag
  # Board ports in arch/powerpc/platform/40x/Kconfig
  image-$(CONFIG_EP405)                 += dtbImage.ep405
  image-$(CONFIG_WALNUT)                        += treeImage.walnut
@@ -20,9 +18,6 @@ index 6403275..5f4a59c 100644
  
  # Board ports in arch/powerpc/platform/44x/Kconfig
  image-$(CONFIG_EBONY)                 += treeImage.ebony cuImage.ebony
-diff --git a/arch/powerpc/boot/cuboot-acadia.c b/arch/powerpc/boot/cuboot-acadia.c
-new file mode 100644
-index 0000000..0634aba
 --- /dev/null
 +++ b/arch/powerpc/boot/cuboot-acadia.c
 @@ -0,0 +1,174 @@
index 4193b196c415a111568aa15c6b38b1a51e5fb30a..159e4f8a65fb0447065b2a82487d849354c5c8a6 100644 (file)
@@ -1,6 +1,5 @@
-diff -Nur a/arch/powerpc/boot/cuboot-magicboxv1.c b/arch/powerpc/boot/cuboot-magicboxv1.c
---- a/arch/powerpc/boot/cuboot-magicboxv1.c    1970-01-01 01:00:00.000000000 +0100
-+++ b/arch/powerpc/boot/cuboot-magicboxv1.c    2008-11-23 20:13:57.000000000 +0100
+--- /dev/null
++++ b/arch/powerpc/boot/cuboot-magicboxv1.c
 @@ -0,0 +1,40 @@
 +/*
 + * Old U-boot compatibility for Magicbox v1
@@ -42,9 +41,8 @@ diff -Nur a/arch/powerpc/boot/cuboot-magicboxv1.c b/arch/powerpc/boot/cuboot-mag
 +      fdt_init(_dtb_start);
 +      serial_console_init();
 +}
-diff -Nur a/arch/powerpc/boot/dts/magicboxv1.dts b/arch/powerpc/boot/dts/magicboxv1.dts
---- a/arch/powerpc/boot/dts/magicboxv1.dts     1970-01-01 01:00:00.000000000 +0100
-+++ b/arch/powerpc/boot/dts/magicboxv1.dts     2008-11-26 09:14:46.000000000 +0100
+--- /dev/null
++++ b/arch/powerpc/boot/dts/magicboxv1.dts
 @@ -0,0 +1,217 @@
 +/*
 + * Device Tree Source for Magicbox v1
@@ -263,10 +261,9 @@ diff -Nur a/arch/powerpc/boot/dts/magicboxv1.dts b/arch/powerpc/boot/dts/magicbo
 +              linux,stdout-path = "/plb/opb/serial@ef600300";
 +      };
 +};
-diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
---- a/arch/powerpc/boot/Makefile       2008-11-26 09:14:31.000000000 +0100
-+++ b/arch/powerpc/boot/Makefile       2008-11-22 21:21:01.000000000 +0100
-@@ -69,7 +69,7 @@
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -69,7 +69,7 @@ src-plat := of.c cuboot-52xx.c cuboot-82
                cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
                cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
                virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \
@@ -275,7 +272,7 @@ diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
  src-boot := $(src-wlib) $(src-plat) empty.c
  
  src-boot := $(addprefix $(obj)/, $(src-boot))
-@@ -213,6 +213,7 @@
+@@ -213,6 +213,7 @@ image-$(CONFIG_DEFAULT_UIMAGE)             += uImag
  image-$(CONFIG_EP405)                 += dtbImage.ep405
  image-$(CONFIG_WALNUT)                        += treeImage.walnut
  image-$(CONFIG_ACADIA)                        += cuImage.acadia
@@ -283,10 +280,9 @@ diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
  
  # Board ports in arch/powerpc/platform/44x/Kconfig
  image-$(CONFIG_EBONY)                 += treeImage.ebony cuImage.ebony
-diff -Nur a/arch/powerpc/platforms/40x/Kconfig b/arch/powerpc/platforms/40x/Kconfig
---- a/arch/powerpc/platforms/40x/Kconfig       2008-11-26 09:14:31.000000000 +0100
-+++ b/arch/powerpc/platforms/40x/Kconfig       2008-11-18 14:28:06.000000000 +0100
-@@ -41,6 +41,16 @@
+--- a/arch/powerpc/platforms/40x/Kconfig
++++ b/arch/powerpc/platforms/40x/Kconfig
+@@ -41,6 +41,16 @@ config KILAUEA
        help
          This option enables support for the AMCC PPC405EX evaluation board.
  
@@ -303,10 +299,9 @@ diff -Nur a/arch/powerpc/platforms/40x/Kconfig b/arch/powerpc/platforms/40x/Kcon
  config MAKALU
        bool "Makalu"
        depends on 40x
-diff -Nur a/arch/powerpc/platforms/40x/ppc40x_simple.c b/arch/powerpc/platforms/40x/ppc40x_simple.c
---- a/arch/powerpc/platforms/40x/ppc40x_simple.c       2008-11-26 09:14:31.000000000 +0100
-+++ b/arch/powerpc/platforms/40x/ppc40x_simple.c       2008-11-18 14:29:59.000000000 +0100
-@@ -51,7 +51,8 @@
+--- a/arch/powerpc/platforms/40x/ppc40x_simple.c
++++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
+@@ -51,7 +51,8 @@ machine_device_initcall(ppc40x_simple, p
   * board.c file for it rather than adding it to this list.
   */
  static char *board[] __initdata = {
index 47ddd112905f11391858634f80d2eeedf75889a7..686c0efdb6714ad77a51c49efc4315b89df10986 100644 (file)
@@ -1,6 +1,5 @@
-diff -Nur a/arch/powerpc/boot/cuboot-magicboxv2.c b/arch/powerpc/boot/cuboot-magicboxv2.c
---- a/arch/powerpc/boot/cuboot-magicboxv2.c    1970-01-01 01:00:00.000000000 +0100
-+++ b/arch/powerpc/boot/cuboot-magicboxv2.c    2008-11-26 09:29:02.000000000 +0100
+--- /dev/null
++++ b/arch/powerpc/boot/cuboot-magicboxv2.c
 @@ -0,0 +1,40 @@
 +/*
 + * Old U-boot compatibility for Magicbox v2
@@ -42,9 +41,8 @@ diff -Nur a/arch/powerpc/boot/cuboot-magicboxv2.c b/arch/powerpc/boot/cuboot-mag
 +      fdt_init(_dtb_start);
 +      serial_console_init();
 +}
-diff -Nur a/arch/powerpc/boot/dts/magicboxv2.dts b/arch/powerpc/boot/dts/magicboxv2.dts
---- a/arch/powerpc/boot/dts/magicboxv2.dts     1970-01-01 01:00:00.000000000 +0100
-+++ b/arch/powerpc/boot/dts/magicboxv2.dts     2008-11-26 09:28:10.000000000 +0100
+--- /dev/null
++++ b/arch/powerpc/boot/dts/magicboxv2.dts
 @@ -0,0 +1,250 @@
 +/*
 + * Device Tree Source for Magicbox v2
@@ -296,10 +294,9 @@ diff -Nur a/arch/powerpc/boot/dts/magicboxv2.dts b/arch/powerpc/boot/dts/magicbo
 +              linux,stdout-path = "/plb/opb/serial@ef600300";
 +      };
 +};
-diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
---- a/arch/powerpc/boot/Makefile       2008-11-26 09:15:15.000000000 +0100
-+++ b/arch/powerpc/boot/Makefile       2008-11-26 09:17:01.000000000 +0100
-@@ -69,7 +69,7 @@
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -69,7 +69,7 @@ src-plat := of.c cuboot-52xx.c cuboot-82
                cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
                cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
                virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \
@@ -308,7 +305,7 @@ diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
  src-boot := $(src-wlib) $(src-plat) empty.c
  
  src-boot := $(addprefix $(obj)/, $(src-boot))
-@@ -214,6 +214,7 @@
+@@ -214,6 +214,7 @@ image-$(CONFIG_EP405)                      += dtbImage.ep40
  image-$(CONFIG_WALNUT)                        += treeImage.walnut
  image-$(CONFIG_ACADIA)                        += cuImage.acadia
  image-$(CONFIG_MAGICBOXV1)            += cuImage.magicboxv1
@@ -316,10 +313,9 @@ diff -Nur a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
  
  # Board ports in arch/powerpc/platform/44x/Kconfig
  image-$(CONFIG_EBONY)                 += treeImage.ebony cuImage.ebony
-diff -Nur a/arch/powerpc/platforms/40x/Kconfig b/arch/powerpc/platforms/40x/Kconfig
---- a/arch/powerpc/platforms/40x/Kconfig       2008-11-26 09:15:15.000000000 +0100
-+++ b/arch/powerpc/platforms/40x/Kconfig       2008-11-26 09:16:08.000000000 +0100
-@@ -51,6 +51,16 @@
+--- a/arch/powerpc/platforms/40x/Kconfig
++++ b/arch/powerpc/platforms/40x/Kconfig
+@@ -51,6 +51,16 @@ config MAGICBOXV1
        help
          This option enables support for the Magicbox v1 board.
  
@@ -336,10 +332,9 @@ diff -Nur a/arch/powerpc/platforms/40x/Kconfig b/arch/powerpc/platforms/40x/Kcon
  config MAKALU
        bool "Makalu"
        depends on 40x
-diff -Nur a/arch/powerpc/platforms/40x/ppc40x_simple.c b/arch/powerpc/platforms/40x/ppc40x_simple.c
---- a/arch/powerpc/platforms/40x/ppc40x_simple.c       2008-11-26 09:15:15.000000000 +0100
-+++ b/arch/powerpc/platforms/40x/ppc40x_simple.c       2008-11-26 09:15:46.000000000 +0100
-@@ -52,7 +52,8 @@
+--- a/arch/powerpc/platforms/40x/ppc40x_simple.c
++++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
+@@ -52,7 +52,8 @@ machine_device_initcall(ppc40x_simple, p
   */
  static char *board[] __initdata = {
        "amcc,acadia",
index 65987c5403b1932074bfb597a581cda912b875d1..1e5639735e066540dca5b341b785ef189bb31f5e 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.27.7
+LINUX_VERSION:=2.6.27.8
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 37d94fd7c7f1bada15fe8b7168e3d1bfebba4c4d..30104153f55aa157f332a7c203642bbeea230ec8 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2 vdi vmdk
 SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.27.7
+LINUX_VERSION:=2.6.27.8
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci