targets: remove useless quotes around KERNELNAME
authorFelix Fietkau <nbd@openwrt.org>
Sun, 5 Oct 2014 20:17:19 +0000 (20:17 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 5 Oct 2014 20:17:19 +0000 (20:17 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 42780

26 files changed:
target/linux/avr32/Makefile
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/cns21xx/Makefile
target/linux/cns3xxx/Makefile
target/linux/ep93xx/Makefile
target/linux/gemini/Makefile
target/linux/imx6/Makefile
target/linux/iop32x/Makefile
target/linux/ipq806x/Makefile
target/linux/ixp4xx/Makefile
target/linux/kirkwood/Makefile
target/linux/mcs814x/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/mvebu/Makefile
target/linux/mxs/Makefile
target/linux/omap/Makefile
target/linux/omap24xx/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/pxa/Makefile
target/linux/realview/Makefile
target/linux/realview/image/Makefile
target/linux/sunxi/Makefile

index de5410309e25a2c6b2dfef4e8bbb9b956ff30732..cd8bd5e60d59617effa8bd97286d6b4bcbf129f5 100644 (file)
@@ -20,6 +20,6 @@ define Target/Description
   Build firmware images for ATNGW100 board
 endef
 
-KERNELNAME:="uImage"
+KERNELNAME:=uImage
 
 $(eval $(call BuildTarget))
index 519b5a553065e9068da14519cfc87f09dcf6bafc..69f30f84ec99e220147dbebc10eb4cd51f5505db 100644 (file)
@@ -22,7 +22,7 @@ define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 DEFAULT_PACKAGES += swconfig wpad-mini nvram \
        kmod-gpio-button-hotplug \
index 0779e61252a9c3c8b153c7923200c87da7760a34..c8a55369349ba45ffc70908a7f24bb0dd906caa1 100644 (file)
@@ -25,6 +25,6 @@ define Target/Description
        Currently produces SD Card image for Raspberry Pi.
 endef
 
-KERNELNAME="Image"
+KERNELNAME:=Image
 
 $(eval $(call BuildTarget))
index 4f320b2f29a04185944f2801bccbfefc2100d0aa..a183a21b865f2586e53dd44266421ab5549ddaa5 100644 (file)
@@ -24,6 +24,6 @@ define Target/Description
  Build firmware images for Cavium Networks CNS21XX based boards.
 endef
 
-KERNELNAME:="zImage uImage"
+KERNELNAME:=zImage uImage
 
 $(eval $(call BuildTarget))
index 7508240caa5571b35e56decdc63b3dd33e75f4cf..dd5349cd6f6264f74cf8bd804aaacb744c7e4f31 100644 (file)
@@ -23,7 +23,7 @@ define Target/Description
        eg. the Gateworks Laguna family
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
 
index debb8e99ae93f44628e2797946506f90f15e27ef..ad7fb31bd30716d47d052c3ec5f8e8f3eeef8098 100644 (file)
@@ -19,6 +19,6 @@ DEVICE_TYPE:=developerboard
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:=uImage
 
 $(eval $(call BuildTarget))
index 6a6c0a74505ec6ff2dec69c0b18e570c2c6d85e5..45ae97ef9189ad631f920ed0b880e523c3f20c6e 100644 (file)
@@ -15,7 +15,7 @@ MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.10.49
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
index 1e64fd7bce927e292824a8ec68092574ca49fe17..c29187cb35131bf43fbe8d826b760a5047f7c22c 100644 (file)
@@ -18,6 +18,6 @@ LINUX_VERSION:=3.14.18
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 $(eval $(call BuildTarget))
index 8c66387e6b28b7af5359a63f028b94e12a9448ed..02037d9837a6148b01badc2281449e53eb97c40e 100644 (file)
@@ -16,6 +16,6 @@ LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))
index 6207c9126fead2d169bd3d459399331b32479086..55a0d72f7ddd04ba0b669ec628d71302e68975d3 100644 (file)
@@ -11,7 +11,7 @@ MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 LINUX_VERSION:=3.14.18
 
-KERNELNAME="Image dtbs"
+KERNELNAME:=Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 
index b0665db0510c86ece725547b85f6097bc250dbfa..2b249dc85591901da599b965e0c71ef6b8ce05c5 100644 (file)
@@ -18,6 +18,6 @@ LINUX_VERSION:=3.10.49
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += ixp4xx-microcode fconfig
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))
index 33c33a4d6f6476c6115e639e931aa52197d51756..4b6d841de2f4a8cdc0fd474175f7f2bce64a0588 100644 (file)
@@ -17,6 +17,6 @@ LINUX_VERSION:=3.14.18
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 $(eval $(call BuildTarget))
index 6b1b40e486f67d16783d24d774d2b0f58e634c82..25c778afa6ab71c89bad3883327427b6df18ad5c 100644 (file)
@@ -26,6 +26,6 @@ DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES)) \
                  kmod-nls-utf8 \
                  kmod-mcs814x-wdt kmod-ledtrig-usbdev
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 $(eval $(call BuildTarget))
index a9657730783482416c843e304965d5ec2df7f36f..56f655a31e88b87b267b748dcc3dbe5cc2a96e00 100644 (file)
@@ -20,6 +20,6 @@ define Target/Description
        Build images for the Freescale MPC52xx based boards.
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))
index 915faec2dfec5d592d8c3535be7132dc0213102c..806b8f6e4e53e46998140f4a7221a43d8b304516 100644 (file)
@@ -23,6 +23,6 @@ define Target/Description
        Build firmware images for Freescale MPC83xx based boards (eg. RouterBoard 600).
 endef
 
-KERNELNAME:="uImage dtbImage.rb600 dtbImage.rb333"
+KERNELNAME:=uImage dtbImage.rb600 dtbImage.rb333
 
 $(eval $(call BuildTarget))
index b899d63007903930ac4299ea0e19508db8c23458..dc61e7c2c170894956c5ac32db8b7d7ab82f2602 100644 (file)
@@ -18,7 +18,7 @@ LINUX_VERSION:=3.14.18
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 DEFAULT_PACKAGES += uboot-envtools
 
index 7a5730b76100f80fb2b75f7dd126ce4025e74e95..9f950959b841993c37a0650e9abdf070966682ed 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=arm926ej-s
 
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 LINUX_VERSION:=3.14.18
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 define Target/Description
        Support for Freescale i.MX23/i.MX28 boards
index 5795c002d8c7b98777c798914f126b802e4bd8e0..3ebfccddc32eab89a610de676d303b2a1f026534 100644 (file)
@@ -17,7 +17,7 @@ LINUX_VERSION:=3.13.7
 
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 include $(INCLUDE_DIR)/target.mk
 
index f8cd3c51153e69748ab3e95818f6566bd29794aa..40ad342bed50fc9dced584b3c6e3082a713810b4 100644 (file)
@@ -19,7 +19,7 @@ define Target/Description
        TI OMAP-24xx
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
index a38b74fe4d946415d33f24ab051b395b88337b4b..ec40a00d18dec2c9cfce7f92d7e714d480c7e423 100644 (file)
@@ -16,7 +16,7 @@ LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 DEFAULT_PACKAGES += kmod-ath9k kmod-crypto-mv-cesa wpad-mini kmod-i2c-core kmod-i2c-mv64xxx kmod-rtc-isl1208
 
index 817abc7f49a7be5a0faf7c7f36b3f928a4ff8b05..00e8d4322cd8d850e5205d46a74f7dca230f7123 100644 (file)
@@ -21,6 +21,6 @@ define Target/Description
        Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
-KERNELNAME:="uImage cuImage.magicbox cuImage.openrb"
+KERNELNAME:=uImage cuImage.magicbox cuImage.openrb
 
 $(eval $(call BuildTarget))
index f6d932743a0b0112862a934ddf70114de1cb0b9c..5c2e15da2abf7e41f650b552e038d64f8e6ccfab 100644 (file)
@@ -23,6 +23,6 @@ define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
-KERNELNAME:="uImage cuImage.taishan"
+KERNELNAME:=uImage cuImage.taishan
 
 $(eval $(call BuildTarget))
index 86e4950f1e98cbf1ec285c2cb9d5c5edd1aadb26..c61231daf7a9adc19991a46358981b045fd9ad91 100644 (file)
@@ -20,6 +20,6 @@ define Target/Description
        Build images for PXA2xx systems, eg. Gumstix.
 endef
 
-KERNELNAME:="uImage"
+KERNELNAME:=uImage
 
 $(eval $(call BuildTarget))
index 3d49605130817c9fd7a007a22774d201f894909a..80892075b0999366e4332975f93b1c4bdbf91c57 100644 (file)
@@ -24,6 +24,6 @@ define Target/Description
        Build images for ARM Ltd. Realview boards to be run with qemu
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))
index c6ff8ce46a86d8fd3949322bd619a82ae74dfdf4..1f3fa4a664a6298e66ebb96ae0482387f77f4cb5 100644 (file)
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/BuildKernel
-       cp $(KDIR)/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+       cp $(KDIR)/$(KERNELNAME) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
 endef
 
 define Image/BuildKernel/Initramfs
-       cp $(KDIR)/$(subst ",,$(KERNELNAME))-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
+       cp $(KDIR)/$(KERNELNAME)-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
 endef
 
 define Image/Build/squashfs
index 4f59f3ef91b78a80ea303dfa38aede596f88942e..e96f0815b4f6ae12bcbfdbc9c901024275d040c4 100644 (file)
@@ -16,7 +16,7 @@ CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
 LINUX_VERSION:=3.14.18
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 DEFAULT_PACKAGES += uboot-envtools uboot-sunxi kmod-eeprom-sunxi kmod-wdt-sunxi
 
 # A10: Cortex-A8